Thread: install - new

Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2019
    Location
    florida
    Posts
    22
    Plugin Contributions
    0

    Default install - new

    I am trying to install zc into my site on thecottoncabana.com and I get as far as the Prerequisites an it says:

    CURL problems detected: 0 => [ 301 Moved Permanently Moved Permanently The document has moved here. ] and

    MySQL Support = OFF Click here for more info

    click here does nothing and I cannot install the cart. please help!!!!

  2. #2
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    9,556
    Plugin Contributions
    121

    Default Re: install - new

    You may need to upgrade your account - call your hoster.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  3. #3
    Join Date
    Jun 2019
    Location
    florida
    Posts
    22
    Plugin Contributions
    0

    Default Re: install - new

    Quote Originally Posted by swguy View Post
    You may need to upgrade your account - call your hoster.
    I have talked with bluehost. they upgraded my php from 7.0 to 7.3 and I am still getting these:
    ATTENTION: Problems Found

    CURL problems detected: 0 => [ 301 Moved Permanently Moved Permanently The document has moved here. ] and

    System Inspection Results
    Webserver = Apache
    HTTP Host = thecottoncabana.com
    Path_Translated = /home1/thecoty4/public_html/catalog/zc_install/index.php(SCRIPT_FILENAME)
    Real Path = /home1/thecoty4/public_html/catalog
    Server Free Disk Space = 1163.36 GB
    PHP O/S = Linux
    PHP API Mode = cgi-fcgi
    PHP Max Execution Time per page = 30
    MySQL Support = OFF Click here for more info
    PHP Version = 7.3.6
    PHP Version = 7.3.6
    PHP Sessions Support = ON
    PHP Session.AutoStart = OFF
    PHP session.use_trans_sid = OFF
    Suggested SQL Cache Folder = /home1/thecoty4/public_html/catalog/cache
    PHP GD Support = ON
    GD Version = GD bundled (2.1.0 compatible)
    PHP ZLIB Compression Support = ON
    PHP OpenSSL Support = ON
    PHP cURL Support = ON
    CURL NON-SSL Capability = CURL problems detected: 0 => [
    Moved Permanently
    The document has moved here.
    ] Click here for more info
    CURL SSL Capability = Okay
    PHP Upload Support = ON upload_max_filesize=256M; post_max_size=260M
    PHP Upload TMP dir =
    Apache .htaccess Support = ON

    note: it says my sql support is off, they say it does not turn off. how do I fix this?

  4. #4
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    9,090
    Plugin Contributions
    10

    Default Re: install - new

    What do you get when you click on the mysql support "Click here for more info."

  5. #5
    Join Date
    Jun 2019
    Location
    florida
    Posts
    22
    Plugin Contributions
    0

    Default Re: install - new

    it does nothing when I click it

  6. #6
    Join Date
    Jul 2012
    Posts
    16,703
    Plugin Contributions
    17

    Default Re: install - new

    This error, while reporting an issue with "mysql" is really a result of failing the test for the extension mysqli. Note the i at the end. The specific test via php is
    Code:
    extension_loaded('mysqli');
    Could create a file at the root of your domain (e.g. mysqli_test.php) with the following code and request bluehost to access it while they attempt to resolve the issue:
    Code:
    <?php
    
    echo 'mysqli extension is loaded: ' . (extension_loaded('mysqli') ? 'true' : 'false');
    You could also add to that a call to show all of the php info related to the server by adding the following on a new line at the end of the above:
    Code:
    echo phpinfo();
    Which will show the extensions installed among many other characteristics of the php installation.
    Last edited by mc12345678; 19 Jun 2019 at 11:33 AM.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  7. #7
    Join Date
    Jun 2019
    Location
    florida
    Posts
    22
    Plugin Contributions
    0

    Default Re: install - new

    can I install a lower version since it still does not work. Bluehost has added every thing that you suggested. they said the server php is 7.0 but increased mine to 7.3 then we trie it at 7.2. still no go. so I don't know it wont work. they said they cannot change the server php due to the fact it is shared.

  8. #8
    Join Date
    Jul 2012
    Posts
    16,703
    Plugin Contributions
    17

    Default Re: install - new

    You can try Zen Cart version 1.5.5f, but it performs the same check for the same extension and therefore may have the same result.

    There *ARE* others here that use bluehost to successfully run Zen Cart.

    What were the results of the above test and have you shared this thread with bluehost?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  9. #9
    Join Date
    Jun 2019
    Location
    florida
    Posts
    22
    Plugin Contributions
    0

    Default Re: install - new

    I deleted everything and reinstalled version 1.5.6a and it is working really good.

  10. #10
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    9,556
    Plugin Contributions
    121

    Default Re: install - new

    Before you get too far, I'd encourage you to back up your configure files, wipe the slate and install 1.5.6b. HUNDREDS of improvements over 1.5.6a.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

 

 

Similar Threads

  1. Host install (create new DB and migrate data) or manual install (point to old DB)?
    By kirkbross in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 25 Nov 2012, 09:11 PM
  2. Replies: 16
    Last Post: 15 Aug 2012, 12:40 PM
  3. New install which version should I install?
    By Marlake in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 26 Jul 2011, 03:54 AM
  4. How do i install a mod to a new zen install?
    By Dave D in forum General Questions
    Replies: 10
    Last Post: 23 Apr 2011, 11:44 PM
  5. Doing new install get 3 warnings on install page
    By gws76 in forum Installing on a Linux/Unix Server
    Replies: 6
    Last Post: 23 Aug 2007, 12:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR