Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2009
    Posts
    40
    Plugin Contributions
    0

    Default Cloned Zone Shipping has stopped working in 1.5.6c

    Hey, I'm having a really big headache with my cloned 'Zone Shipping' module.

    I have three different zone shipping options.

    When they select the first, everything works as normal.

    But when I select the second or third shipping zone, and then click 'Continue,' nothing happens. It keeps just going back to the select shipping options page. It refreshes, but it does not go forward.

    I have tried using the 'Multiple Shipping Zones' plugin, but same thing. I have tried remaking the module PHP files from the zones.php in 1.5.6c, changing all instances of 'zones,' but same thing.

    It can calculate the prices, and the payment process does work if I first go to PayPal, enter my details, and then come back to my site.

    Nothing is being output to /logs/ or the Apache logs file. Everything is configured properly for these zones on the admin panel. switch to the default theme, the same behavior occurs. I'm not sure how long it's been doing this, but I think it's since I upgraded to 1.5.6c.

    Has anyone had anything like this? Any insight into what the issue might be, how to proceed? I'm at my wits end.

    1.5.6c. No plugins. 7.3.8PHP, running on a fully updated Ubuntu 18.04.3.

    The site is http://hyosungsource.com.

    Thank you so much for your help.

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,089
    Plugin Contributions
    72

    Default Re: Cloned Zone Shipping has stopped working in 1.5.6c

    You could have PHP notices that identify the source of your issue(s). Try installing Report All Errors, configuring to report storefront IgnoreDups and to include backtrace on PHP notices.

    I believe that you'll be surprised at what you see.

  3. #3
    Join Date
    Mar 2009
    Posts
    40
    Plugin Contributions
    0

    Default Re: Cloned Zone Shipping has stopped working in 1.5.6c

    Awesome, thanks so much!

    Installing this, I was able to grep the logs directory and found the following:

    "Undefined variable: small in includes/modules/pages/checkout_shipping/header_php.php on line 156."

    I had called this module 'small_package,' and it seems that it was being truncated to just 'small' somehow. I'm not sure how this was happening.

    But I just recreated the module calling it 'smallPackage' instead and now everything is working perfectly. Appreciate your help so much

  4. #4
    Join Date
    Jul 2012
    Posts
    14,545
    Plugin Contributions
    17

    Default Re: Cloned Zone Shipping has stopped working in 1.5.6c

    Quote Originally Posted by buddhaflow View Post
    Awesome, thanks so much!

    Installing this, I was able to grep the logs directory and found the following:

    "Undefined variable: small in includes/modules/pages/checkout_shipping/header_php.php on line 156."

    I had called this module 'small_package,' and it seems that it was being truncated to just 'small' somehow. I'm not sure how this was happening.

    But I just recreated the module calling it 'smallPackage' instead and now everything is working perfectly. Appreciate your help so much
    In evaluating the submitted shipping information, the information following the underscore is used to identify the method within the module that was chosen where the module is identified by the information before the underscore. This is why/how small was identified as the module instead of the intended small_package... :)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

 

 

Similar Threads

  1. v151 Cloned table shipping module not showing zone selector
    By earmsby in forum Built-in Shipping and Payment Modules
    Replies: 4
    Last Post: 17 Oct 2013, 06:29 PM
  2. Ez slider has stopped working!!!
    By rainbow_pixie_star in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 26 Apr 2012, 02:32 PM
  3. Paypal has stopped working?
    By rainbow_pixie_star in forum General Questions
    Replies: 6
    Last Post: 17 Apr 2012, 11:16 AM
  4. Replies: 18
    Last Post: 28 Apr 2010, 05:02 AM
  5. Error installing cloned zone shipping module
    By shocker in forum Built-in Shipping and Payment Modules
    Replies: 11
    Last Post: 16 Aug 2007, 04:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR