Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2010
    Posts
    897
    Plugin Contributions
    0

    Default Is v154 compatible with PHP 5.6?

    Hi,

    I'm doing some upgrades on my VPS (to EA4 and WHM v78). However, the server is currently running PHP 5.3 which is not available on EA4. I would like to just bump up to PHP 5.6 but I'm worried about breaking my Zen Cart.

    Is v154 compatible with PHP 5.6?

    If not, what is the highest PHP that *is* compatible with ZC 154?

    Thanks,
    Mike

  2. #2
    Join Date
    Jan 2004
    Posts
    65,315
    Blog Entries
    7
    Plugin Contributions
    228

    Default Re: Is v154 compatible with PHP 5.6?

    https://www.zen-cart.com/content.php...o-run-zen-cart

    As far as I recall, we tweaked v154 for PHP 5.6. But it's very possible that there's been bugfixes in later versions that are directly related to PHP 5.6. Sorry it too far back to accurately enumerate such a list of possible later issues.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Apr 2010
    Posts
    897
    Plugin Contributions
    0

    Default Re: Is v154 compatible with PHP 5.6?

    So... probably not a good idea to go to 5.6.

    What about 5.5 or 5.4? I'm not sure what the minimum is for EA4, but 5.3 (where the server is now) is really old.

  4. #4
    Join Date
    Jul 2012
    Posts
    14,802
    Plugin Contributions
    17

    Default Re: Is v154 compatible with PHP 5.6?

    Quote Originally Posted by Feznizzle View Post
    So... probably not a good idea to go to 5.6.

    What about 5.5 or 5.4? I'm not sure what the minimum is for EA4, but 5.3 (where the server is now) is really old.
    Again, from the link provided by DrByte
    Zen Cart v1.5.4 is designed for PHP 5.5 and PHP 5.6 (and is compatible with PHP 5.3.7* and PHP 5.4 if posted bugfixes are researched and applied)
    As to things done later to support php 5.6, there is this thread on the 1.5.4 release: http://www.zen-cart.com/showthread.p...s)-with-v1-5-4

    And then there are possibly some other things that have been changed in later versions that were done to address php 5.6.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Apr 2010
    Posts
    897
    Plugin Contributions
    0

    Default Re: Is v154 compatible with PHP 5.6?

    Oh my gosh, totally missed that link! Thank you so much, MC! And DrB!!!

 

 

Similar Threads

  1. v150 v1.5.0 with PHP 5.4.19 : compatible ?
    By vandiermen in forum General Questions
    Replies: 1
    Last Post: 18 Sep 2013, 11:40 PM
  2. v151 Compatible with PHP 5.4.12?
    By fright-rags in forum General Questions
    Replies: 4
    Last Post: 13 Mar 2013, 08:10 PM
  3. Is Version 1.3.9d Compatible with PHP 5.3.3?
    By kailas in forum General Questions
    Replies: 8
    Last Post: 16 Aug 2010, 03:26 PM
  4. Zencart 1.3.7 compatible with PHP 5?
    By BEatMaKeR in forum General Questions
    Replies: 3
    Last Post: 17 Jul 2010, 04:25 AM
  5. Is 1.3.8 compatible with php 5??????
    By aly22 in forum General Questions
    Replies: 3
    Last Post: 20 Feb 2009, 11:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR