Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2007
    Location
    Manitou Beach, Michigan
    Posts
    317
    Plugin Contributions
    0

    Default PHP Error - Verison problem?

    HI Folks,
    hope you had a Happy Thanksgiving
    I can get to some of the info since I am locked, out of admin also with this error below.

    I believe cart ver. is 1.50

    http://www.ckbarrymores.com/CKSt0rE!/

    "Call to undefined function: mysql_connect(). Please install the MySQL Connector for PHP"

    My web hosting company came back with this reply.

    Your site is currently using PHP 7.3. It is possible that downgrading PHP to 5.4 will resolve the issue, but you will want to rework the site's code to use the PDO Mysql extension so that it will be compatible with more current PHP versions. I've included some additional information below that you may find helpful:

    I would like to know what is the best way to resolve the problem other than install a new cart.
    Thank You,
    Mark

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,102
    Plugin Contributions
    72

    Default Re: PHP Error - Verison problem?

    You can determine the site's current Zen Cart version by inspecting the file /includes/version.php. If, as you surmise, the site is running Zen Cart 1.5.0, then the webhost's upgrade to PHP 7.3 is absolutely the underlying issue. Zen Cart, starting with v1.5.4, has converted to use the more current MySQL interface routines.

    Ask your webhost to down-level your PHP version to PHP 5.4 so that your store can continue operations while you plan your upgrade from a version that was released December 30, 2011.

  3. #3
    Join Date
    Jul 2012
    Posts
    14,563
    Plugin Contributions
    17

    Default Re: PHP Error - Verison problem?

    There will be a few other things that likely will need to be applied after the downgrade to PHP 5.4 while working on the upgrade by rebuild of the store. There were some cache and session related fixes needed back in the day to support PHP 5.4 on the older Zen Cart systems. There are a number of other security fixes as well, but temporary operation may be sufficient while truly working on the upgrade.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

 

 

Similar Threads

  1. Replies: 2
    Last Post: 4 Jul 2014, 11:03 AM
  2. Add-On Install Problem - Error 406 with sqlpatch.php
    By MichaelD in forum All Other Contributions/Addons
    Replies: 8
    Last Post: 18 Mar 2011, 03:24 AM
  3. Replies: 3
    Last Post: 13 Mar 2009, 05:20 PM
  4. configure.php error problem
    By Pauline in forum General Questions
    Replies: 3
    Last Post: 21 Jun 2006, 02:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR