Thread: version php

Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2007
    Location
    Manitou Beach, Michigan
    Posts
    317
    Plugin Contributions
    0

    Default version php

    HI Folks,
    Hope all is well with you all.
    A general question if I may. I have a number of older carts running 1.5, 1.5.1, 1.5.3.
    Recently my hosting company upgraded my php version to 7.3 which to a number of my carts down for PHP errors.
    Example
    Call to undefined function: mysql_connect(). Please install the MySQL Connector for PHP

    Having them revert the PHP version back to 5.4 brought them back. They warn of security problems with 5.4 and suggest getting it back to 7.3 as soon as possible. Is there any changes I can make to the existing carts to accept 7.3?
    As always thanks for the help.
    Mark

  2. #2
    Join Date
    Jan 2004
    Posts
    65,414
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: version php

    Sounds like it's time to upgrade your Zen Cart versions (and addons) in order to support modern PHP versions.

    Reference: Server Requirements for Zen Cart

    PHP dropped mysql_xxxx functions in favor of mysqli_xxxxx functions several years ago. Zen Cart made corresponding changes as well. You may have addons that need to make the same change ... along with other PHP modernization changes.

    I've made some related posts over the years to summarize some technical considerations when modernizing PHP code. The latest is here, which contains links to prior posts: https://www.zen-cart.com/entry.php?9...eady-for-PHP-7
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    May 2014
    Posts
    65
    Plugin Contributions
    0

    Default Re: version php

    You surely have to upgrade the Zen Cart to latest edition (1.5.6c) ASAP!

    ... and why PHP 5.4? That version had been "discontinued" since 2015.
    (The last PHP 5 version is 5.6.40, which you should had been using if you were in PHP 5.)

    You will need to read this article to ensure that you can upgrade your multiple sites of Zen Cart while keep data intact
    (along with keep website alive until upgrade is ready to go)

    https://www.zen-cart.com/entry.php?3...d-of-upgrading

    It can be rough for the first time going through this, but once you get the whole progress, you will know what to do.

 

 

Similar Threads

  1. v139h PHP Version
    By stevens157 in forum General Questions
    Replies: 1
    Last Post: 4 Feb 2014, 08:00 PM
  2. Php version
    By Doodlebuckets in forum General Questions
    Replies: 1
    Last Post: 5 Sep 2013, 10:25 PM
  3. Replies: 1
    Last Post: 31 Aug 2012, 06:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR