Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2010
    Posts
    232
    Plugin Contributions
    1

    Default PHP Fatal error: require(): Failed opening required ''

    redsautorehab.com/test
    php 7.0.33
    Tableau2 template

    I was running 1.5.4, and my host recently changed php on me, and they are only allowing me to use php 7.0, 7.2, and 7.3, so I am having to upgrade, because checkout isn't working.

    On the test site, it only works with the classic template. I have tried three different templates, and the pages don't load properly. This is the current error:
    [06-Dec-2019 18:41:39 UTC] Request URI: /test/index.php?main_page=index&cPath=13_1, IP address: 75.167.190.4
    #1 require() called at [/home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php:179]
    #2 require(/home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php) called at [/home1/redsauto/public_html/test/index.php:97]
    --> PHP Warning: require(): Filename cannot be empty in /home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php on line 179.

    [06-Dec-2019 18:41:39 UTC] Request URI: /test/index.php?main_page=index&cPath=13_1, IP address: 75.167.190.4
    #1 require() called at [/home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php:179]
    #2 require(/home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php) called at [/home1/redsauto/public_html/test/index.php:97]
    --> PHP Warning: require(): Filename cannot be empty in /home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php on line 179.

    [06-Dec-2019 18:41:39 UTC] PHP Fatal error: require(): Failed opening required '' (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home1/redsauto/public_html/test/includes/templates/tableau2/common/tpl_main_page.php on line 179
    Lines 174-180 of tpl_main_page.php
    Code:
    			<?php
    				/**
    				 * prepares and displays center column
    				 *
    				 */
    				require($body_code);
    			?>
    I tried the developers toolkit, and can't really tell what the body_code is referencing.



    Also, the current issue with my 1.5.4, is the only payment method working, is paypal express checkout button. If I sign in, and select any other payment method, I get this message, "Please select a payment method for your order." Nothing in the log file. It was having fatal php errors with Paypal, which were causing a white screen, so I installed the paypal files from 1.5.6, and no longer have the white screen, but I have this.

  2. #2
    Join Date
    Jul 2012
    Posts
    15,130
    Plugin Contributions
    17

    Default Re: PHP Fatal error: require(): Failed opening required ''

    This would appear to be an issue related to version(s) of Zen Cart and template compatibility.

    The template modified the tpl_main_page.php file to incorporate something specific for the template. To find what that is, compare the template's version against the Zen Cart's default version for the compatible version of Zen Cart. Ie. If written for Zen Cart 1.5.4, then compare the template override file against the template_default version available in Zen Cart 1.5.4. That difference should then be applied to a copy from your current Zen Cart version.

    As it stands at the moment, the variable $body_code is not defined during execution based on the log file information.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  3. #3
    Join Date
    Apr 2010
    Posts
    232
    Plugin Contributions
    1

    Default Re: PHP Fatal error: require(): Failed opening required ''

    Numinix claims that this template works with 1.5.6, and I get the same error with the Westminster New template.

  4. #4
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,191
    Plugin Contributions
    96

    Default Re: PHP Fatal error: require(): Failed opening required ''

    Right above the require do

    die($body_code);

    run it once to see the output, then remove the die() statement. That will tell you what's missing.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  5. #5
    Join Date
    Apr 2010
    Posts
    232
    Plugin Contributions
    1

    Default Re: PHP Fatal error: require(): Failed opening required ''

    I gave up on other templates, and went live with responsive classic. I will experiment a little with my spare time, to try to figure it out.

 

 

Similar Threads

  1. Fatal Error: Failed opening required 'includes/application_top.php'
    By WeebleSue in forum Installing on a Linux/Unix Server
    Replies: 18
    Last Post: 24 Oct 2007, 03:38 AM
  2. Replies: 0
    Last Post: 20 Feb 2007, 01:39 AM
  3. Replies: 43
    Last Post: 25 Oct 2006, 12:04 PM
  4. Replies: 3
    Last Post: 4 Oct 2006, 07:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR