Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27
  1. #21
    Join Date
    Jul 2012
    Posts
    14,850
    Plugin Contributions
    17

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    The why is the tighter constraints of higher php versions and that most previous software was not written to avoid notices (which are to eventually become errors as reported by php).

    Would suggest either providing a copy of the code in this area and/or comparing to almost any of the other shipping modules provided with the ZC core shipping modules to see how such not yet defined variables are handled.

    It may also be that the module needs to be reinstalled (from within admin->modules->shipping) to ensure that the database has the latest configuration values incorporated...

    May also want to identify which fedex module (ie. Link to the plugin) is being used and verify that it is up-to-date with the latest.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  2. #22
    Join Date
    Feb 2009
    Location
    atlanta GA
    Posts
    168
    Plugin Contributions
    0

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    Quote Originally Posted by mc12345678 View Post
    The why is the tighter constraints of higher php versions and that most previous software was not written to avoid notices (which are to eventually become errors as reported by php).

    Would suggest either providing a copy of the code in this area and/or comparing to almost any of the other shipping modules provided with the ZC core shipping modules to see how such not yet defined variables are handled.

    It may also be that the module needs to be reinstalled (from within admin->modules->shipping) to ensure that the database has the latest configuration values incorporated...

    May also want to identify which fedex module (ie. Link to the plugin) is being used and verify that it is up-to-date with the latest.
    Oh sorry about that I used this version , 1.5.2 from https://www.zen-cart.com/downloads.php?do=file&id=1784 . Its also interesting that the plugin section calls its version 1.5.4 but when its installed its 1.5.2. The plugins say its compatible with v1.3.8, v1.3.9, v1.5.0, v1.5.1, v1.5.2, v1.5.3, v1.5.4, v1.5.5. Which I can't understand is why it worked before i nuked everything for the newer version of ceon. I wasn't getting these mydebug errors before.

    Providing a copy of the code ? I honestly don't know what file to show code from. I uninstalled it from admin and then reinstalled it. I also tried copying over a new set of the files i downloaded. Same issue It seems to still work. I guess these are just notices like you said. It still allows for checkout and for giving shipping pricing.

  3. #23
    Join Date
    Feb 2009
    Location
    atlanta GA
    Posts
    168
    Plugin Contributions
    0

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    okay I just realized that just like ceon URI , there might be a newer version on the authors website and sure enough , Its up to 1.7.9 there with support for 1.5.6c ZC. going to scrub all the files and try the newest version. I feel so silly.

  4. #24
    Join Date
    Feb 2009
    Location
    atlanta GA
    Posts
    168
    Plugin Contributions
    0

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    nope same issue. mm back to the drawing board.

  5. #25
    Join Date
    Jul 2012
    Posts
    14,850
    Plugin Contributions
    17

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    Quote Originally Posted by jasonshanks View Post
    Oh sorry about that I used this version , 1.5.2 from https://www.zen-cart.com/downloads.php?do=file&id=1784 . Its also interesting that the plugin section calls its version 1.5.4 but when its installed its 1.5.2. The plugins say its compatible with v1.3.8, v1.3.9, v1.5.0, v1.5.1, v1.5.2, v1.5.3, v1.5.4, v1.5.5. Which I can't understand is why it worked before i nuked everything for the newer version of ceon. I wasn't getting these mydebug errors before.

    Providing a copy of the code ? I honestly don't know what file to show code from. I uninstalled it from admin and then reinstalled it. I also tried copying over a new set of the files i downloaded. Same issue It seems to still work. I guess these are just notices like you said. It still allows for checkout and for giving shipping pricing.
    The code in question would be this area as identified in the myDebug log:
    Code:
    /dreamhost/servername/salvagecrate.com/includes/modules/shipping/fedexwebservices.php on line 277.
    Would suggest providing a few lines before through a few lines after.

    Considering that previous reports dealt mostly with initial usage, not sure if operation previously included an attempt to step through the checkout and if the/a log was identified to have this warning. (yes, I was incorrect earlier in indicating that it was a notice. The mydebug log clearly says warning...)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  6. #26
    Join Date
    Mar 2006
    Posts
    9
    Plugin Contributions
    0

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    Im having similar dB issues upgrading from 1.5.5f to 1.5.6c. The upgrade dB option is not appearing when running zc_install. I've tried several times on local (winamp) and live site. I could just rewrite the 1.5.5f database into the new dB, but i have compared the 2 dB's and the tables are different. If i upload my files into new fresh install it seems to work, but all my categories and products are not installed obviously. is there another way to install my old data into the new db and keep new table structure ? or is there a way to use the SQL patches in zc_install to update the 1.5.5f db?
    everything else seems to be ok as far as i can tell, just the db im struggling to update.
    any help appreciated, i will get there in the end but have spent all weekend on this already and need to speed things up as website is down now (moving to new host). thanks in advance.
    Last edited by mushepea; 20 Jan 2020 at 08:39 AM.

  7. #27
    Join Date
    Jul 2012
    Posts
    14,850
    Plugin Contributions
    17

    Default Re: trying to upgrade zencart 1.5.5f to 1.5.6c but it seems I am a bit stuck. Please

    Quote Originally Posted by mushepea View Post
    Im having similar dB issues upgrading from 1.5.5f to 1.5.6c. The upgrade dB option is not appearing when running zc_install. I've tried several times on local (winamp) and live site. I could just rewrite the 1.5.5f database into the new dB, but i have compared the 2 dB's and the tables are different. If i upload my files into new fresh install it seems to work, but all my categories and products are not installed obviously. is there another way to install my old data into the new db and keep new table structure ? or is there a way to use the SQL patches in zc_install to update the 1.5.5f db?
    everything else seems to be ok as far as i can tell, just the db im struggling to update.
    any help appreciated, i will get there in the end but have spent all weekend on this already and need to speed things up as website is down now (moving to new host). thanks in advance.
    Not sure I follow the discussion of new versus old table structure, but there are a few key elements to the database to help identify the status of it and whether there is an update to be performed.

    One is the DB_PREFIX. That value is set/available in a few places. In the old store it can be found in both incudes/configure.php and admin/includes/configure.php. It also can be seen by review of the database when looking at all of the tables. If you happen to see say: bob_admin, john_admin, admin, and zen_admin for example then it would appear that the database has been used by at least 4 different installs though perhaps only one of those was actively used. The above demonstrates 4 different DB_PREFIX values: 'bob_', 'john_', '', and 'zen_' respectively.

    When attempting to execute zc_install, it will look to the files that are present. If the files point to a database that exists, then it will evaluate the database to see the current status of it and whether it needs updating or not. So if the files were to have a DB_PREFIX that pointed to 'sally_' using the above database set, then that would indicate that it doesn't exist and needs to be a fresh install. If the includes/configure.php file doesn't exist then there would be some amount of action necessary that might lead to a database upgrade.

    If you already know the file path on this new server because you have gone through and done an initial install, then you can use that information and whatever else has been learned to allow Zen Cart to create new configure.php files that contain the information to connect to your database that is to be updated to 1.5.6... Note, there likely will still be issues if you are only upgrading to 1.5.6a as there were database upgrade fixes applied to 1.5.6c, but perhaps you can at least get back up and running.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

 

 
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Trying to cleanup table.. Stuck.. Help..
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 11
    Last Post: 29 Mar 2015, 09:24 PM
  2. v154 Manufacturers - Is this correct - it all seems a bit odd
    By toyseller in forum Setting Up Categories, Products, Attributes
    Replies: 2
    Last Post: 19 Mar 2015, 12:24 PM
  3. i just installed zencart but i cant get it to work. please help
    By james hetfeild in forum General Questions
    Replies: 14
    Last Post: 31 Dec 2008, 06:15 PM
  4. Database upgrade stuck at 1.3.0.2 trying to get to 1.3.8
    By websokind in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 12 Dec 2007, 04:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR