Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2010
    Location
    Richmond, Virginia, United States
    Posts
    108
    Plugin Contributions
    0

    Default No images or links after migrating to 1.56c

    I just spent the better part of today fiddling around with 1.56c on a test site. Everything looked good.

    Then I moved everything up a directory to my live store. Ugh.

    Now the images, CSS, and URLs aren't working. Looking at the code, it appears they're missing a starting slash (for example, linking at "includes/templates/" instead of "/includes/templates/").

    How do I fix this?

    URL is https://www.jms-books.com

  2. #2
    Join Date
    Jan 2010
    Location
    Richmond, Virginia, United States
    Posts
    108
    Plugin Contributions
    0

    Default Re: No images or links after migrating to 1.56c

    So I got things working on the storefront, but the admin is still a mess. Not sure where to go to add that leading slash.

  3. #3
    Join Date
    Jan 2010
    Location
    Richmond, Virginia, United States
    Posts
    108
    Plugin Contributions
    0

    Default Re: No images or links after migrating to 1.56c

    Fixed. For the record, I did the following:

    * Updated my /includes/configure.php file to add "define('HTTPS_SERVER', 'https://localhost');" after "define('HTTP_SERVER', 'https://localhost');"

    * Added "<base href="https://localhost/" />" to the /admin/includes/html_header.php file after the metadata.

  4. #4
    Join Date
    Dec 2009
    Location
    Amersfoort, The Netherlands
    Posts
    2,873
    Plugin Contributions
    25

    Default Re: No images or links after migrating to 1.56c

    Quote Originally Posted by jmsnyder23 View Post
    Fixed. For the record, I did the following:

    * Updated my /includes/configure.php file to add "define('HTTPS_SERVER', 'https://localhost');" after "define('HTTP_SERVER', 'https://localhost');"

    * Added "<base href="https://localhost/" />" to the /admin/includes/html_header.php file after the metadata.
    Not knowing where you got your Zen Cart file set from, but "/admin/includes/html_header.php" is not included in the default Zen Cart file set.

  5. #5
    Join Date
    Jan 2004
    Posts
    65,400
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: No images or links after migrating to 1.56c

    Quote Originally Posted by jmsnyder23 View Post
    So I got things working on the storefront, but the admin is still a mess. Not sure where to go to add that leading slash.
    I suspect when you "moved up a directory" you removed the leading slash in your DIR_xxxx defines in configure.php. But you didn't post the file so it's hard to comment on it. You'll find an example in dist-configure.php
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  6. #6
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,593
    Plugin Contributions
    3

    Default Re: No images or links after migrating to 1.56c

    Quote Originally Posted by Design75 View Post
    Not knowing where you got your Zen Cart file set from, but "/admin/includes/html_header.php" is not included in the default Zen Cart file set.
    hard to imagine a purchased theme would modify the admin headers; but you never know.

    that said, i think the site looks great. obviously personal preference, but i wish the default ZC theme looked like the theme used here (yourstore from theme forest).

    you mighty want to change the text in the about box:

    "No more need to look for other ecommerce themes. We provide huge number of different layouts. Yourstore comes packed with free and useful features developed to make your website creation easier... "

    best.
    practice #socialdistancing #staysafe
    email is hard....
    help out with the green....

 

 

Similar Threads

  1. v139h 404 error after migrating
    By darkusblack in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 15 Jun 2015, 03:22 AM
  2. White Pages after migrating
    By blackwolf in forum General Questions
    Replies: 4
    Last Post: 2 Aug 2010, 02:11 AM
  3. Errors After Migrating To A New Server
    By svakanda in forum General Questions
    Replies: 3
    Last Post: 16 Jun 2009, 09:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR