Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    Join Date
    Aug 2009
    Posts
    369
    Plugin Contributions
    0

    Default Investigating new_product_preview blank page from admin when insert new product

    Hi,

    On my test environment, when I try to add a new product to a category and try preview button, I can see only admin menus and blank content after. When I try doing this for products already existing, works fine.

    Example page:

    https://www.mysite/shopname/admin/pr...roduct_preview

    No log files on log directory or cache directory. I have tried activating STRICT_ERROR_REPORTING but I believe is not working on admin side.

    Can you please give some hints how to debug this ?

    thank you

  2. #2
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,190
    Plugin Contributions
    96

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    My guess would be that there's a SQL error occurring. See if your hoster can give you access to these logs.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  3. #3
    Join Date
    Aug 2009
    Posts
    369
    Plugin Contributions
    0

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    Thank you. Is hosted by myself on a personal linux environment.

    No errors on /var/log/mariadb/mariadb.log

  4. #4
    Join Date
    Aug 2009
    Posts
    369
    Plugin Contributions
    0

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    I discovered that problem shows up when URI checkbox "Tick this box to have the URI auto-generated for this product." is selected. How can I debug this ?

  5. #5
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,190
    Plugin Contributions
    96

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    I'd recommend you get rid of your URL modification process until your cart is working.
    (And after that too, but that's your call.)
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  6. #6
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,647
    Plugin Contributions
    73

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    Note, too, that the Ceon URI Mappings have an update that's compatible with zc156 and later (although you don't mention your Zen Cart version). See this link for more information: https://www.zen-cart.com/showthread....I-Mapping-V5-0

  7. #7
    Join Date
    Aug 2009
    Posts
    369
    Plugin Contributions
    0

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    At Modules -> Payment Modules cannot see right area which allows to remove or edit payment options.

    No errors in log directory. Is there a way to force a full debug of every php call ?

    ZC Version is 1.5.5.
    Last edited by solo_400; 26 Apr 2020 at 04:17 PM.

  8. #8
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,190
    Plugin Contributions
    96

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    Can you scroll to the right and see the edit option? Sometimes entries can get super wide and it appears that there's no right sidebar, but there is, it's just off-screen.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  9. #9
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,600
    Plugin Contributions
    3

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    Quote Originally Posted by solo_400 View Post
    Thank you. Is hosted by myself on a personal linux environment.

    No errors on /var/log/mariadb/mariadb.log
    Quote Originally Posted by solo_400 View Post
    At Modules -> Payment Modules cannot see right area which allows to remove or edit payment options.

    No errors in log directory. Is there a way to force a full debug of every php call ?

    ZC Version is 1.5.5.
    if you are hosting in your linux environment, i would look here:

    /var/log/apache2/error.log

    i'm assuming you are running a LAMP stack. your access log would also be in that directory:

    /var/log/apache2/access.log

    if you do not see the logs there, your would then need to look into your apache configuration to see where you have configured the log files to go, as well as the logging level.

    best.
    practice #socialdistancing #staysafe
    email is hard....
    help out with the green....

  10. #10
    Join Date
    Aug 2009
    Posts
    369
    Plugin Contributions
    0

    Default Re: Investigating new_product_preview blank page from admin when insert new product

    Thank you.

    Found the php log file path: /var/log/php-fpm/www-error.log

    And surprise, surprise the same error everytime I click on any payment option:

    [26-Apr-2020 15:52:39 UTC] PHP Parse error: syntax error, unexpected '[', expecting ',' or ';' in /var/www/html/mystore/includes/modules/payment/linkpoint_api.php on line 320

    I've never had a problem like this on live store. This is a clone store on my private server. Could be related to php version ?
    [[email protected] php-fpm]# php -v
    PHP 7.3.16 (cli) (built: Mar 17 2020 10:18:38) ( NTS )

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Page blank when displaying product page in admin
    By unclemantis in forum Setting Up Categories, Products, Attributes
    Replies: 7
    Last Post: 18 Jan 2014, 01:20 AM
  2. Blank page when product selected from sidebox
    By PK_Lisa in forum Setting Up Categories, Products, Attributes
    Replies: 1
    Last Post: 4 Nov 2011, 04:46 AM
  3. Blank page when product selected from sidebox
    By PK_Lisa in forum Templates, Stylesheets, Page Layout
    Replies: 0
    Last Post: 3 Nov 2011, 04:26 AM
  4. problem when I insert a new product
    By bahaa87 in forum Setting Up Categories, Products, Attributes
    Replies: 3
    Last Post: 4 Jun 2011, 03:49 PM
  5. Blank Page suddenly when adding new product
    By sweetjaime in forum Basic Configuration
    Replies: 1
    Last Post: 31 Jul 2010, 06:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR