Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Join Date
    May 2008
    Posts
    96
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    Quote Originally Posted by XxDrAg0nxX View Post
    https://www.zen-cart.com/downloads.php?do=file&id=166

    I tried to download tinymce... it also doesnt work, same as the CKeditor.

    When using the Old 2015 HTML editor... that error appear that says Mozilla <1.3 not supported, if you press ok, it actually loads the editor which works fine...

    Seems like this error affects CKeditor and TinyMCE?
    Sorry the old editor in my system it shows as editor_htmlarea, i tried searching for an updated version but dont seem to have


    I just tried this: https://www.zen-cart.com/downloads.php?do=file&id=1184

    Also does not load, same plain text editor

  2. #12
    Join Date
    May 2008
    Posts
    96
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    my guess is the editors are not loading at all, and its showing the default plain text mode.

    Only the old HTMLAREA editor can load for some reason

  3. #13
    Join Date
    Apr 2006
    Location
    West Salem, IL
    Posts
    2,570
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    new version released to fix compatibilty with older versions of ZC
    Mike
    GeekHost - Zen Cart Certified & PCI Compliant Hosting
    The Zen Cart Forum...Better than a monitor covered with post-it notes!

  4. #14
    Join Date
    Oct 2004
    Location
    Southport, UK
    Posts
    4,224
    Plugin Contributions
    20

    Default Re: CKEditor stopped working ?

    It's Google's fault!

    The CKEditor problem (and likely the others) is caused by loading modules with the jsapi loader being deprecated by Google, thus leaving the editor missing a required jQuery library.

    That said, we've found it only affects ZC versions prior to 155 so it's not entirely Google's fault - you can't blame them if you're running relatively ancient software.

    Uploading the newer CK Editor is unlikely to fix the problem on ZC154 so if you're not going to upgrade the site, you can fix the old module (
    v3.7e )

    admin/includes/ckeditor.php

    Replace lines 20/21 with


    PHP Code:
    <?php /* 
    ******  commented out as jsapi loader has been deprecated by Google  ******
    <script type="text/javascript" src="<?php echo (strstr(HTTP_SERVER, 'ttps:') ? 'https' : 'http'); ?>://www.google.com/jsapi"></script>
    <script type="text/javascript">if (typeof jQuery == 'undefined') google.load("jquery", "1");</script>
    */ 
    ?>
    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>


  5. #15
    Join Date
    Apr 2006
    Location
    West Salem, IL
    Posts
    2,570
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    Gee, the NEWEST with 1.5.5 an older change for the loading of CKeditor works great... Troubleshot it with the good doctor today.
    Mike
    GeekHost - Zen Cart Certified & PCI Compliant Hosting
    The Zen Cart Forum...Better than a monitor covered with post-it notes!

  6. #16
    Join Date
    Oct 2004
    Location
    Southport, UK
    Posts
    4,224
    Plugin Contributions
    20

    Default Re: CKEditor stopped working ?

    Just to be clear - our fix above was for ZC154 using CKEditor 3.7e ...but you really should upgrade!

  7. #17
    Join Date
    May 2008
    Posts
    96
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    Quote Originally Posted by Ryk View Post
    It's Google's fault!

    The CKEditor problem (and likely the others) is caused by loading modules with the jsapi loader being deprecated by Google, thus leaving the editor missing a required jQuery library.

    That said, we've found it only affects ZC versions prior to 155 so it's not entirely Google's fault - you can't blame them if you're running relatively ancient software.

    Uploading the newer CK Editor is unlikely to fix the problem on ZC154 so if you're not going to upgrade the site, you can fix the old module (
    v3.7e )

    admin/includes/ckeditor.php

    Replace lines 20/21 with


    PHP Code:
    <?php /* 
    ******  commented out as jsapi loader has been deprecated by Google  ******
    <script type="text/javascript" src="<?php echo (strstr(HTTP_SERVER, 'ttps:') ? 'https' : 'http'); ?>://www.google.com/jsapi"></script>
    <script type="text/javascript">if (typeof jQuery == 'undefined') google.load("jquery", "1");</script>
    */ 
    ?>
    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>


    Yup this works, thanks :)

    For us we did too much mods here and there until we forgot what we modified, updating to that latest version will be too tedious and would undo a lot of our mods

  8. #18
    Join Date
    Jun 2006
    Posts
    751
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    Thanks. I will try this today.

    I know what you mean by a hesitation to upgrade Zen all the time. I always get that same response , "Upgrade", "1.54 is ancient". Well, for those of us running a business on Zen, we know Upgrading is a Nightmare. About two weeks of working out the bugs and all the Mods that no longer work, etc. I dread the Zen upgrades and only do as a Last resort as it disrupts my business.

  9. #19
    Join Date
    Jun 2006
    Posts
    751
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    Quote Originally Posted by Ryk View Post
    It's Google's fault!

    The CKEditor problem (and likely the others) is caused by loading modules with the jsapi loader being deprecated by Google, thus leaving the editor missing a required jQuery library.

    That said, we've found it only affects ZC versions prior to 155 so it's not entirely Google's fault - you can't blame them if you're running relatively ancient software.

    Uploading the newer CK Editor is unlikely to fix the problem on ZC154 so if you're not going to upgrade the site, you can fix the old module (
    v3.7e )

    admin/includes/ckeditor.php

    Replace lines 20/21 with


    PHP Code:
    <?php /* 
    ******  commented out as jsapi loader has been deprecated by Google  ******
    <script type="text/javascript" src="<?php echo (strstr(HTTP_SERVER, 'ttps:') ? 'https' : 'http'); ?>://www.google.com/jsapi"></script>
    <script type="text/javascript">if (typeof jQuery == 'undefined') google.load("jquery", "1");</script>
    */ 
    ?>
    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>

    I'm not a coder so the code in black , "<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>", I assume you use to replace the code in orange ?

    If so there are no "Script type" lines in the Ckeditor.php file for v 1.54 and earlier ??

  10. #20
    Join Date
    Jun 2013
    Location
    Melbourne, Australia
    Posts
    12
    Plugin Contributions
    0

    Default Re: CKEditor stopped working ?

    Thanks for posting this fix. Much appreciated.

 

 
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. v154 CKEditor not working in Chrome??
    By kevinmc3 in forum General Questions
    Replies: 1
    Last Post: 20 May 2020, 05:14 PM
  2. CKEditor menu buttons not working
    By Fly130 in forum General Questions
    Replies: 7
    Last Post: 1 Aug 2018, 06:59 PM
  3. v154 suddenly ckeditor became not working
    By win8win in forum General Questions
    Replies: 3
    Last Post: 9 Sep 2016, 03:23 AM
  4. CkEditor Anchor text not working
    By pixelpadre in forum All Other Contributions/Addons
    Replies: 6
    Last Post: 27 May 2013, 05:43 PM
  5. asking a 2nd time, CKEDITOR.. not working
    By Shane78 in forum General Questions
    Replies: 14
    Last Post: 3 Jun 2010, 08:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR