Results 1 to 10 of 10
  1. #1
    Join Date
    Oct 2019
    Location
    Georgia, USA
    Posts
    20
    Plugin Contributions
    0

    Default Attempt to Create Test Domain Results in 404 error at Admin Logon

    Hello,

    In March, I copied our proposed webstore, eStore.marinlatinfoods.com to a testing domain, tempcart.marinlatinfoods.com. All went well. Today, I attempted the procedure again to update the test domain. All seemed well until I tried to login to the test domain admin area. When attempting login, the typed URL/domain changes from the test domain, tempcart.marinlatinfoods.com/tempcartadminfolder to the proposed webstore domain, eStore.marinlatinfoods.com/tempcartadminfolder. So the system is looking for the tempcart admin folder in the eStore domain, but the eStore domain has a differently-named admin folder. This results in landing on 404-page not found.

    I assumed that I would be able to log in using the credentials copied from the eStore domain.

    So that is the problem I'm having. Here is what I did. Firstly, I saved the 2 config files in the Tempcart domain. Next, I copied all contents of the eStore domain to the Tempcart domain. I then replaced the copied config files with the original config files that were in the TempCart domain. Next I copied the eStore MySQL database into the Tempcart database, preserving the Tempcart database name and user.

    So I obviously overlooked something such that attempting to access the admin area of Tempcart is still pointing to the wrong domain, although the correctly-named admin folder.

    Please review my efforts as explained here and let me know what I forgot to do. I'm stumped.

    Thank You in Advance!
    mrsawyer

  2. #2
    Join Date
    Jan 2004
    Posts
    65,400
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    You can name your admin folder whatever you want it to be, and then enter that in your browser.

    So, if you've named the admin directory "foo", then you would visit https://your_domain.com/foo/ to access the admin.
    If you named the admin directory "bizbuz" then you would visit https://your_domain.com/bizbuz/ to access the admin.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Oct 2019
    Location
    Georgia, USA
    Posts
    20
    Plugin Contributions
    0

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    Quote Originally Posted by DrByte View Post
    You can name your admin folder whatever you want it to be, and then enter that in your browser.

    So, if you've named the admin directory "foo", then you would visit https://your_domain.com/foo/ to access the admin.
    If you named the admin directory "bizbuz" then you would visit https://your_domain.com/bizbuz/ to access the admin.
    Hello,

    Thanks for the reply, but you seem to have missed the point. The issue is not the name of the admin folder, the issue is the domain name changes to point to the eStore domain, after I've typed the Tempcart-domain/adminfolder and press enter. So, it seems I have omitted a step in the process described that will allow access to the Tempcart admin area.

  4. #4
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,593
    Plugin Contributions
    3

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    its a little confusing what you are trying to do.... i will not get into the why you trying to do what you are doing....

    from the sound of it, it could be your .htacess file (are you familiar with that? do you have one?) or it could be your config files....

    i would review the work in those two spots very closely.

    good luck!
    practice #socialdistancing #staysafe
    email is hard....
    help out with the green....

  5. #5
    Join Date
    Oct 2019
    Location
    Georgia, USA
    Posts
    20
    Plugin Contributions
    0

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    Quote Originally Posted by carlwhat View Post
    its a little confusing what you are trying to do.... i will not get into the why you trying to do what you are doing....

    from the sound of it, it could be your .htacess file (are you familiar with that? do you have one?) or it could be your config files....

    i would review the work in those two spots very closely.

    good luck!
    Thanks for the reply Carl. I would not think that creating a copy of our store for testing would be very unusual. When I did it in March, I did not have to do anything with .htaccess, so I would not think that would be an issue now, though I will take a look at the file to see if anyone changed anything there. I have reviewed the 2 config files ad nauseum with no errors I can see. I did notice that this has happened to others in the past, but no resolutions were ever mentioned in those threads. Well, off I go to examine the .htaccess file.

    Later,
    mrsawyer

  6. #6
    Join Date
    Oct 2012
    Location
    Philadelphia, PA, USA
    Posts
    28
    Plugin Contributions
    0

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    I had a similar problem. It was caused by not modifying the server name correctly in my two config.php files.
    Verify that main web server is still not pointing to the eStore path but to tempcart path.

  7. #7
    Join Date
    Oct 2019
    Location
    Georgia, USA
    Posts
    20
    Plugin Contributions
    0

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    I found the issue. I mentioned that I preserved the 2 config files to restore after the copy. However there are 3 config files. There is one in the includes folder, one in the root of the admin folder, and another in the includes folder inside the admin folder. I had forgotten to configure the one inside the includes folder in the admin folder. All is well now.
    Thanks to all who tried to help!

  8. #8
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,593
    Plugin Contributions
    3

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    Quote Originally Posted by mrsawyer View Post
    I found the issue. I mentioned that I preserved the 2 config files to restore after the copy. However there are 3 config files. There is one in the includes folder, one in the root of the admin folder, and another in the includes folder inside the admin folder. I had forgotten to configure the one inside the includes folder in the admin folder. All is well now.
    Thanks to all who tried to help!
    really? 3 config files? sorry that is just incorrect. there are 2 configure.php files and both are in their respective includes directories.

    not sure what you are looking at, and how many other extra files you may have.
    practice #socialdistancing #staysafe
    email is hard....
    help out with the green....

  9. #9
    Join Date
    Jul 2012
    Posts
    15,106
    Plugin Contributions
    17

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    There well could be three configure.php files in the filesystem. There could be however many the file system could support, but there are only two that matter. The identified one extra likely was part of the copy/backup process that was performed only in part.

    It came down to what is routinely suggested for a system where one side (catalog or admin) works as expected but the other side doesn't. Comparing the two files (includes/configure.php and admin/includes/configure.php) looking for unexplainable differences or those differences that seem to lead to the identified issue(s).

    Unfortunately there are those in the previously reviewed threads that may not post the simple/obvious solution for any of a number of reasons, too much trouble, too obvious, ashamed, pride, forgot, moved on, other fish, etc... :) but... at least this thread has the reason identified, so keep up the good work!
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  10. #10
    Join Date
    Apr 2006
    Location
    West Salem, IL
    Posts
    2,570
    Plugin Contributions
    0

    Default Re: Attempt to Create Test Domain Results in 404 error at Admin Logon

    Most likely confusing the admin/configuration.php with admin/includes/configure.php
    Mike
    GeekHost - Zen Cart Certified & PCI Compliant Hosting
    The Zen Cart Forum...Better than a monitor covered with post-it notes!

 

 

Similar Threads

  1. v139h Help, I can't create test customers. Error 404?
    By BookGirl in forum General Questions
    Replies: 0
    Last Post: 30 Jul 2012, 10:36 AM
  2. v139h Transferring site to new domain now get 404 error when accessing admin on new site
    By nikihaym314159 in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 29 Jan 2012, 09:24 PM
  3. Search engine results getting Error 404-Not found
    By FukienMan in forum General Questions
    Replies: 4
    Last Post: 18 Dec 2011, 05:45 AM
  4. Error message when trtying logon to admin
    By discoverytdi in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 31 May 2011, 08:07 PM
  5. Admin logon error
    By mogglin in forum Installing on a Windows Server
    Replies: 0
    Last Post: 1 Mar 2007, 11:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR