Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29
  1. #11
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,586
    Plugin Contributions
    78

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Quote Originally Posted by wilt View Post
    Hi,

    As mentioned already, for v157 there is not that much support for plugins are used catalog side, that will come in v158.

    Note also that code within the zc_plugin directory is protected by an .htaccess file so, can never be run directly anyway.

    That said...

    You can get the path to a plugin using

    Code:
    $path = $pluginManager->getPluginVersionDirectory('myPluginKey', $installedPlugins)
    $pluginManager and $installedPlugins are available in the global scope, so if you want to use them in a function/class method you will need to bring them into scope.

    For v158 (and we have this working already) you will be able to have URI's like
    Code:
    https://mdomain.com/index.php?cmd=someplugincode
    which will resolve to code within the plugin directory
    That change is going to have a negative affect on the various URL manglers (e.g. USU/Ceon) since they're not going to 'understand' the &cmd= variable.

  2. #12
    Join Date
    Apr 2009
    Posts
    2,123
    Plugin Contributions
    3

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Just a quick note to say thanks for all the work on this one.

    It is a vast improvement - even if only for admin at the moment.

    Thanks to all ...

  3. #13
    Join Date
    Jul 2012
    Posts
    16,006
    Plugin Contributions
    17

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    What additional code is needed to support stepping through the upgrade option?

    I was working on an admin only plugin and wanted to keep the software unchanged in the original version, so I created a new version folder. I am using the installer class (don't recall the exact name) which has an install and deinstall method in it. (again specific name not recalled). I am able to uninstall the older/lower version and install the upper/higher version, but while the lower version is installed I am notified that a higher version is available. When I select the upgrade button, I am then presented with a radio button showing just the next higher version. As I step through that, there is no change in the installed version.

    Now, any work done/to be done on such an upgrade also calls into question how existing settings (if present) might be expected to be retained. E.g. Is there a plan to store the settings that were in place with the plugin being upgraded to be able to restore said settings upon return or in event of a problem during upgrade? Not expecting that all of that would necessarily be internally "pre-"handled, but some sort of helper/consistent method to support something like that when/if coded or found necessary. Otherwise it seems that in an upgrade failure one would have to try to remove and then reinstall and manually make adjustments to "restore" settings associated with the plugin...

    I have not reviewed the code progress associated with 1.5.8 yet.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  4. #14
    Join Date
    Apr 2014
    Location
    Polska
    Posts
    20
    Plugin Contributions
    0

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Does anyone confirmed this plugin manager works? I have 2 issues with it, maybe somenone have some solution,
    Issue #1
    Blank page in Plugin Manager, logs show following error:
    --> PHP Parse error: syntax error, unexpected '?' in /home/xxxx/public_html/zen_new/includes/classes/TableViewControllers/BaseController.php on line 232.
    this happens at live server with PHP Version: 5.6.40 (Zend: 2.6.0)
    Is there possibility I missed some info about php version needed to use it? (somehow I feel it may be the cause)
    The same website on localhost works, plugin manager loads and let install items (almost)

    Issue #2 (maybe Daveallen can help)
    Tried install/remove testimonials manager using plugin manager but even thou it claims it is installed, database entries (tm status > on) are not added. Dont know if this is some issue with sql queries in installation script or plugin manager issue itself.

    If this is not the place for these bug reports please move message in proper tread.

    Thanks
    Tomek

  5. #15
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    2,012
    Plugin Contributions
    5

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Quote Originally Posted by store-support View Post
    Does anyone confirmed this plugin manager works? I have 2 issues with it, maybe somenone have some solution,
    Issue #1
    Blank page in Plugin Manager, logs show following error:
    --> PHP Parse error: syntax error, unexpected '?' in /home/xxxx/public_html/zen_new/includes/classes/TableViewControllers/BaseController.php on line 232.
    this happens at live server with PHP Version: 5.6.40 (Zend: 2.6.0)
    Is there possibility I missed some info about php version needed to use it? (somehow I feel it may be the cause)
    The same website on localhost works, plugin manager loads and let install items (almost)

    Issue #2 (maybe Daveallen can help)
    Tried install/remove testimonials manager using plugin manager but even thou it claims it is installed, database entries (tm status > on) are not added. Dont know if this is some issue with sql queries in installation script or plugin manager issue itself.

    If this is not the place for these bug reports please move message in proper tread.

    Thanks
    Tomek
    line 232 on 1.5.7a makes use of the coalesce operator, ie a double question mark, `??`. support for that operator started in php7.0.
    You could use the updated version from https://github.com/zencart/zencart/b...Controller.php until you upgrade your PHP.

    best.
    help with WCAG is now here! PM if you want some help with this. (or any ZC issue).
    if you feel so inclined, feel free to send some cake....

  6. #16
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,586
    Plugin Contributions
    78

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Quote Originally Posted by carlwhat View Post
    line 232 on 1.5.7a makes use of the coalesce operator, ie a double question mark, `??`. support for that operator started in php7.0.
    You could use the updated version from https://github.com/zencart/zencart/b...Controller.php until you upgrade your PHP.

    best.
    Hmm, the docs (https://docs.zen-cart.com/user/first..._requirements/) that identify the requirements for various Zen Cart versions indicate that the zc157 series should work on PHP 5.6.

    Update: Never mind, I see that the issue's been corrected for the forthcoming zc157c.

  7. #17
    Join Date
    Jul 2012
    Posts
    16,006
    Plugin Contributions
    17

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Quote Originally Posted by lat9 View Post
    Hmm, the docs (https://docs.zen-cart.com/user/first..._requirements/) that identify the requirements for various Zen Cart versions indicate that the zc157 series should work on PHP 5.6.

    Update: Never mind, I see that the issue's been corrected for the forthcoming zc157c.
    As I said in this commit: https://github.com/zencart/zencart/c...2310#r45515165
    I had introduced PHP 7.x centric code as I had seen other similar use within the code at that time, then with consideration that the move should be to go to 7.x where 5.6 was active from more of a "highest available to support upgrading from some of the older systems", my (incorrect) independent evaluation that the plugins manager wouldn't necessarily cause a problem in routine operation as the "same" software could be installed manually as well, and any number of other incorrect tidbits about why it wasn't implemented with more "older system" readiness/compatibility.

    So yeah, hi, I introduced that problem and as identified above it is written out in "long form" for zc 1.5.7c.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  8. #18
    Join Date
    Apr 2014
    Location
    Polska
    Posts
    20
    Plugin Contributions
    0

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Great, thanks for info, got sorted my issues there and awaiting next release.

  9. #19
    Join Date
    Apr 2009
    Posts
    295
    Plugin Contributions
    2

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    Is it OK to create a mixed admin/ store-front plug-in that uses plug-in manager for the admin side and leaves the store-front side as is?
    Or is 1.5.8 nearly there and i am better waiting?
    Mark Brittain
    http:\\innerlightcrystals.co.uk\sales\

  10. #20
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,909
    Plugin Contributions
    108

    Default Re: Plugin Manager (Zen Cart 1.5.7+)

    This would be amazingly confusing. If your plugin has front end and back end elements, just do it the old way for 1.5.7 and below.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

 

 
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Zen-Cart Order Manager
    By Zapisto in forum All Other Contributions/Addons
    Replies: 32
    Last Post: 28 Jul 2010, 12:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR