Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2012
    Posts
    170
    Plugin Contributions
    1

    Idea or Suggestion Cannot use object of type mysqli_result as array in \includes\classes\PluginManager

    Admin end not opening due to the following error , how to fix ?


    PHP Fatal error: Uncaught Error: Cannot use object of type mysqli_result as array in ......\includes\classes\PluginManager.php:32


    $pluginList[$result['unique_key']] = $result; is line 32 of PluginManager.php

  2. #2
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,319
    Plugin Contributions
    99

    Default Re: upgrading from previous version to 157

    Verify that you ran the upgrade procedure (zc_install) and that it created the table plugin_control.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  3. #3
    Join Date
    Apr 2012
    Posts
    170
    Plugin Contributions
    1

    Default Re: upgrading from previous version to 157

    Yes the table is in database and empty ie no rows

  4. #4
    Join Date
    Jan 2004
    Posts
    65,475
    Blog Entries
    7
    Plugin Contributions
    237

    Default Re: upgrading from previous version to 157

    In what ways have you altered core code?
    It seems perhaps your /includes/classes/db/mysql/query_factory.php may not be current.

    This is the sort of thing where you need to re-review all the things you've altered in original core code. Only you have access to that information: review all changes and be sure that the things that are different are indeed necessary and intentional and not causing problems.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Apr 2012
    Posts
    170
    Plugin Contributions
    1

    Idea or Suggestion Re: upgrading from previous version to 157

    Quote Originally Posted by DrByte View Post
    In what ways have you altered core code?
    It seems perhaps your /includes/classes/db/mysql/query_factory.php may not be current.

    This is the sort of thing where you need to re-review all the things you've altered in original core code. Only you have access to that information: review all changes and be sure that the things that are different are indeed necessary and intentional and not causing problems.


    Thanks . I will check .

 

 

Similar Threads

  1. v139h Cannot use object of type queryFactoryResult
    By dmagic in forum General Questions
    Replies: 1
    Last Post: 19 Dec 2013, 06:05 PM
  2. Replies: 3
    Last Post: 14 Dec 2009, 10:51 AM
  3. Replies: 3
    Last Post: 11 Nov 2009, 04:37 AM
  4. Error in referrals.php - Cannot use object of type queryFactoryResult as array
    By Agouti in forum All Other Contributions/Addons
    Replies: 3
    Last Post: 3 Jan 2009, 08:25 PM
  5. Replies: 4
    Last Post: 21 Mar 2008, 06:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR