Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26
  1. #11
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    woohoo.... mysterically the old store started working again today... it has a number of issues which I assume are due to a very long needed upgrade but it's something I have been and can continue to live with until the new store can be completed... do I by chance need to build the store before the database can be updated or can I update the database with the store in it's default state right after the install? basically what I have been trying to do is update the database before a lot of work is put into building the store so if there is an issue I can easily get back to to point where to problem arises...

  2. #12
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    Quote Originally Posted by iknowalttl View Post
    woohoo.... mysterically the old store started working again today... it has a number of issues which I assume are due to a very long needed upgrade but it's something I have been and can continue to live with until the new store can be completed... do I by chance need to build the store before the database can be updated or can I update the database with the store in it's default state right after the install? basically what I have been trying to do is update the database before a lot of work is put into building the store so if there is an issue I can easily get back to to point where to problem arises...
    I just received an email explaining the old store issue and why it started working again... they changed the PHP version which caused the issue and now have changed it back which resolved the issue but will be deprecated the end of the month...

  3. #13
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    I am still having an issue upgrading the database and still in need of some guidance here... I have the current 1.5.7 installed and running with all the bug fixes in the sticky completed with the exception of #10 (Fixes #3805 - also purchased products broken)... when I do the change per #10 I get the white screen with a server error message... when trying to run the installer again, I do not get the option to upgrade datatbase... the server is running PHP 7.4 and has made apparel-printers.com/estore run under PHP 5.x... the new store that I am working on is at apparel-printers.com/store...

  4. #14
    Join Date
    Jan 2004
    Posts
    65,783
    Blog Entries
    7
    Plugin Contributions
    245

    Default Re: In need of help upgrading to new version

    Quote Originally Posted by iknowalttl View Post
    I get the white screen with a server error message...
    Can't help sort out an error without you stating what the actual error is.
    Zen Cart stores error logs in the /logs/ directory.

    Quote Originally Posted by iknowalttl View Post
    when trying to run the installer again, I do not get the option to upgrade datatbase...
    As said earlier, you won't see the option to upgrade the database if the database can't be detected. It reads the database connection details from the DB_XXXXXXX values in your /includes/configure.php file.

    https://docs.zen-cart.com/user/upgrading/
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #15
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    Quote Originally Posted by DrByte View Post
    Can't help sort out an error without you stating what the actual error is.
    Zen Cart stores error logs in the /logs/ directory.


    As said earlier, you won't see the option to upgrade the database if the database can't be detected. It reads the database connection details from the DB_XXXXXXX values in your /includes/configure.php file.

    https://docs.zen-cart.com/user/upgrading/
    understood... thanks for helping me know what you need in order to help resolve things... I can't say I am real knowledgeable on coding but I can generally stumble through things with a bit of directions and accomplish what I have to do... I have had the old store for many years and done mods, plugins and have moved to different host a number of times and have had to deal with the database and config files on numerous occasions so I am not completely blind at things either...
    looking through the logs here is what I found... file name zcInstallLog_10-06-2020_03-27-01-bslogu3.log everything passed with the following exception...

    Oct 06 2020 15:27 -- checkIniGet
    FAILED
    (
    [inigetName] => output_buffering
    [expectedValue] => 1
    )

    and just to be clear... #10 post in the sticky is telling me to delete lines 32 and 33...
    32 ORDER BY date_purchased desc, p.products_id
    33 LIMIT %u");
    from public_html/store/includes/classes/db/mysql/define_queries.php... as a guess, I deleted line 32 completely and only the LIMIT %u and left the "); and now I no longer get the white page and server error when going to apparel-printers.com/store... sorry but as I was typing I just thought of this... like I said, I kind of stumble my way...

    the info in the config file seems to match what I setup on the server... I checked multiple times and unless I am not looking at things properly I believe they are correct... here is what I am checking... please let me know if there is something different I should be looking at....

    define('DB_SERVER', 'localhost'); // address of your db server
    define('DB_SERVER_USERNAME', 'xxx');
    define('DB_SERVER_PASSWORD', 'xxx');
    define('DB_DATABASE', 'xxx');

    all 3 xxx items are matching on the server... shown here as xxx but are actually names in the config file and on the server...

    also, and correct me if I am wrong and maybe not laugh to hard, I am under the impression that since everything is running and I am able to log in to the admin area, that the script an database are communicating...

    so again while typing I went and added a product to the store and had no issues... then went to the store front and it was there no problem... is there still a possibility of no communication between the script and database?
    Last edited by iknowalttl; 7 Oct 2020 at 03:16 AM.

  6. #16
    Join Date
    Jan 2004
    Posts
    65,783
    Blog Entries
    7
    Plugin Contributions
    245

    Default Re: In need of help upgrading to new version

    In the configure.php on old and new, what's the DB_PREFIX set to? It needs to be the same in the new as it was in the old else it will read a different set of database table data.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #17
    Join Date
    Mar 2006
    Location
    Auckland, New Zealand
    Posts
    160
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    Quote Originally Posted by iknowalttl View Post
    I just received an email explaining the old store issue and why it started working again... they changed the PHP version which caused the issue and now have changed it back which resolved the issue but will be deprecated the end of the month...
    Mine has the same issue - my cart has been disabled the last few days on the 1.3.7 version and I hadn't even noticed as I've been so busy with work and creating the new site. I decided a migration was too hard and complicated and are using this upgrade as an option to restructure my business.
    Elemi

    The Art of Bespoke Aromatherapy
    www.AmorAromatherapy.co.nz

  8. #18
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    Quote Originally Posted by DrByte View Post
    In the configure.php on old and new, what's the DB_PREFIX set to? It needs to be the same in the new as it was in the old else it will read a different set of database table data.
    empty on both... old and new have their own database...

  9. #19
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    Quote Originally Posted by iknowalttl View Post
    empty on both... old and new have their own database...
    old store.... /estore/includes/configure.php
    // define our database connection
    define('DB_TYPE', 'mysql');
    define('DB_PREFIX', '');
    define('DB_SERVER', 'localhost');

    new store.... /store/includes/configure.php
    * The following settings define your database connection.
    * These must be the SAME as you're using in your admin copy of configure.php
    */
    define('DB_TYPE', 'mysql'); // always 'mysql'
    define('DB_PREFIX', ''); // prefix for database table names -- preferred to be left empty
    define('DB_CHARSET', 'utf8mb4'); // 'utf8mb4' or older 'utf8' / 'latin1' are most common
    define('DB_SERVER', 'localhost'); // address of your db server

  10. #20
    Join Date
    Oct 2010
    Posts
    30
    Plugin Contributions
    0

    Default Re: In need of help upgrading to new version

    I am still at a loss on how to bring the database info from my 1.3.9h store to my 1.5.7 store... help would be very much appreciated... my host has enabled an older version PHP on my old store directory till the end of the month and will likely stop working after that... I really need to get the new store updated badly and just not sure why things aren't working for me here... I'm not getting the upgrade database option upon re-running the install... I currently have the new install under a new directory with it's own new database and all seems to work properly... the old store is currently working also... just need to get all the customer and product info into the new store...
    Last edited by iknowalttl; 23 Oct 2020 at 05:48 PM.

 

 
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. v157 E-mail problems since upgrading to new version
    By SCOX5275 in forum Basic Configuration
    Replies: 8
    Last Post: 22 Nov 2020, 02:51 AM
  2. v139h upgrading a new installation of version 1.3.9 to 1.5
    By cshearer in forum Upgrading to 1.5.x
    Replies: 17
    Last Post: 2 May 2012, 10:30 PM
  3. Error when upgrading to new version through Softaculous
    By annav in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 9 Oct 2010, 06:07 PM
  4. upgrading to new version
    By geovino in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 28 Jun 2007, 06:59 PM
  5. upgrading to the new version
    By op913chad in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 8 Dec 2006, 04:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR