Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default 1.5.7c Trying to install on PHP 8.0

    Trying to install on PHP 8.0 First came up with message saying I didn't have the component to connect to the database. I installed the MySQL and Postegre database PHP modules and now the installation will not come up at all? Any ideas?

    P.S. Thank you all for the latest and greatest. Would love to see more features added into it like Google reCaptcha, keep cart, google analytics, remember me, sitemap XML, option to use Ultimate Urls, option to use Image Handler.

    Thank you!

    Shrimp

  2. #2
    Join Date
    Jul 2012
    Posts
    15,649
    Plugin Contributions
    17

    Default Re: 1.5.7c Trying to install on PHP 8.0

    Addressing the PS. These programs are for the most part loadable to easily be in action with little to no intervention. That said, not all of them are the only ones in town, so generally speaking the code is made more suitable for the other programs to be brought in without touching the core code.

    As to the issue(s) with the installation, what do the logs files have to reveal (if anything) and if none generated because it seems like this server is just being put together, what do the server logs have to say?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  3. #3
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,669
    Plugin Contributions
    104

    Default Re: 1.5.7c Trying to install on PHP 8.0

    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  4. #4
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default Re: 1.5.7c Trying to install on PHP 8.0

    Thank you!

  5. #5
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default Re: 1.5.7c Trying to install on PHP 8.0

    Hello,

    Slightly confused.... did you delete my post that had the error messages? I am sure that I saw it that I had posted it here but it is gone now....

    [08-Mar-2021 00:31:31 UTC] PHP Fatal error: Uncaught TypeError: mysqli_close(): Argument #1 ($mysql) must be of type mysqli, bool given in /home/account/public_html/webstoreb/includes/classes/db/mysql/query_factory.php:130
    Stack trace:
    #0 /home/account/public_html/webstoreb/includes/classes/db/mysql/query_factory.php(130): mysqli_close(false)
    #1 /home/account/public_html/webstoreb/includes/classes/db/mysql/query_factory.php(135): queryFactory->close()
    #2 /home/account/public_html/webstoreb/zc_install/includes/classes/class.systemChecker.php(44): queryFactory->__destruct()
    #3 /home/account/public_html/webstoreb/zc_install/includes/modules/pages/index/header_php.php(62): systemChecker->runTests()
    #4 /home/account/public_html/webstoreb/zc_install/index.php(40): require('/home/account/pu...')
    #5 {main}
    thrown in /home/account/public_html/webstoreb/includes/classes/db/mysql/query_factory.php on line 130

  6. #6
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default Re: 1.5.7c Trying to install on PHP 8.0

    This is the Database I am using: Database Engine: MySQL 5.5.5-10.3.28-MariaDB

  7. #7
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default Re: 1.5.7c Trying to install on PHP 8.0

    Okay, looking at installing with
    PHP Version 7.4.15

    How does one get: The GZIP extension enabled?

    Thank you!

    Shrimp

  8. #8
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    7,902
    Plugin Contributions
    8

    Default Re: 1.5.7c Trying to install on PHP 8.0


  9. #9
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default Re: 1.5.7c Trying to install on PHP 8.0

    Thank you!

  10. #10
    Join Date
    Jun 2007
    Posts
    1,282
    Plugin Contributions
    0

    Default Re: 1.5.7c Trying to install on PHP 8.0


    Thank you dbltoe for your answer. I have to wonder if this is the solution to the problem.... why this message is given when a new install happens? Thank you!

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Trying to install
    By beeshive in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 6 Aug 2011, 08:16 AM
  2. trying to install, but hangs on database install
    By tangwystl in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 16 Oct 2009, 06:07 PM
  3. trying to install on godaddy server errors on install
    By live4soccer7 in forum Installing on a Windows Server
    Replies: 12
    Last Post: 20 Jun 2009, 04:06 PM
  4. Trying to install
    By ByondF1 in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 29 Oct 2008, 08:51 PM
  5. Replies: 23
    Last Post: 18 Mar 2007, 10:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR