Results 1 to 9 of 9

Hybrid View

  1. #1
    Join Date
    Jun 2010
    Location
    Milano (Italy)
    Posts
    24
    Plugin Contributions
    0

    Default session,php on line 108

    Hi, I have installed my domain, which until now has always worked on aruba.it keeping my hosting on siteground.

    Except that you can't access the store again, even if you see the site.
    Instead it appears in the administration panel
    Warning: session_start () [function.session-start]: open (/ home /...../ public_html / shop / cache / sess_242td7nn2os4giqrksgse1o1r7, O_RDWR) failed: No such file or directory (2) in / home / customer / www / ......... public_html / shop / includes / functions / sessions.php on line 108

    What can I do? Can anyone help me? Thank you

  2. #2
    Join Date
    Jan 2004
    Posts
    66,385
    Blog Entries
    7
    Plugin Contributions
    81

    Default Re: session,php on line 108

    I suspect your server is denying access to write session files in your /cache directory because your server account is probably using more disk space than your hosting account allows.

    What Zen Cart version?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jun 2010
    Location
    Milano (Italy)
    Posts
    24
    Plugin Contributions
    0

    Default Re: session,php on line 108

    thanks, I still have 1.3.7
    I'll update it later.
    Do you think it depends on SSL?

  4. #4
    Join Date
    Jan 2004
    Posts
    66,385
    Blog Entries
    7
    Plugin Contributions
    81

    Default Re: session,php on line 108

    Quote Originally Posted by adelefr View Post
    I still have 1.3.7
    Wow!
    In that old version there was a configuration setting available in your /includes/configure.php file that controls whether to use file-based or db-based session storage.
    Since your errors are indicating problems with file-based storage, perhaps changing to database-storage may offer some interim help.

    For v1.3.7:
    /includes/configure.php
    define('STORE_SESSIONS', 'db');

    (On yours, instead of 'db' it might currently say '' or 'file'. Change it to 'db'.)
    (Note: The /includes/configure.php file is usually set as read-only on the server's filesystem, so you will need to change its permissions to writable before your can save any edits to it.)
    Do the same to your /admin/includes/configure.php file as well.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jun 2010
    Location
    Milano (Italy)
    Posts
    24
    Plugin Contributions
    0

    Default Re: session,php on line 108

    thank you and sorry for the late reply, but the hosting company has changed the whole setup of the site and I could no longer find the free space available. The space occupied is only one third, so that's not the problem

  6. #6
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    9,188
    Plugin Contributions
    11

    Default Re: session,php on line 108

    I would be willing to bet your host has upped their lowest supported PHP and broken your store. Your maximum version of PHP is 5.2 which was officially End Of Life ten years ago!

    I know of no one that can accommodate that old a php AND, if I did, I would not recommend them as they would certainly be at risk running such an outdated PHP.

    Try to salvage your images, define pages, and database for a new install.

    In bocca al lupo!

 

 

Similar Threads

  1. Replies: 22
    Last Post: 2 Sep 2020, 05:30 PM
  2. Replies: 1
    Last Post: 15 Dec 2018, 10:54 PM
  3. Replies: 9
    Last Post: 11 Dec 2015, 11:35 PM
  4. PhP question about a line of code in includes/classes/order.php
    By dbrewster in forum Managing Customers and Orders
    Replies: 12
    Last Post: 1 Feb 2007, 03:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR