Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    Join Date
    Jul 2012
    Posts
    16,384
    Plugin Contributions
    17

    Default Re: Reinstall - can't get past database setup

    Quote Originally Posted by dbltoe View Post
    Doesn't match any configure.php that I recall. Should be located at YOUR_ADMIN/includes/configure.php
    "Original" version of the admin/includes/configure.php for ZC 1.5.1 can be seen here: https://github.com/zencart/zencart/b...-configure.php

    While the image includes text wrapped around, it appears that the two are relatively similar. (haven't done a line for line compare, but does look familiar to the *old* way that it was formatted.)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  2. #12
    Join Date
    Nov 2007
    Location
    Texas
    Posts
    253
    Plugin Contributions
    0

    Default Re: Reinstall - can't get past database setup

    Quote Originally Posted by mc12345678 View Post
    As of Zen Cart 1.5.1 (the version being used), the admin directory path is auto-determined by the line(s) below the red text. In this way, the admin directory never needs to be hard coded in the file and the admin directory can be renamed on a whim without further revision of the file. However, there may be an .htaccess file that has been manually generated in a parent directory of that folder which may need to be updated to properly reference that directory.

    The question right now would be what issue is being experienced when attempting to access the admin directory? If receiving some sort of message about installing, please be sure to include information that is towards the bottom of the message indiciating the reason(s) the message is being provided. May still be experiencing DNS issues as I have not been able to access that site using the domain provided in the first post of this thread.
    Interesting. I just tried on my phone to access my admin page and it says server not found. From a computer it says 504 DNS look up failed. Iím not even getting the install notifications. Iíll cal my host. In the meantime, is there a specific .htaccess file I need to look at? I didnít change any files. I just pulled them out of the folder and put them in the root directory.

  3. #13
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Reinstall - can't get past database setup

    If your old configure.php files are no longer valid (evidenced by invalid paths in them, especially if you've switched hosts/servers/etc), you can build new configure.php files.

    In such a case I would:
    - create a new separate temporary database that you will discard in a few minutes
    - run zc_install and treat it as a new install, providing that new temporary database when it asks you for database details
    - this will also generate updated configure.php files suitable for this server.
    - then delete the temporary database
    - then update both configure.php files with the correct "real" database name, and user credentials, so that it displays real data.
    - (if you were actually upgrading from an older version now you could re-run zc_install and choose Database Upgrade) -- but you seem to be using the same version in your situation so this last step isn't relevant.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #14
    Join Date
    Nov 2007
    Location
    Texas
    Posts
    253
    Plugin Contributions
    0

    Default Re: Reinstall - can't get past database setup

    Hey everybody - thanks for your help and suggestions! I was able to get it done with completely wiping/reinstalling the database. I'm missing some images and stylesheet settings, but I'll figure out where to make those changes again. I'm getting there!

  5. #15
    Join Date
    Nov 2007
    Location
    Texas
    Posts
    253
    Plugin Contributions
    0

    Default Re: Reinstall - can't get past database setup

    Ok I thought I had this all figured out. However, if I go to www.personalizedpetid.com the page won’t load. If I just type personalizedpetid.com the site loads. How do I fix this?

  6. #16
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    8,543
    Plugin Contributions
    9

    Default Re: Reinstall - can't get past database setup

    Looks like a bad or missing 301 redirect. Since your SSL does not include www, I would use the following in your .htaccess
    Code:
    # Needed before any rewritingRewriteEngine On
    
    
    ### Built using the .htaccess 301 Redirect Generator from Web Site Advantage
    ### https://websiteadvantage.com.au/HtAccess-301-Redirect-Generator
    ### Place after 'RewriteEngine On' and before any CMS specific rewrite rules
    
    
    # Redirect HTTP with www to HTTPS without www
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule .* https://%1%{REQUEST_URI} [R=301,L]
    # Redirect HTTP without www to HTTPS without www
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    # Redirect HTTPS with www to HTTPS without www
    RewriteCond %{HTTPS} on
    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule .* https://%1%{REQUEST_URI} [R=301,L]
    
    
    ## 301 Redirects

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Can't get past "database setup" page to install
    By BPM Training in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 10 Jan 2011, 02:02 PM
  2. Can't get past 'Database Setup' page
    By gavwright in forum Installing on a Linux/Unix Server
    Replies: 7
    Last Post: 17 Jul 2010, 04:56 PM
  3. Install won't get past the Database Setup
    By ssolis5788 in forum Installing on a Windows Server
    Replies: 2
    Last Post: 5 May 2008, 11:31 PM
  4. Can't get past database setup
    By RavenMoon in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 6 Sep 2007, 12:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR