Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2004
    Posts
    173
    Plugin Contributions
    0

    Default Can't edit Payment Modules

    shopcybermidi.com
    157b
    StripePay
    php 7.4

    Recently upgraded. I can no longer edit any payment modules. The little blue arrow to the right of a payment module is not clickable.

    Please help debug this.

    Thank you

  2. #2
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    7,951
    Plugin Contributions
    9

    Default Re: Can't edit Payment Modules

    There's some excellent info in the first Similar Threads below.

  3. #3
    Join Date
    Sep 2004
    Posts
    173
    Plugin Contributions
    0

    Default Re: Can't edit Payment Modules

    Quote Originally Posted by dbltoe View Post
    There's some excellent info in the first Similar Threads below.
    Can you point me out to another with this issue? I cannot find anything.

  4. #4
    Join Date
    Jan 2004
    Posts
    66,335
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Can't edit Payment Modules

    As discussed in the threads mentioned, most likely you have a fatal PHP error that's stopping the rest of the page from being drawn (as evidenced by having no footer and no sidebar on that admin page, and confirmed by the presence of fatal error logs in the /logs/ directory).
    Once you resolve the fatal error things should return to normal.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Sep 2004
    Posts
    173
    Plugin Contributions
    0

    Default Re: Can't edit Payment Modules

    Can you assist with this log as to the next step?

    Thank you

    [14-Apr-2021 16:49:55 America/New_York] Request URI: /adminnew/index.php?cmd=modules&set=payment&module=authorizenet, IP address: 24.164.151.237
    #1 include(/shopcybermidi.com/includes/languages/english/modules/payment/authorizenet_echeck.php) called at [/shopcybermidi.com/adminnew/modules.php:200]
    #2 require(/shopcybermidi.com/adminnew/modules.php) called at [/shopcybermidi.com/adminnew/index.php:11]
    --> PHP Warning: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_ECHECK_STATUS - assumed 'MODULE_PAYMENT_AUTHORIZENET_ECHECK_STATUS' (this will throw an Error in a future version of PHP) in /shopcybermidi.com/includes/languages/english/modules/payment/authorizenet_echeck.php on line 17.

    [14-Apr-2021 16:49:55 America/New_York] Request URI: /adminnew/index.php?cmd=modules&set=payment&module=authorizenet, IP address: 24.164.151.237
    #1 authorizenet_echeck->authorizenet_echeck() called at [/shopcybermidi.com/adminnew/modules.php:204]
    #2 require(/shopcybermidi.com/adminnew/modules.php) called at [/shopcybermidi.com/adminnew/index.php:11]
    --> PHP Warning: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_ECHECK_STATUS - assumed 'MODULE_PAYMENT_AUTHORIZENET_ECHECK_STATUS' (this will throw an Error in a future version of PHP) in /shopcybermidi.com/includes/modules/payment/authorizenet_echeck.php on line 77.

    [14-Apr-2021 16:49:55 America/New_York] Request URI: /adminnew/index.php?cmd=modules&set=payment&module=authorizenet, IP address: 24.164.151.237
    #1 authorizenet_echeck->authorizenet_echeck() called at [/shopcybermidi.com/adminnew/modules.php:204]
    #2 require(/shopcybermidi.com/adminnew/modules.php) called at [/shopcybermidi.com/adminnew/index.php:11]
    --> PHP Warning: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_ECHECK_SORT_ORDER - assumed 'MODULE_PAYMENT_AUTHORIZENET_ECHECK_SORT_ORDER' (this will throw an Error in a future version of PHP) in /shopcybermidi.com/includes/modules/payment/authorizenet_echeck.php on line 94.

    [14-Apr-2021 16:49:55 America/New_York] Request URI: /adminnew/index.php?cmd=modules&set=payment&module=authorizenet, IP address: 24.164.151.237
    #1 authorizenet_echeck->authorizenet_echeck() called at [/shopcybermidi.com/adminnew/modules.php:204]
    #2 require(/shopcybermidi.com/adminnew/modules.php) called at [/shopcybermidi.com/adminnew/index.php:11]
    --> PHP Warning: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_ECHECK_ORDER_STATUS_ID - assumed 'MODULE_PAYMENT_AUTHORIZENET_ECHECK_ORDER_STATUS_ID' (this will throw an Error in a future version of PHP) in /shopcybermidi.com/includes/modules/payment/authorizenet_echeck.php on line 97.

    [14-Apr-2021 16:49:55 America/New_York] PHP Parse error: syntax error, unexpected '[', expecting ';' or ',' in /shopcybermidi.com/includes/modules/payment/linkpoint_api.php on line 320

    [14-Apr-2021 16:49:55 America/New_York] Request URI: /adminnew/index.php?cmd=modules&set=payment&module=authorizenet, IP address: 24.164.151.237
    --> PHP Parse error: syntax error, unexpected '[', expecting ';' or ',' in /shopcybermidi.com/includes/modules/payment/linkpoint_api.php on line 320.

  6. #6
    Join Date
    Jan 2004
    Posts
    66,335
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Can't edit Payment Modules

    Those logs point out the existence of two old payment modules that are no longer part of core Zen Cart.
    I'm guessing you did an upgrade recently but didn't delete obsolete files from your server?

    /includes/modules/payment/linkpoint_api.php
    /includes/modules/payment/authorizenet_echeck.php
    /includes/languages/english/modules/payment/linkpoint_api.php
    /includes/languages/english/modules/payment/authorizenet_echeck.php

    When doing upgrades it's worth cleaning up all other files no longer used by your Zen Cart version.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Sep 2004
    Posts
    173
    Plugin Contributions
    0

    Default Re: Can't edit Payment Modules

    Fixed. Thank you, I appreciate it.

 

 

Similar Threads

  1. v155 Can't Edit Payment Modules
    By cyberfolli in forum Addon Payment Modules
    Replies: 9
    Last Post: 18 Aug 2017, 08:40 PM
  2. Can't Install/Edit Payment Modules
    By sam_brew in forum Installing on a Linux/Unix Server
    Replies: 5
    Last Post: 21 Aug 2011, 02:21 PM
  3. Can't edit on payment modules page?
    By bogie in forum General Questions
    Replies: 13
    Last Post: 28 Sep 2009, 06:58 PM
  4. Can't (un)install/edit payment-modules
    By mrtorrez in forum Basic Configuration
    Replies: 4
    Last Post: 21 Sep 2006, 09:50 PM
  5. Can't (un)install/edit payment-modules
    By mrtorrez in forum Built-in Shipping and Payment Modules
    Replies: 0
    Last Post: 21 Sep 2006, 01:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR