Thread: Logging Errors

Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2012
    Location
    West Jefferson, NC
    Posts
    304
    Plugin Contributions
    0

    Default Logging Errors

    site URL - localhost
    ZC version - 156c
    list of plugins - none...except the one I am developing for importing mass data into the catalog.
    PHP version - 7.4

    STORE_PAGE_PARSE_TIME is not defined anywhere in zencart according to the search in developer tools.

    Code:
         Searching 346 files ... for: STORE_PAGE_PARSE_TIME
     
    /var/www/html/zc156c/ElleN-beY-toRch/includes/application_bottom.php
    
    Line #15 :   if (STORE_PAGE_PARSE_TIME == 'true') {
    /var/www/html/zc156c/ElleN-beY-toRch/includes/classes/logger.php
    
    Line #46 :     error_log(strftime(STORE_PARSE_DATE_TIME_FORMAT) . ' [' . $type . '] ' . $message . "\n", 3, STORE_PAGE_PARSE_TIME_LOG);
    /var/www/html/zc156c/ElleN-beY-toRch/includes/functions/general.php
    
    Line #  21 :     if (STORE_PAGE_PARSE_TIME == 'true') {
    Match Lines found: 3 --- Searching 346 files ... for: STORE_PAGE_PARSE_TIME
    I have been getting this error:

    Code:
    PHP Warning: Use of undefined constant STORE_PAGE_PARSE_TIME - assumed 'STORE_PAGE_PARSE_TIME' (this will throw an Error in a future version of PHP) in /var/www/html/zc156c/ElleN-beY-toRch/includes/functions/general.php on line 21.
    It looks like there are remnants of old code in general.php and logger.php or the define has been accidentally left out...not sure which one it is.

  2. #2
    Join Date
    Jul 2012
    Posts
    16,043
    Plugin Contributions
    17

    Default Re: Logging Errors

    Out of curiosity, is there a reason that developing a new set of software instead of using existing?

    The constant is defined for a fresh install at: https://github.com/zencart/zencart/b...cart.sql#L2552

    And for an upgrade is even covered again, just-in-case, at: https://github.com/zencart/zencart/b...rt_156.sql#L50

    So... how is it that this store doesn't have the constant in the database? E.g., what's the history of the database? What's the history of the software?

    Note here: https://docs.zen-cart.com/user/first..._requirements/

    1.5.6 is compatible up to php 7.3 (as reported there anyways). So not sure how much that factors into the issue either.
    Last edited by mc12345678; 18 Jul 2021 at 10:53 PM.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  3. #3
    Join Date
    Jul 2012
    Posts
    16,043
    Plugin Contributions
    17

    Default Re: Logging Errors

    I'll note that in ZC 1.5.7, that entire "process" has been removed from the core files. Implementation would use an observer to capture related data if it is/was necessary for diagnostics. A possible scenario here is that a 1.5.7 database was applied to a 1.5.6 set of software... or as I have occasionally seen, the configuration didn't appear to be something desired to use/access so it was just removed from the database. That way it couldn't be abused even though the software wasn't prepared for its complete absence of being set...
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  4. #4
    Join Date
    Sep 2012
    Location
    West Jefferson, NC
    Posts
    304
    Plugin Contributions
    0

    Default Re: Logging Errors

    [QUOTE=mc12345678;1382563]Out of curiosity, is there a reason that developing a new set of software instead of using existing?

    The constant is defined for a fresh install at: https://github.com/zencart/zencart/b...cart.sql#L2552

    And for an upgrade is even covered again, just-in-case, at: https://github.com/zencart/zencart/b...rt_156.sql#L50

    So... how is it that this store doesn't have the constant in the database? E.g., what's the history of the database? What's the history of the software?

    Note here: https://docs.zen-cart.com/user/first..._requirements/

    1.5.6 is compatible up to php 7.3 (as reported there anyways). So not sure how much that factors into the issue either.[/QE]

    It is not in the database and it is not defined in the files. I haven't edited the file where the define should be located. The database is a fresh install on Ubunttu 20.04 LAMP.

    I have had the files since 1.5.6c came out originally. I quit developing for quite a while and am in the process of converting everything over to the newest version...1.5.7c. First, I have to get 1.5.6c working again...maybe not since php 7.3 was the highest version supported...I am using 7.4.

    Thanks for your help and clarification.

  5. #5
    Join Date
    Sep 2012
    Location
    West Jefferson, NC
    Posts
    304
    Plugin Contributions
    0

    Default Re: Logging Errors

    [QUOTE=mc12345678;1382563]Out of curiosity, is there a reason that developing a new set of software instead of using existing?

    The constant is defined for a fresh install at: https://github.com/zencart/zencart/b...cart.sql#L2552

    And for an upgrade is even covered again, just-in-case, at: https://github.com/zencart/zencart/b...rt_156.sql#L50

    So... how is it that this store doesn't have the constant in the database? E.g., what's the history of the database? What's the history of the software?

    Note here: https://docs.zen-cart.com/user/first..._requirements/

    1.5.6 is compatible up to php 7.3 (as reported there anyways). So not sure how much that factors into the issue either.[/QE]

    It is not in the database and it is not defined in the files on my system. I haven't edited the file where the define should be located. The database is a fresh install on Ubunttu 20.04 LAMP.

    I have had the files since 1.5.6c came out originally. I quit developing for quite a while and I am in the process of converting everything over to the newest version...1.5.7c. First, I have to get 1.5.6c working again...maybe not since php 7.3 was the highest version supported...I am using 7.4.

    As far as developing my add-on is concerned, there is only one other add-on that is remotely close to what mine does...and I do not like it. It is not reliable or kept up to date with versions.

    Thanks for your help and clarification.

  6. #6
    Join Date
    Sep 2012
    Location
    West Jefferson, NC
    Posts
    304
    Plugin Contributions
    0

    Default Re: Logging Errors

    Quote Originally Posted by mc12345678 View Post
    I'll note that in ZC 1.5.7, that entire "process" has been removed from the core files. Implementation would use an observer to capture related data if it is/was necessary for diagnostics. A possible scenario here is that a 1.5.7 database was applied to a 1.5.6 set of software... or as I have occasionally seen, the configuration didn't appear to be something desired to use/access so it was just removed from the database. That way it couldn't be abused even though the software wasn't prepared for its complete absence of being set...
    Interesting. I wonder if some files got crossed somewhere along the way.

    I'll just start fresh with 1.5.7c and move my modifications over from 1.5.6c

    Thanks.

  7. #7
    Join Date
    Jul 2012
    Posts
    16,043
    Plugin Contributions
    17

    Default Re: Logging Errors

    [QUOTE=mikeel100;1382588]
    Quote Originally Posted by mc12345678 View Post
    Out of curiosity, is there a reason that developing a new set of software instead of using existing?

    The constant is defined for a fresh install at: https://github.com/zencart/zencart/b...cart.sql#L2552

    And for an upgrade is even covered again, just-in-case, at: https://github.com/zencart/zencart/b...rt_156.sql#L50

    So... how is it that this store doesn't have the constant in the database? E.g., what's the history of the database? What's the history of the software?

    Note here: https://docs.zen-cart.com/user/first..._requirements/

    1.5.6 is compatible up to php 7.3 (as reported there anyways). So not sure how much that factors into the issue either.[/QE]

    It is not in the database and it is not defined in the files on my system. I haven't edited the file where the define should be located. The database is a fresh install on Ubunttu 20.04 LAMP.

    I have had the files since 1.5.6c came out originally. I quit developing for quite a while and I am in the process of converting everything over to the newest version...1.5.7c. First, I have to get 1.5.6c working again...maybe not since php 7.3 was the highest version supported...I am using 7.4.

    As far as developing my add-on is concerned, there is only one other add-on that is remotely close to what mine does...and I do not like it. It is not reliable or kept up to date with versions.

    Thanks for your help and clarification.
    Unfortunately it appears there are several likely or highly potential issues.

    I doubt that there is just "one" such software and second not sure why so often there is such a splintering instead of building on or otherwise improving what already exists instead... But have at it.

    It looks like though that if in the process of "upgrading" to 1.5.7c, it seems that have jumped the gun and performed the database upgrade without using the latest software. E.g. have run the database upgrade on a 1.5.6 database to bring it to 1.5.7 but not using the 1.5.7 files. ZC 1.5.7 removed the constant from both the database and the fileset that is being reported as "missing from 1.5.6c". I would hazard to guess that if looked at the database actions in the 1.5.7 upgrade that would see that they have already been performed to this database. As a result, yes, 1.5.6 (and every previous version back to at least 1.5.2) would report the same issue with that database present against older files...
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  8. #8
    Join Date
    Sep 2012
    Location
    West Jefferson, NC
    Posts
    304
    Plugin Contributions
    0

    Default Re: Logging Errors

    You nailed it and I figured out where I went wrong. Sorry for the mix up.

    Yes, I did a fresh install of 1.5.7c and copied the newest db to 4 of my previous stores back to 1.5.5...stupid mistake.

    Moving forward, follow directions if I want it to work. LOL.

    Thanks for your help...close the thread if you like.

 

 

Similar Threads

  1. error logging: does ZC generate any error logging anywhere?
    By cyberbaffled in forum General Questions
    Replies: 4
    Last Post: 12 Jul 2014, 07:08 PM
  2. v151 Logging in twice - only after logging out
    By SarahL in forum Bug Reports
    Replies: 4
    Last Post: 1 Nov 2013, 07:53 PM
  3. category dressing errors and move add to cart errors
    By MachaNeko in forum Templates, Stylesheets, Page Layout
    Replies: 11
    Last Post: 18 May 2008, 02:29 PM
  4. Admin errors on fresh installation - module errors and language definition errors
    By etrader in forum Installing on a Linux/Unix Server
    Replies: 5
    Last Post: 5 Oct 2007, 09:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR