Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    422
    Plugin Contributions
    0

    Default 1.5.6c and PHP 7.4

    I am upgrading a client's shop to 1.5.7 but his live store is still on 1.5.6c. His hosting company is suggesting he upgrade to PHP 7.4. Want to check if that will break anything in his live shop (1.5.6c) since the release notes on 1.5.6 say "PHP 7.3 is recommended, but it "can" work with PHP 5.5 or newer" He is currently running PHP 7.2

    Thanks!

  2. #2
    Join Date
    Mar 2008
    Location
    Belgium
    Posts
    89
    Plugin Contributions
    6

    Default Re: 1.5.6c and PHP 7.4

    How about going to Developers Tools Kit in the Admin of the shop and looking for deprecated features in the files?
    One step at a time explaned in the links. Just make a list and search for them.

    Migrating from PHP 7.2.x to PHP 7.3.x
    Migrating from PHP 7.3.x to PHP 7.4.x

    The second link might have Zen Cart features.
    Both might have plugin features.

    I'm not a web designer but that's how I would do it.

  3. #3
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: 1.5.6c and PHP 7.4

    Server Requirements for Zen Cart says "Zen Cart v1.5.6 is designed for PHP 5.5 through PHP 7.3"
    You are likely to encounter extra "strict warnings" and perhaps some actual fatal errors when using PHP 7.4 with Zen Cart v1.5.6.

    But since you're already in the process of upgrading to Zen Cart v1.5.7 which has updates in it for PHP 7.4, once the upgrade is done you can certainly move to PHP 7.4.

    Why the rush to move to PHP 7.4 before finishing the Zen Cart upgrade?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #4
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    422
    Plugin Contributions
    0

    Default Re: 1.5.6c and PHP 7.4

    Quote Originally Posted by DrByte View Post
    Server Requirements for Zen Cart says "Zen Cart v1.5.6 is designed for PHP 5.5 through PHP 7.3"
    You are likely to encounter extra "strict warnings" and perhaps some actual fatal errors when using PHP 7.4 with Zen Cart v1.5.6.

    But since you're already in the process of upgrading to Zen Cart v1.5.7 which has updates in it for PHP 7.4, once the upgrade is done you can certainly move to PHP 7.4.

    Why the rush to move to PHP 7.4 before finishing the Zen Cart upgrade?
    Thanks for that. That's exactly what we ended up doing! :)

 

 

Similar Threads

  1. Replies: 2
    Last Post: 20 Dec 2016, 05:20 AM
  2. Replies: 2
    Last Post: 12 Jun 2015, 10:11 PM
  3. lay out inconsistency between index.php and alt_nav.php
    By Lucky1968 in forum Customization from the Admin
    Replies: 2
    Last Post: 4 Mar 2011, 09:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR