Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2007
    Location
    Bronx, New York, United States
    Posts
    496
    Plugin Contributions
    3

    Default Upgrading Database From vs. 1.5.3 to 1.5.7 giving errors.

    I'm running the script on an imported database from version 1.5.3. The script is running through OK but then it struggles on this part, telling me that the installer is detecting 1.5.5 and cannot go through until it gets to 1.5.6.

    I found another post saying to remove the check but for some reason, the database is STILL saying that it is 1.5.5:

    Name:  5Jf0SzM.jpg
Views: 92
Size:  26.8 KB

    Here are the relevant log files as posted:

    Code:
    ---------------
    Jun 18 2021 8:58 -- Version detected in database_upgrade/header_php.php
    1.5.5
    Pastebin of Log #1: https://pastebin.com/W9Pf6Pwm
    Pastebin of Log #2: https://pastebin.com/DgfnCMxJ

    I'd rather not flush the complete database out but I cannot figure out what would cause this to crash. The database has been modified but I do not see what parts of the DB could cause this hang up,

  2. #2
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,599
    Plugin Contributions
    117

    Default Re: Upgrading Database From vs. 1.5.3 to 1.5.7 giving errors.

    This means the upgrade from 1.5.5 to 1.5.6 failed.

    The most common reason for this is that you have old-format dates in the orders table.

    https://docs.zen-cart.com/user/upgra...d_not_upgrade/
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  3. #3
    Join Date
    Jun 2007
    Location
    Bronx, New York, United States
    Posts
    496
    Plugin Contributions
    3

    Default Re: Upgrading Database From vs. 1.5.3 to 1.5.7 giving errors.

    Quote Originally Posted by swguy View Post
    This means the upgrade from 1.5.5 to 1.5.6 failed.

    The most common reason for this is that you have old-format dates in the orders table.

    https://docs.zen-cart.com/user/upgra...d_not_upgrade/
    That did it. I ended up altering a few of the database and it works fine now.

  4. #4
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,599
    Plugin Contributions
    117

    Default Re: Upgrading Database From vs. 1.5.3 to 1.5.7 giving errors.

    Fantastic, thanks for confirming.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

 

 

Similar Threads

  1. v153 Database errors when upgrading from 1.5.3 to the latest 1.5.5a
    By icecold in forum Upgrading to 1.5.x
    Replies: 3
    Last Post: 14 Oct 2016, 04:13 PM
  2. v154 Chinese Language from Database Garbled after upgrading from v137
    By haostaff in forum Upgrading to 1.5.x
    Replies: 2
    Last Post: 21 May 2015, 04:01 AM
  3. Replies: 2
    Last Post: 27 Jun 2008, 05:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR