Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2005
    Location
    Chicago, IL USA
    Posts
    1,487
    Plugin Contributions
    28

    Default Authorize.net payhment received but no order in database

    This has happened twice now. A payment is processed in Authorize.net but there is no order in Zen Cart. I know the payment is from Zen Cart because of the order ID reported, 5365-AiiwHj. 5365 is the next order number in Zen Cart, but there is no such order number.

    The site is a recent upgrade, 1.5.7c from 1.5.6a
    Using Authorize.net (AIM)
    PHP 7.4.22
    Session settings: https://screenrec.com/share/TdE9bq6S0H
    curltester.php returns all "Good" results

    I have not seen this problem before. Suggestions?

  2. #2
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,987
    Plugin Contributions
    109

    Default Re: Authorize.net payhment received but no order in Zen Cart

    Did you check for debug logs? If you run an order with a different payment method like Check/Money Order, does everything work properly?
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  3. #3
    Join Date
    Jul 2012
    Posts
    16,037
    Plugin Contributions
    17

    Default Re: Authorize.net payhment received but no order in Zen Cart

    Debug logs generated?
    First thought is to go ahead and do a remove and reinstall of the payment plugin (taking note of all the settings before doing so) and possibly backing up the database.

    Appears there is something that is going wrong during the checkout_process or checkout_success steps. If I remember correctly this is a lot like the issue that occurs with say PayPal standard where information is captured and passed around a little, but an issue occurs before ZC is notified of the successful transactions and then takes action to log the purchase. Sometimes the issue in that case is with the email account, sometimes with storage availability and sometimes just doesn't work out or get alignment of the purchase info with what has been captured about the purchase.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  4. #4
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,635
    Plugin Contributions
    78

    Default Re: Authorize.net payhment received but no order in Zen Cart

    For cases like these, I normally check the site's hosted "Raw Access Logs" to see how the customer traversed through the site when the issue occurred.

  5. #5
    Join Date
    Oct 2005
    Location
    Chicago, IL USA
    Posts
    1,487
    Plugin Contributions
    28

    Default Re: Authorize.net payhment received but no order in Zen Cart

    Thank you for the suggestions. Looking at the logs folder, I am seeing a few different errors related to sessions and memory issues but I think there is a different underlying problem. PHP is set for 128M. I'd doing a little more digging.

 

 

Similar Threads

  1. Receiving Authorize.Net authorizations but no order info in my Zen Admin Console
    By trevally in forum Built-in Shipping and Payment Modules
    Replies: 6
    Last Post: 11 Jul 2012, 04:32 PM
  2. Charges showing in Authorize.net but no order in zencart
    By mrawers in forum General Questions
    Replies: 0
    Last Post: 9 Jul 2010, 04:00 AM
  3. cc charged but no order! Authorize.net
    By Olof Holte in forum Managing Customers and Orders
    Replies: 29
    Last Post: 10 Feb 2009, 11:04 PM
  4. Replies: 9
    Last Post: 20 Sep 2008, 02:55 AM
  5. Received payment, but no order in database
    By chulo34 in forum Managing Customers and Orders
    Replies: 4
    Last Post: 1 Jul 2007, 02:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR