Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,223
    Plugin Contributions
    111

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    Good catch - I'll bet that's what happened.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  2. #12
    Join Date
    Sep 2007
    Location
    Yorkshire
    Posts
    16
    Plugin Contributions
    0

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    Thanks MC12345678

    Your assumption was correct and that issue is now sorted, thanks.
    [QUOTE]ALTER TABLE customers ADD customers_secret varchar(64) NOT NULL default ' ';

    As I ran the above query, it flagged up issues with the dates in the gdpr columns, which are all "0000-00-00 00:00:00". I have tried to use the query below in @Install SQL Patches and it just says "an error has occurred, etc."

    ALTER TABLE zen_customers ALTER gdpr_accept_date SET DEFAULT '0001-01-01 00:00:00';
    If I run this query in the console in PHPmyadmin, it does not like "SET"? It says
    X A new statement was found, but no delimiter between it and the previous one. (near SET)
    Looked at the posts you flagged up and tried several different combinations of coding, but no luck yet!!

    also, if i update a product, the screen goes blank after pressing "Update" and I get this warning

    [01-Dec-2021 08:49:06 Europe/London] Request URI: /admin1/index.php?cmd=product&cPath=29&pID=174&action=new_product_preview, IP address: 86.168.218.100
    #1 header() called at [/admin1/includes/init_includes/init_templates.php:27]
    #2 require_once(/admin1/includes/init_includes/init_templates.php) called at [/includes/autoload_func.php:37]
    #3 require(/includes/autoload_func.php) called at [/admin1/includes/application_top.php:37]
    #4 require(/admin1/includes/application_top.php) called at [/admin1/product.php:8]
    #5 require(/admin1/product.php) called at [/admin1/index.php:11]
    --> PHP Warning: Cannot modify header information - headers already sent by (output started at /admin1/includes/languages/english/product.php:93) in /admin1/includes/init_includes/init_templates.php on line 27.
    This is line 27
    header("Content-Type: text/html; charset=" . CHARSET);

  3. #13
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,223
    Plugin Contributions
    111

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    You have to fix gdpr_accept_date but you need a different set of steps.

    UPDATE customers SET gdpr_accept_date = '0001-01-01 00:00:00' WHERE gdpr_accept_date < '0001-01-01' and gdpr_accept_date is not null;

    ALTER TABLE customers MODIFY COLUMN gdpr_accept_date datetime NOT NULL default '0001-01-01 00:00:00';
    Last edited by swguy; 1 Dec 2021 at 12:46 PM.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  4. #14
    Join Date
    Sep 2007
    Location
    Yorkshire
    Posts
    16
    Plugin Contributions
    0

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    Thanks SWGUY

    All that updated and now getting a lot less Debug log files.

    Still getting the blank screen after modify/adding products and getting this

    [01-Dec-2021 13:34:54 Europe/London] Request URI: /admin1/index.php?cmd=product&cPath=25&pID=195&action=update_product, IP address: 86.168.218.100
    #1 header() called at [/admin1/includes/init_includes/init_templates.php:27]
    #2 require_once(/admin1/includes/init_includes/init_templates.php) called at [/includes/autoload_func.php:37]
    #3 require(/includes/autoload_func.php) called at [/admin1/includes/application_top.php:37]
    #4 require(/admin1/includes/application_top.php) called at [/admin1/product.php:8]
    #5 require(/admin1/product.php) called at [/admin1/index.php:11]
    --> PHP Warning: Cannot modify header information - headers already sent by (output started at /admin1/includes/languages/english/product.php:93) in /admin1/includes/init_includes/init_templates.php on line 27.

    [01-Dec-2021 13:34:54 Europe/London] Request URI: /admin1/index.php?cmd=product&cPath=25&pID=195&action=update_product, IP address: 86.168.218.100
    #1 header() called at [/admin1/includes/functions/general.php:19]
    #2 zen_redirect() called at [/admin1/includes/modules/update_product.php:130]
    #3 require(/admin1/includes/modules/update_product.php) called at [/admin1/product.php:33]
    #4 require(/admin1/product.php) called at [/admin1/index.php:11]
    --> PHP Warning: Cannot modify header information - headers already sent by (output started at /admin1/includes/languages/english/product.php:93) in /admin1/includes/functions/general.php on line 19.
    Any ideas?

  5. #15
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,223
    Plugin Contributions
    111

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    that's just a warning - it doesn't cause a blank screen. You'll have to find the issue that's causing a blank screen.

    Look in /admin1/includes/languages/english/product.php and see at the bottom if you have text after the closing ?>
    If so, remove that text (you don't even need the closing ?> but if it's there it must be the last thing in the file.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  6. #16
    Join Date
    Sep 2007
    Location
    Yorkshire
    Posts
    16
    Plugin Contributions
    0

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    Thanks swguy

    Its fixed, but I have no idea what the problem was??? There was no text after the ?> I deleted some text above that related to Youtube plugin that has stopped work since uggrade, but that made no difference. So I deleted the ?> and then retyped it back in and it now works properly.

    Any idea why some of my descriptions are a box within a box?? Whilst most are just a single box?
    See here https://www.lrbits.co.uk/index.php?m...roducts_id=130

    Cheers Mick

  7. #17
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,223
    Plugin Contributions
    111

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    Please create a new post to ask about the boxes - I think this post has been completed, and different people will answer your next questions.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  8. #18
    Join Date
    Mar 2006
    Location
    Auckland, New Zealand
    Posts
    211
    Plugin Contributions
    0

    Default Re: Upgraded to 1.5.7c.Working through the Debug Log Files.

    Quote Originally Posted by Jabbawocky View Post

    Any idea why some of my descriptions are a box within a box?? Whilst most are just a single box?
    See here https://www.lrbits.co.uk/index.php?m...roducts_id=130

    Cheers Mick
    I actually like your box within a box... looks funky and modern :-)
    Elemi

    The Art of Bespoke Aromatherapy
    www.AmorAromatherapy.co.nz

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. v154 Should I delete old Debug error Log files?
    By Maynards in forum General Questions
    Replies: 7
    Last Post: 27 Dec 2016, 01:30 PM
  2. v1.51 Clean Up Debug Log Files
    By haredo in forum Code Collaboration
    Replies: 2
    Last Post: 27 Nov 2013, 12:15 AM
  3. v151 "500" on Cleanup Debug Log Files, PHP 5.4
    By rayw1679 in forum General Questions
    Replies: 5
    Last Post: 5 Mar 2013, 07:06 AM
  4. PHP Error - Blank Page w/ log files from debug utility.
    By jester8131 in forum General Questions
    Replies: 2
    Last Post: 5 Feb 2010, 05:35 AM
  5. Debug utility not writing log files
    By zhamid in forum General Questions
    Replies: 1
    Last Post: 4 Jul 2009, 02:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR