Results 1 to 10 of 10
  1. #1
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Unidentified error on loading site

    http://www.nyfaeriefest.com , ZC1.5.0, few plugins but many customizations (Ultimate Fade-in Slideshow, Orders Export - my improved version, ??), PHP5.6. I couldn't see how to look up the MySQL version; cPanel says version 102 if that is meaningful, and says the database is okay. Installed and upgraded several times manually, most recently to v1.5.0.

    My host (Fastcomet) recently migrated my account to a different server farm (from Chicago to New Jersey if I recall correctly), and the website went down with an "undefined function mysql_connect()" error. They had upgraded from PHP5.6 to PHP7 without telling me. When I opened a ticket they promptly changed back to PHP5.6, but now I get an error message with zero information: "WARNING: An Error occurred, please refresh the page and try again." This is in both catalog and admin. I can find no current error logs in cPanel /cache, the most recent being a couple of weeks ago.

    Any ideas on what the issue might be and how to fix it? We are in the middle of registration season with vendors, performers and attendees trying to sign up and pay. Our webmail (host provided) still functions.

  2. #2
    Join Date
    Oct 2008
    Location
    Croatia
    Posts
    1,418
    Plugin Contributions
    16

    Default Re: Unidentified error on loading site

    Could it be that the mysql/mysqli extensions are not enabled in cPanel? Perhaps check your cPanel and see if you have PHP Selector and see if the mysql extension is ticked there.

    BTW, I'm shocked that YOU still have that relic, why haven't you upgraded yet?
    Zen Cart Point of Sale? Sure: ZX POS - v2 released
    My site - Pro ZC Help | My portfolio | My plugins

  3. #3
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    2,384
    Plugin Contributions
    9

    Default Re: Unidentified error on loading site

    Quote Originally Posted by balihr View Post
    Could it be that the mysql/mysqli extensions are not enabled in cPanel? Perhaps check your cPanel and see if you have PHP Selector and see if the mysql extension is ticked there.

    BTW, I'm shocked that YOU still have that relic, why haven't you upgraded yet?
    i am more apt to think it is a mysql in strict mode.... but i am just guessing.

    BTW, I'm shocked that YOU (balihr) still have not come up with a KILLER template for all to use!
    mxWorks now has premium plugins
    are you using square? have you shown any appreciation with cake on venmo or on paypal?
    called the savior by the chief bottle washer...

  4. #4
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Re: Unidentified error on loading site

    I presume the mysqli selector is irrelevant while the codebase only uses mysql_ functions.

    I know I should have upgraded years ago... the customizations I had done were so extensive that I dreaded adapting them to a newer version. Now one of my associates is building a new website from scratch on a completely different base and after this year's festival we will be replacing the original site, so a big expenditure of work would have little benefit (as long as it still functions).

  5. #5
    Join Date
    Oct 2008
    Location
    Croatia
    Posts
    1,418
    Plugin Contributions
    16

    Default Re: Unidentified error on loading site

    Quote Originally Posted by carlwhat View Post
    BTW, I'm shocked that YOU (balihr) still have not come up with a KILLER template for all to use!
    I have, but thanks to the stupid licensing on themeforest, I can't share it so I never wrapped it up as a distributable solution... And that same licensing kinda stopped me from making more... Sorry.

    Quote Originally Posted by gjh42 View Post
    I presume the mysqli selector is irrelevant while the codebase only uses mysql_ functions.
    Yeah, just mysql would be enough.

    Now one of my associates is building a new website from scratch on a completely different base and after this year's festival we will be replacing the original site, so a big expenditure of work would have little benefit (as long as it still functions).
    So you're leaving us as well after so many years? I wonder how many (if any) of us will be left in a year or two...
    Zen Cart Point of Sale? Sure: ZX POS - v2 released
    My site - Pro ZC Help | My portfolio | My plugins

  6. #6
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Re: Unidentified error on loading site

    I don't intend to abandon Zen Cart, though I stopped development work years ago because it was not giving me any rewards beside community while taking up considerable time. If I am ever able to re-establish my jewelry site (the domain name was pirated when I unknowingly let it lapse during concentration on festival management work) I will be using the latest ZC base.

    It looks like the error I get indicates failure to communicate with MySQL, so I have asked the host for help figuring that out.

  7. #7
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Re: Unidentified error on loading site

    I got some detailed info from the host:

    The MySQL version on the previous server was 5.7, while the MySQL version on the current server is MySQL 8. It does appear that only the latest version of Zen Cart, 1.5.7, supports MySQL with the previous versions only supporting MySQL 5.7. Apart from this, only the following error is currently spawned in the application's error log:

    > PHP Deprecated: Unparenthesized `a ? b : c ? d : e` is deprecated. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /home/nyfairie/public_html/includes/application_top.php on line 84

    This indicates that the code in your application is partially configured to work with higher PHP versions. Since it is possible that this is indeed the error in question, we would recommend that you review the file in question and adjust its code accordingly.

    The other error currently spawned in the server error logs (cPanel -> Errors) appears to be incomplete and is the following:

    > [Mon May 02 19:42:48.763172 2022] [:error] [pid 1489479:tid 22458190440192] [client 5.53.210.181:62732] where date_scheduled != 'NULL' in /home/nyfairie/public_html/includes/classes/db/mysql/query_factory.php on line 101

    However, we are unable to provide much more insight into it even after reviewing the mentioned file query_factory.php.

  8. #8
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    2,384
    Plugin Contributions
    9

    Default Re: Unidentified error on loading site

    ok. running 150... last bit of help from me... sorry, it's just too old...

    you will need your host to be able to provide access to your logs. 150, from what i remember, is before ZC logging overrides.

    post #1, you said the host moved you back down to php 5.6...

    this error:

    > PHP Deprecated: Unparenthesized `a ? b : c ? d : e` is deprecated. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)`

    indicates a php version of 7.4. see first item:

    https://www.php.net/manual/en/migrat...deprecated.php

    so they are running 7.4 on that server. 7.3 would NOT throw that notice. (nor would 5.6...)

    the date scheduled error is not providing any information as you need the whole error.

    without the error log, it will be slow going to track what is going down. but i would start with the host getting you to php 5.6 (if possible).

    i do not agree with the host's interpretation of the log messages.

    good luck.
    mxWorks now has premium plugins
    are you using square? have you shown any appreciation with cake on venmo or on paypal?
    called the savior by the chief bottle washer...

  9. #9
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Re: Unidentified error on loading site

    I found the complete error message that the host support said was imcomplete - they just didn't look at the whole thing.

    [02-May-2022 18:02:57 UTC] PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/nyfairie/public_html/includes/languages/fae1/english.php on line 16
    [02-May-2022 18:02:57 UTC] PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/nyfairie/public_html/includes/languages/english/email_extras.php on line 30
    [02-May-2022 18:02:57 UTC] PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/nyfairie/public_html/includes/languages/english.php on line 16
    [02-May-2022 18:02:57 UTC] PHP Fatal error: 1525:Incorrect DATETIME value: 'NULL' :: select banners_id, date_scheduled
    from banners
    where date_scheduled != 'NULL' in /home/nyfairie/public_html/includes/classes/db/mysql/query_factory.php on line 101

    This was from before I had anything done by the host, so still PHP7.4. They have now migrated me to a server farm that has not been upgraded and is supposedly exactly the same as my previous functioning environment. The migration has propagated per a test file they put on the new server, but I still get the unspecified error message when accessing the site root. I have notified them, waiting for response.

  10. #10
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Re: Unidentified error on loading site

    After a few more back-and-forths with host support and clearing my DNS cache, my site seems to be working fine for now. I have time to pursue options.

 

 

Similar Threads

  1. Error in https with Firefox - Site NOT loading
    By kevinmc3 in forum General Questions
    Replies: 1
    Last Post: 6 Dec 2010, 05:23 AM
  2. Half Frozen loading stuck site with text only loading
    By Zellcorp in forum Installing on a Windows Server
    Replies: 5
    Last Post: 1 Nov 2009, 09:16 AM
  3. Error loading Admin site
    By TeeGee in forum General Questions
    Replies: 2
    Last Post: 18 Jan 2008, 12:13 PM
  4. Site not loading with error present.
    By irrational in forum General Questions
    Replies: 3
    Last Post: 21 Sep 2007, 02:23 AM
  5. error when loading site
    By ner0tik in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 19 Apr 2007, 05:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR