Results 1 to 9 of 9
  1. #1
    Join Date
    May 2023
    Location
    Canada
    Posts
    50
    Plugin Contributions
    0

    Default Setup Freezes at Database Setup

    I am creating a test install on a Linux web server which also has Wordpress on it. My interface is through cPanel.

    I can reach the home page for the installation and start the setup process, but when I get to Database Setup, fill in the details of the new database and user for ZenCart, and click "Continue" the setup freezes with the progress bar between 25% and 90% complete. The message above the progress bar is something like "Loading Character Set Specific data 99%" or "Loading Demo Data 100%," Refreshing the page just brings me back to the Database Setup screen.

    The new database for Zen Cart is still only 4 KB so nothing is being added during the incomplete install.

    MySQL is version 10.5.21-MariaDB, I am pretty sure PHP is version 7.4
    Last edited by pixodaros; 22 Jul 2023 at 01:21 AM. Reason: added web server type

  2. #2
    Join Date
    Jul 2012
    Posts
    16,705
    Plugin Contributions
    17

    Default Re: Setup Freezes at Database Setup

    What logs are generated in the logs folder? Would expect some helpful information to exist, provided haven't tried to access the admin folder yet through your browser.

    Also, what is the origin of your fileset? Ver 1.5.8? Ver 1.5.8a or the latest on github?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  3. #3
    Join Date
    May 2023
    Location
    Canada
    Posts
    50
    Plugin Contributions
    0

    Default Re: Setup Freezes at Database Setup

    The version is 1.5.8a (the latest version linked from the ZenCart homepage).

    At my first look the logs at /home/mysite/public_html/zencart-1.5.8a-test/logs say something like this:

    Code:
    PHP Fatal error:  Uncaught Error: Class 'ZipArchive' not found in /home/mysite/public_html/zencart-1.5.8a-test/zc_install/ajaxLoadMainSql.php:57
    Stack trace:
    #0 {main}
      thrown in /home/mysite/public_html/zencart-1.5.8a-test/zc_install/ajaxLoadMainSql.php on line 57
    (There are also log files for the times I entered the wrong password, but those were easy to solve)
    Last edited by pixodaros; 22 Jul 2023 at 02:42 AM. Reason: fixed code tag

  4. #4
    Join Date
    May 2023
    Location
    Canada
    Posts
    50
    Plugin Contributions
    0

    Default Re: Setup Freezes at Database Setup

    Here is a thread with a similar error. It looks like the poster talked to their web host ("Dreamhost support was finally able to figure this out - they didn't tell me how they fixed it, but it's all set, thanks!"), I may try that in a few days.

    https://www.zen-cart.com/showthread....on-hangs-at-85

  5. #5
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    12,302
    Plugin Contributions
    87

    Default Re: Setup Freezes at Database Setup

    FWIW, it's never a good idea to use a webhost's 1-click install as those have been problematic for years.

    Copying the files to the web-hosted file-system via FTP or pulling a zip-file via cPanel's File Manager and extracting prior to running the zc_install process is much more reliable.

  6. #6
    Join Date
    Jul 2012
    Posts
    16,705
    Plugin Contributions
    17

    Default Re: Setup Freezes at Database Setup

    Did an internet search on the issue which didn't target a specific host, but that either the installation of a needed server package was missed or possibly the call in the code is not quite right or could be made slightly different.

    My guess though is that it is more likely that either the software is not available for access or the php.ini for your php 7.4 instance isn't invoking it.

    Reason why not using php 8.x?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  7. #7
    Join Date
    May 2023
    Location
    Canada
    Posts
    50
    Plugin Contributions
    0

    Default Re: Setup Freezes at Database Setup

    Quote Originally Posted by lat9 View Post
    FWIW, it's never a good idea to use a webhost's 1-click install as those have been problematic for years.
    Yes, I used the "copy the Zip file onto the web server with File Manager then extract it, load the URL, and install through the web interface" method because that is what the Zen Cart installation instructions recommend.

    Quote Originally Posted by mc12345678 View Post
    Did an internet search on the issue which didn't target a specific host, but that either the installation of a needed server package was missed or possibly the call in the code is not quite right or could be made slightly different.
    Did you mean results like https://stackoverflow.com/questions/...e-not-found-in Knowing whether the problem is with Zen Cart or with the server's configuration would help.

    Quote Originally Posted by mc12345678 View Post
    My guess though is that it is more likely that either the software is not available for access or the php.ini for your php 7.4 instance isn't invoking it.

    Reason why not using php 8.x?
    The web server seems to have PHP 8.0 installed but 7.4 is active. Because this is a working server not a pure test environment, I would want to ask the server provider why they set it up like that so I don't break something else. They support 25 databases so having both Wordpress and a test install of Zen cart should not be a problem but we live in Romulus' dump not Plato's republic.

  8. #8
    Join Date
    Jul 2012
    Posts
    16,705
    Plugin Contributions
    17

    Default Re: Setup Freezes at Database Setup

    Quote Originally Posted by pixodaros View Post
    The version is 1.5.8a (the latest version linked from the ZenCart homepage).

    At my first look the logs at /home/mysite/public_html/zencart-1.5.8a-test/logs say something like this:

    Code:
    PHP Fatal error:  Uncaught Error: Class 'ZipArchive' not found in /home/mysite/public_html/zencart-1.5.8a-test/zc_install/ajaxLoadMainSql.php:57
    Stack trace:
    #0 {main}
      thrown in /home/mysite/public_html/zencart-1.5.8a-test/zc_install/ajaxLoadMainSql.php on line 57
    (There are also log files for the times I entered the wrong password, but those were easy to solve)
    Quote Originally Posted by pixodaros View Post
    Yes, I used the "copy the Zip file onto the web server with File Manager then extract it, load the URL, and install through the web interface" method because that is what the Zen Cart installation instructions recommend.


    Did you mean results like https://stackoverflow.com/questions/...e-not-found-in Knowing whether the problem is with Zen Cart or with the server's configuration would help.


    The web server seems to have PHP 8.0 installed but 7.4 is active. Because this is a working server not a pure test environment, I would want to ask the server provider why they set it up like that so I don't break something else. They support 25 databases so having both Wordpress and a test install of Zen cart should not be a problem but we live in Romulus' dump not Plato's republic.
    The error called out above in this post is attempting to access a class that is only used in core code this one time.

    As to the issue being specifically something wrong with the overall software, it's not specifically an issue with overall zen cart otherwise there would be far more posts at this point about it. For a little background though, the primary developers have determined that installation of the demo data is "best" through this unzip process, even though that software or class is only managed this one time.

    A solution can be offered if your interested in continuing down a path of not getting the host to support. Basically it would be to offer direction of how to unzip the necessary files and as part of the code to skip the unzip process and search for the necessary upon which to take the next action.

    As to impact on other software, hopefully you are seeking upgrading that software to start using a current version of php. Php 7.4 is already outdated, unfortunately.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  9. #9
    Join Date
    May 2023
    Location
    Canada
    Posts
    50
    Plugin Contributions
    0

    Default Re: Setup Freezes at Database Setup

    Activating PHP 8.0 and turning on some more PHP packages appears to have solved this problem. Now I have a test install with test data.

 

 

Similar Threads

  1. System Setup Required...4 years after setup
    By advancing in forum General Questions
    Replies: 6
    Last Post: 12 Mar 2015, 06:07 PM
  2. v150 Database Setup Issue: Connection to Database failed, on iPage
    By tempoart in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 10 Jul 2012, 07:43 AM
  3. setup-database setup
    By craigearl in forum General Questions
    Replies: 5
    Last Post: 2 Feb 2010, 05:22 PM
  4. Install blank at Zen Cart™ Setup - Database Setup
    By ChamplainPictures in forum Installing on a Linux/Unix Server
    Replies: 7
    Last Post: 14 Feb 2008, 05:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR