Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    Join Date
    Aug 2007
    Location
    Gijůn, Asturias, Spain
    Posts
    2,595
    Plugin Contributions
    30

    Default Re: Problem with Product Images

    ok, I'll sit corrected.

    The inconsistency depending on location seems incorrect, and the allowing-anything-after-the-basename is a hole which has lead to this thread.

    For me, the big picture is the core image-handling process seems very unwieldly for 2024...
    Steve
    github.com/torvista: Spanish Language Pack, Google reCaptcha, Structured Data, Multiple Copy-Move-Delete, Image Checker, BackupMySQL Admin/Auto...

  2. #12
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    12,580
    Plugin Contributions
    88

    Default Re: Problem with Product Images

    Quote Originally Posted by torvista View Post
    ok, I'll sit corrected.

    The inconsistency depending on location seems incorrect, and the allowing-anything-after-the-basename is a hole which has lead to this thread.

    For me, the big picture is the core image-handling process seems very unwieldly for 2024...
    I agree that it's inconsistent, but making that change would result in sites that "followed the rules" for years having to go back and rename any additional images for images present in the root /images directory.

  3. #13
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    9,183
    Plugin Contributions
    11

    Default Re: Problem with Product Images

    How about providing a switch somewhat similar to the option of 0 vs 3 in columns for bootstrap?

    I feel this was wrong from the start and that fact is not a very good reason for continuing.

    Still trying to find code and fix.

  4. #14
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    9,183
    Plugin Contributions
    11

    Default Re: Problem with Product Images

    What is so frustrating to figure out is that any product found by searching 11 has the "problem".

    Any product found by searching for 01 does not.

  5. #15
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    9,183
    Plugin Contributions
    11

    Default Re: Problem with Product Images

    Revisiting this as I think there may be an inherent bug somewhere in the system.

    Let me know where my thinking is incorrect.

    ncludes/modules/main_product_image.php uses lines 19 - 22 to strip the extension from the products image.
    Code:
    $products_image_extension = '.' . pathinfo($products_image, PATHINFO_EXTENSION);$products_image_base = str_replace($products_image_extension, '', $products_image);
    $products_image_medium = $products_image_base . IMAGE_SUFFIX_MEDIUM . $products_image_extension;
    $products_image_large = $products_image_base . IMAGE_SUFFIX_LARGE . $products_image_extension;
    Therefore, xxxx111.jpg, xxxx112.jpg, and xxxx113.jpg should be passed to the system as xxxx111, xxxx112, and xxxx113 removing the (.) along with the file extension.

    Then we move the to the product listing page and the additional images (in my case, xxxx111_a thru xxxx111_d)

    The same thing is done to provide a base for additional images in includes/modules/additional_images.php.

    What appears to be happening somewhere along the way is that the $poducts_image_base is being truncated to the first six characters after the extension is removed as the duplicate additional images only occur in products that have a match of the first six characters in the image filename.

    I can find no where in the additional images file that this is happening but perhaps it is happening elsewhere.

  6. #16
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    9,183
    Plugin Contributions
    11

    Default Re: Problem with Product Images

    An even better representation of the probblem is at https://russianradiantsa.com/index.p...oducts_id=1309.

    One item picking up ten images instead of just the one matching the product's image filename.

    Doing a workaround with DBIO means hours of work on each weekly input.

    This is one of those things that would send someone to S h o p i f y.

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Problem with product images
    By heathdog77 in forum General Questions
    Replies: 1
    Last Post: 13 Jul 2010, 10:21 PM
  2. Problem with Images on Product page
    By GPDMTR25 in forum General Questions
    Replies: 0
    Last Post: 7 Dec 2009, 01:10 AM
  3. Product Images Problem.? All images are Large?
    By jeffhardy in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 10 Apr 2009, 10:50 PM
  4. Problem with Add'l Images on a Product
    By Seanmyr in forum Setting Up Categories, Products, Attributes
    Replies: 4
    Last Post: 3 Apr 2009, 10:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR