Results 1 to 2 of 2

Hybrid View

  1. #1
    Join Date
    May 2006
    Plugin Contributions

    SSL works for Admin, Account Creation, NOT Login

    I am setting up ssl on an almost virgin install of zc-1.3. SSL is working fine for the admin system, and curtomers can use secure creation of new accounts fine, but they can NOT log in with SSL enabled. it just kicks them back to the main page as a non-logined ( ) user, and invites them to try logging in over again. I've spent a couple of hours looking through the forum and can find similar, but not quite the same or helpful examples. any ideas?

    here's my config->sessions

    Session Directory /home/takspeed/
    Cookie Domain True Info
    Force Cookie Use False Info
    Check SSL Session ID False Info
    Check User Agent False Info
    Check IP Address False Info
    Prevent Spider Sessions True Info
    Recreate Session True Info
    IP to Host Conversion Status true

    end here's the relevant sections of admin/include/configure.php and include/configure.php respectively.


    define('HTTP_SERVER', '');
    define('HTTPS_SERVER', '');
    define('HTTP_CATALOG_SERVER', '');
    define('HTTPS_CATALOG_SERVER', '');

    // Use secure webserver for catalog module and/or admin areas?
    define('ENABLE_SSL_CATALOG', 'true');
    define('ENABLE_SSL_ADMIN', 'true');


    define('HTTP_SERVER', '');
    define('HTTPS_SERVER', '');

    // Use secure webserver for checkout procedure?
    define('ENABLE_SSL', 'true');

  2. #2
    Join Date
    May 2006
    Plugin Contributions

    Default Re: SSL works for Admin, Account Creation, NOT Login

    acting on an informed PM tip, I think that changing

    Recreate Session True

    to False, seems to be the fix.



Similar Threads

  1. Newsletter creation works for me, not for client
    By CiaW in forum General Questions
    Replies: 3
    Last Post: 20 Jan 2011, 04:45 AM
  2. rearrange login and account creation for split login
    By ctcentralinfo in forum Templates, Stylesheets, Page Layout
    Replies: 4
    Last Post: 16 Jul 2008, 07:45 AM
  3. SSL for login and account creation
    By jrelwell in forum General Questions
    Replies: 2
    Last Post: 5 Aug 2007, 08:15 AM
  4. SSL and Admin Login (config file) - only works with dedicated IP???
    By firstimpression in forum General Questions
    Replies: 6
    Last Post: 26 Jan 2007, 10:38 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Zen-Cart, Internet Selling Services, Klamath Falls, OR