Thread: Ask A Question

Page 4 of 40 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 399
  1. #31
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    9,751
    Plugin Contributions
    124

    Default Re: Ask A Question

    When I did it in my cart, the button did not say, "Ask a Question" (I didn't use the supplied button), so I had to add some link text - but I forgot to delete this when I posted the solution. Thanks to Phid for noticing this - but he has missed one problem line (the extra div). The correct code is

    <div id="askQuestion" class="biggerText">
    <?php
    echo '<a href="' . zen_href_link(FILENAME_ASK_A_QUESTION, 'products_id=' . $_GET['products_id']) . '">' .
    zen_image_button(BUTTON_IMAGE_ASK_A_QUESTION, BUTTON_ASK_A_QUESTION_ALT) . '</a>'; ?>
    </div>
    <br />
    <br class="clearBoth" />

    Thanks,
    Scott
    That Software Guy. My Store: Zen Cart Support
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  2. #32
    Join Date
    Nov 2005
    Location
    Narnia
    Posts
    822
    Plugin Contributions
    0

    Default Re: Ask A Question

    Actually I saw that extra div and had to delete it from my page because it was messing things up. I guess I wasn't totally sure if it was a problem specific to my site because of the special formatting I'm doing. Regardless, it now looks good and the button is appearing.

    P.S. in the contrib I downloaded only yesterday or the day before there were no button instructions included....only a reference to "Alternately, you may use the button provided."

  3. #33
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    9,751
    Plugin Contributions
    124

    Default Re: Ask A Question

    Just downloaded the latest version (1.3.5) and button directions were there on l. 84-113. Are you sure you didn't download an old copy? This one has been up since 09/23.

    In the next round, I will add the documentation fixes you have suggested.

    Thanks,
    Scott
    That Software Guy. My Store: Zen Cart Support
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  4. #34
    Join Date
    Oct 2005
    Posts
    97
    Plugin Contributions
    0

    Default Re: Ask A Question

    Hey there. I've install this module before and don't think I've had this problem, but the TEXT AREA is covering up the "Your question/message/whatever" bit. I feel like I've seen something about this before on the forums, but all I could find was about the Tell A Friend module and it was a different problem. Any ideas?

    http://dana.lbdsites.com/index.php?m...products_id=79

    Thanks!


    Leila

  5. #35

    Default Re: Ask A Question

    Ok...I'm stuck.

    This mod is great....exactly what I was hoping for....

    There's only one problem...when I click the "Ask a Question" button, I get:
    Warning: main(includes/templates/template_default/templates/tpl_ask_a_question_default.php): failed to open stream: No such file or directory in xxxxx/includes/templates/template_default/common/tpl_main_page.php on line 115

    Warning: main(includes/templates/template_default/templates/tpl_ask_a_question_default.php): failed to open stream: No such file or directory in xxxxx/includes/templates/template_default/common/tpl_main_page.php on line 115

    Fatal error: main(): Failed opening required 'includes/templates/template_default/templates/tpl_ask_a_question_default.php' (include_path='.:/usr/local/lib/php') in xxxxx/includes/templates/template_default/common/tpl_main_page.php on line 115

    where "xxxxx" of course is the rest of the server path....
    I've checked that particular directory and the files ARE in fact there....I'm wondering if I may have missed something? Can anyone shed any light on what my little brain cramp may have been??

    Site URL is www.twistedsteel4x4.com

    Thanks so much!!!!

  6. #36

    Default Re: Ask A Question

    Nevermind.....figured out what I did wrong...was my own stupidity....

    One of those moments

  7. #37
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    9,751
    Plugin Contributions
    124

    Default Re: Ask A Question

    rvagrrl, I notice you have <br class="clearBoth" /> after your textarea for message input
    and you're not using float:left on it. I would change these things.

    Good luck,
    Scott
    That Software Guy. My Store: Zen Cart Support
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  8. #38
    Join Date
    Nov 2003
    Location
    Haarlem | Netherlands
    Posts
    1,987
    Plugin Contributions
    15

    Default Re: Ask A Question

    Quote Originally Posted by swguy View Post
    rvagrrl, I notice you have <br class="clearBoth" /> after your textarea for message input
    and you're not using float:left on it. I would change these things.
    I just tried to add to the CSS:
    Code:
    textarea{
    clear: both;
    }
    And that seems the fix rvagrrl's problem.

  9. #39
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    9,751
    Plugin Contributions
    124

    Default Re: Ask A Question

    Paulm, are you using the FF Web Developer extension? How did you perform this test? (I know you have a lot of knowledge in this area, and others would benefit from hearing how you figure this sort of stuff out. )

    Thanks,
    Scott
    That Software Guy. My Store: Zen Cart Support
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  10. #40
    Join Date
    Nov 2003
    Location
    Haarlem | Netherlands
    Posts
    1,987
    Plugin Contributions
    15

    Default Re: Ask A Question

    Hi scott,

    Paulm, are you using the FF Web Developer extension?
    Yep

    How did you perform this test?
    By using the web developer extension and editting the CSS (press Ctrl+Shift+e but I assume you already knew about this feature?).

    I know you have a lot of knowledge in this area, and others would benefit from hearing how you figure this sort of stuff out.
    :-) Very nice to hear that.

    More in general it's:

    1.) Reading two books about CSS (written by Eric meyer)

    2.) Years of trail and error (which is still going on). Not very scientific, I know ;-)

    3.) Using tools (approx. 90% using the formentioned web developer tool, 5% using HTML kit (copying and pasting and preview HTML source), 2% using HTML validators and 3% using other tools).

    hth

 

 
Page 4 of 40 FirstFirst ... 2345614 ... LastLast

Similar Threads

  1. Ask A Question module
    By okibi in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 18 Apr 2007, 01:55 PM
  2. Ask a question 1.7
    By Kodam in forum All Other Contributions/Addons
    Replies: 7
    Last Post: 4 Apr 2007, 11:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR