Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2004
    Posts
    45
    Plugin Contributions
    0

    Default Fatal Error During upgrade from 1.3.0.2 to 1.3.5

    I've copied all the modified files into the folder and during upgrade after I click upgrade database it shows the following message. Please help me to solve the problem. Thanks

    Fatal error: main(): Failed opening required '../includes/classes/db/DB_TYPE/query_factory.php' (include_path='.;c:\php4\pear') in d:\usr\www\html\zen\zc_install\includes\modules\pages\database_upgrade\header_ph p.php on line 53

  2. #2
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,608
    Plugin Contributions
    25

    Default Re: Fatal Error During upgrade from 1.3.0.2 to 1.3.5

    This is due to a known problem with the way that Windows and PHP interact. Unfortunately it means that your config files got wiped out or emptied. Do you have backups of them?

    If so, overwrite any configs in admin/includes and includes with your backups. Make them read-only, and then do the database upgrade ignoring any warning messages about them not being writeable - the upgrade process doesn't need to change them.

    If you don't have backup you will need to manually create them either by editing your dist-configure files from scratch, or by doing an install in a similar directory and the editing the resulting config files to point to your actual site. It's a pain, but not too difficult. Help will be here if you need it.
    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  3. #3
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Fatal Error During upgrade from 1.3.0.2 to 1.3.5

    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. v151 Upgrade to 1.5 from a 1.3 version error during zc_install
    By marie893 in forum Upgrading to 1.5.x
    Replies: 5
    Last Post: 6 Oct 2012, 04:52 AM
  2. Replies: 7
    Last Post: 3 Jun 2012, 04:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR