Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23
  1. #21
    Join Date
    Jan 2011
    Posts
    284
    Plugin Contributions
    0

    Default Re: Your database appears to need patching to a higher level. See Tools->Server Infor

    I got this error message installing a brand-new copy of ZenCart through cPanel yesterday, and it was version 1.5.1. I immediately updated it to 1.5.5f, but the error is still there. I've already done quite a lot of work on it, so I don't want to have to start over from scratch. Please help? Thank you! Below is the information it's giving me.


    Server Host: cloud1040.hostgator.com (162.144.19.11)
    Server OS: Linux 3.10.0-693.17.1.2.ELK.el6.x86_64
    Server Date: 05/06/2018 06:56:39
    Server Up Time: 06:56:39 up 44 days, 8:49, 0 users, load average: 0.03, 0.01, 0.00
    HTTP Server: Apache
    PHP Version: 5.5.37 (Zend: 2.5.0)
    PHP File Uploads: On
    Upload Max Size: 64M
    PHP Memory Limit: 256M
    POST Max Size: 64M
    Database: MySQL 5.6.32-78.1
    Database Host: localhost (127.0.0.1)
    Database Date: 05/06/2018 06:56:39
    Database Data Size: 2,045 kB
    Database Index Size: 739 kB
    MySQL Slow Query Log Status: On
    MySQL Slow Query Log File: /var/lib/mysql/cloud1040-slow.log
    MySQL Mode: NO_ENGINE_SUBSTITUTION

    Zen Cart
    Zen Cart 1.5.5f
    Database Patch Level: 1.5.1
    v1.5.1 [2018-05-05 16:54:10] (New Installation)
    v1.5.1 [2018-05-05 16:54:10] (New Installation)

  2. #22
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    6,851
    Plugin Contributions
    8

    Default Re: Your database appears to need patching to a higher level. See Tools->Server Infor

    You've jumped on to an old thread but it's still somewhat pertinent.

    If I'm reading correctly you did your upgrade using the autoloader provided in cpanel by hostgator. If so, that's not the recommended way to go and you're apparently experiencing one of the major problems. Autoloaders are not prepared to upgrade as they generally do not include the zc_install directory.

    The zc_install directory will look for a non-current database and give you the option to upgrade. Here's what I suggest:
    1. backup your site completely
    2. download the latest ZC
    3. extract the zip and load the zc_install directory to your site.
    4. enter yoursite.com/zc_install and see if it gives you the option to upgrade your database (DO NOT CONTINUE WITH ANYTHING BUT UPGRADE)


    This should get the database where it needs to be.

    If the above is not the case, please let us know the steps used to upgrade.

  3. #23
    Join Date
    Jan 2011
    Posts
    284
    Plugin Contributions
    0

    Default Re: Your database appears to need patching to a higher level. See Tools->Server Infor

    Yeah, when I typed in the error message, it brought me to this page. I was hoping someone could help me even though it obviously dealt with the old-old versions of ZenCart. Thanks for that!

    IT WORKED PERFECTLY!!! Thank you so much!!!

 

 
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 4
    Last Post: 14 Dec 2010, 05:33 AM
  2. Your database appears to need patching to a higher level. See Tools->Server Informati
    By genesissystem in forum Upgrading from 1.3.x to 1.3.9
    Replies: 14
    Last Post: 19 Aug 2010, 06:35 AM
  3. Replies: 3
    Last Post: 16 Aug 2010, 11:14 PM
  4. Replies: 4
    Last Post: 10 Feb 2007, 10:44 PM
  5. Replies: 2
    Last Post: 3 Oct 2006, 05:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR