Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Join Date
    Oct 2011
    Posts
    32
    Plugin Contributions
    0

    red flag Need Help ~ Admin Settings

    Hello, I have a questions,

    I'm trying to change my password in zen cart and I'm getting this error, I see no fields or anything


    1054 Unknown column 'admin_level' in 'field list'
    in:
    [select admin_id, admin_name, admin_email, admin_pass, admin_level from zen_admin order by admin_name limit 0, 20]
    If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

  2. #2
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: Need Help ~ Admin Settings

    Please click Reply below and answer all the questions in the Posting Tips section of that screen.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Oct 2011
    Posts
    32
    Plugin Contributions
    0

    red flag Re: Need Help ~ Admin Settings

    What version of Zen Cart are you using? 1.3.9h
    Has your site been upgraded? When? From what version(s)? No
    What addons have you installed? When? None
    In what ways is your site customized or different from a brand new uncustomized install? Its not


    I changed my password about a month ago. I go to change it again and I can't

  4. #4
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: Need Help ~ Admin Settings

    Somehow your database has been changed and a required column/field is missing from the admin table.

    You need to find out why that is.

    A fresh clean install of Zen Cart v1.3.9h does indeed contain the admin_level column. So, either you've done something yourself which has deleted that column, or you've installed an addon that's deleted it, or you've been hacked by someone who's deleted it.

    If indeed you've done NOTHING to change the initial install of Zen Cart on your site, then perhaps a fresh new install after wiping all the files and deleting and recreating the database would be your smartest first step. And while you're at it you may as well use the latest version of Zen Cart. No point starting a new site on old code.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Oct 2011
    Posts
    32
    Plugin Contributions
    0

    red flag Re: Need Help ~ Admin Settings

    Quote Originally Posted by DrByte View Post
    Somehow your database has been changed and a required column/field is missing from the admin table.

    You need to find out why that is.

    A fresh clean install of Zen Cart v1.3.9h does indeed contain the admin_level column. So, either you've done something yourself which has deleted that column, or you've installed an addon that's deleted it, or you've been hacked by someone who's deleted it.

    If indeed you've done NOTHING to change the initial install of Zen Cart on your site, then perhaps a fresh new install after wiping all the files and deleting and recreating the database would be your smartest first step. And while you're at it you may as well use the latest version of Zen Cart. No point starting a new site on old code.


    This would be in the admin.php file correct? So if I just replace the admin.php file with a orig one would that work? I'm new to ZC so Im not sure how to update it without messing my shop up.

  6. #6
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: Need Help ~ Admin Settings

    No, it's not the admin.php file. It's the admin table in your database.
    What have you done to damage your database?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    May 2010
    Location
    WA State
    Posts
    1,692
    Plugin Contributions
    3

    Default Re: Need Help ~ Admin Settings

    Since this is the admin login being effected, I'd be looking at that table in the database poste-haste to see if any changes, (like new admins), have been added.
    The best way to learn is to try stuff. But, back it up first.

  8. #8
    Join Date
    Oct 2011
    Posts
    32
    Plugin Contributions
    0

    Default Re: Need Help ~ Admin Settings

    Quote Originally Posted by DrByte View Post
    No, it's not the admin.php file. It's the admin table in your database.
    What have you done to damage your database?
    I haven't done anything. My host ( JustHost ) was the last person to do anything to my site. Only because my sub domain wasnt on the same server as my main so they moved it. I'm not sure what to do.

  9. #9
    Join Date
    Oct 2011
    Posts
    32
    Plugin Contributions
    0

    Default Re: Need Help ~ Admin Settings

    I'm looking at my DB and i see "admin_level" is missing. How do i add it to the table? I don't remember how to

  10. #10
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: Need Help ~ Admin Settings

    Quote Originally Posted by SocalPotHead View Post
    What addons have you installed? When? None
    In what ways is your site customized or different from a brand new uncustomized install? Its not
    Um ... so what should I make of your prior posts which talk about addons you HAVE installed?
    http://www.zen-cart.com/forum/showth...87#post1081687
    http://www.zen-cart.com/forum/showthread.php?t=188936
    and another about adding a blog
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Need help with main page settings
    By Dashizna in forum Basic Configuration
    Replies: 3
    Last Post: 3 Dec 2011, 07:28 PM
  2. Need help with Attribute Settings
    By nrg77 in forum Setting Up Categories, Products, Attributes
    Replies: 2
    Last Post: 9 Jul 2007, 06:12 AM
  3. Settings for shipping - need help
    By blindman in forum Currencies & Sales Taxes, VAT, GST, etc.
    Replies: 0
    Last Post: 7 Aug 2006, 01:16 AM
  4. Table Rate settings: In need of help!
    By dori in forum Addon Shipping Modules
    Replies: 0
    Last Post: 20 Jul 2006, 06:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR