Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31
  1. #11
    Join Date
    Nov 2009
    Location
    Washington State USA
    Posts
    1
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    Quote Originally Posted by Yesac13 View Post
    Any leads on this? I'm not getting my password reset emails.

    If it is a hosting config problem, could anybody tell me what to start looking at. My hosting company, so far, has been unable to fix this problem.

    I have no other email problems, just that customers who forgot their emails never gets their emails with the new password...
    Using 1.3.8a the latest version and don't receive password reset emails either. If this is a hosting config problem please be more specific, so that it can be fixed.

    GC

  2. #12
    Join Date
    Nov 2008
    Posts
    166
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    Getting the same problem here on my new ZenCart installations.

  3. #13
    Join Date
    Dec 2009
    Posts
    26
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    I'm having the same problem... all email notices work except for password resets.

    After an email address is entered the site notifies the customer that an email has been sent with a new password. but nothing actually arrives.

    Any help would be greatly appreciated.

    Thanks

  4. #14
    Join Date
    Mar 2008
    Posts
    55
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    Ok, this is really bad.

    Zen Cart v1.3.8a/v1.3.8


    I have tried PHP. it won't send the email. dies with errors

    I've tried with sendmail, as shown below. It tells me it works, but I never see the email.

    Module: direct_email

    To: Robert Chalmers [robert@chalmers.com.au]
    From: Skin Care Australia [robert@chalmers.com.cn]
    Sent: 2010-01-22 00:34:51
    Subject: test from zencart

    Message Excerpt:

    yes, well.......



    I've tried with SMTP

    ERROR: Failed sending email to: "Robert Chalmers" with subject: "test from zencart" The following From address failed: robert@chalmers.com.cn

    and it fails no matter what address I use in the From field.

    ...
    now, sendmail-f appears to work as well as sendmail.
    Success: E-mail #2 has been resent to robert@chalmers.com.au


    SMTPAUTH fails.
    ERROR: Failed sending email to: "Robert Chalmers" with subject: "test from zencart" The following From address failed: robert@chalmers.com.cn

    QMAIL appears to work - and really quickly too.
    Success: E-mail #2 has been resent to robert@chalmers.com.au


    Summary:
    sendmail takes forever to process the email. I mean like about 5 minutes. appears to work. but I get no email

    sendmail-f the same.

    qmail appears to send the mail, and processes it very quickly. milliseconds, like it should.

    Nothing else even looks like sending mail, see errors above.

    To date, I have not received one single email from the system. !!!!

    Now as this whole thing relies on email to do business - this critical part of the system should be rock solid.

    I'm on a standard hosting server, alldomains.com on a linux server. Everything else I run has no problems with email. moodle, and a number of others.


    now this is really ODD. ODD I say. I have another ecommerce site, with zen-cart installed, on the same hosting server, and it uses PHP ---- and works with NO ERRORS - except of course it wont send the lost password. However - all other email works fine ???

    go figgure



    I don't understand why this one is failing....

    So any authoritative assistance would be really help full...

    thanks guys.

  5. #15
    Join Date
    Mar 2008
    Posts
    55
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email or admin email

    Ok, it seems that mail from the ADMIN is failing.

    I tried on my live site, where I sell audio-books etc, on the radio station site, http://www.quantum-radio.net/audio_zen/

    went into Admin, and Tools, send email - and guess what.

    Email Error: Could not instantiate mail function. Please check Admin->Configuration->Email Options->Email Transport.

    Now this site works for customers - although I haven't had a password needing to be resent yet.

    But - as Admin, PHP doesn't work to send email, giving the error above. Apparently - as a customer, it works for them.


    what's up doc.

  6. #16
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,186
    Plugin Contributions
    7

    Default Re: Could not receive Password Forgotten Email

    Regarding zen-cart and email.

    I don't profess to have all, or even any of the answers, but I do know several important facts that are relevant and worth keeping in mind.

    Firstly, not all ISP's use the same mail program(s), and those that do invariably have thier own settings and configurations in regards to what is, or isn't allowed.

    This is why zen-cart offers so many different email options. There is almost certainly at least one setting/option avaialble that will work with any given ISP. Some systems may even support several different methods.

    The trick is figuring out what your particular ISP supports and allows.

    Quote Originally Posted by rachalmers View Post
    I have tried PHP. it won't send the email. dies with errors
    This suggests that your ISP dissallows mail sent via this method.

    Quote Originally Posted by rachalmers View Post
    I've tried with sendmail, as shown below. It tells me it works, but I never see the email.
    Give it a few days and the mail will probably be returned to you as being undeliverable.

    Quote Originally Posted by rachalmers View Post

    To: Robert Chalmers [robert@chalmers.com.au]
    From: Skin Care Australia [robert@chalmers.com.cn]
    Is robert@chalmers.com.cn a valid email address on the server hosting your zencart? If not, this email will probably fail because the system will reject at as not being sent by an authorised sender.


    Quote Originally Posted by rachalmers View Post
    I've tried with SMTP
    This one is probably the least likely to work on a linux based system. Very few ISP's allow for this type of access, if it does work it often indicates that the server has been setup in such a way that it is vulnerable to abuse because very few (if any) checks and balances are in place.

    Quote Originally Posted by rachalmers View Post
    and it fails no matter what address I use in the From field.
    Have you tried using youraccountname@yourisp.com in the 'from' field?
    If anything is going to work it will be this.

    Quote Originally Posted by rachalmers View Post
    now, sendmail-f appears to work as well as sendmail.
    Success: E-mail #2 has been resent to robert@chalmers.com.au
    The 'success' here simply means that the sendmail program has accepted the mail. It doesn't suggest that the mail has actually left the server. It is possibly sitting in an outgoing mail spool (for any number of reasons).

    Quote Originally Posted by rachalmers View Post
    SMTPAUTH fails.
    ERROR: Failed sending email to: "Robert Chalmers" with subject: "test from zencart" The following From address failed: robert@chalmers.com.cn
    SMTPAUTH will only work if your server requires SMTP authorization. It is similar to SMTP in functionality, in that the mail is sent direct (rather than via sendmail) , but to avoid the abuse that is possible with regular SMTP this method requires authentication, which means you must define a valid username, password, host and port in the zencart settings. SMTPAUTH is generally only needed/required if you are using your ISP's servers as a relay. I would suggest that since zencart and the mailserver it uses are in the same domain this method probably isn't widely used. It would probably be one of the last methods that I'd be trying.

    Quote Originally Posted by rachalmers View Post
    QMAIL appears to work - and really quickly too.
    Success: E-mail #2 has been resent to robert@chalmers.com.au
    This is where things get a liitle 'blurred' (in my opinion). Sendmail and Qmail both serve the same purpose, and generally speaking only one or the other will be used by your ISP.
    The fact that BOTH appear to work with your ISP would imply a 'symbolic link' is being used, so when the mail is sent to sendmail it is actually going to Qmail (or vice verci). It would be wise to verify with your ISP which of these mail agents are actually being used and select the appropriate one. If set correctly it usually won't make a difference, but if your ISP haapens to have both programs avaialble and only one of them configured it is easy for mail to end up in a 'black hole'.


    Quote Originally Posted by rachalmers View Post
    Summary:
    sendmail takes forever to process the email. I mean like about 5 minutes. appears to work. but I get no email

    sendmail-f the same.

    qmail appears to send the mail, and processes it very quickly. milliseconds, like it should.
    I find this a bit disconcerting, because as stated above, sendmail and qmail are different programs that perform the same purpose. If both appear to work (and work correctly) it is (usually) by virtue of a symbolic link. The fact that you are getting different results implies both programs are installed. This will result in an administration nightmare, and I'd go as far to say that only one of them has actually be configured. Check with your host to see which one they are actually using.

    Quote Originally Posted by rachalmers View Post
    I'm on a standard hosting server,
    Yes, but which 'standard' (The nice thing about standards is that there are so many to choose from) <grin>

    Quote Originally Posted by rachalmers View Post
    alldomains.com on a linux server. Everything else I run has no problems with email. moodle, and a number of others.
    Wow. Moodle eh? That took me a bit by surprise. I guess you have something to do with the education system? I always though I'd be the only person here that's even heard of moodle (as popular as it is).

    Quote Originally Posted by rachalmers View Post
    now this is really ODD. ODD I say. I have another ecommerce site, with zen-cart installed, on the same hosting server, and it uses PHP ---- and works with NO ERRORS - except of course it wont send the lost password. However - all other email works fine ???

    go figgure
    This may (even probably) has something to do with the 'from' addresses being used? Some systems are pretty strict in this regard and will only accept/send emails from 'known' addresses.

    Quote Originally Posted by rachalmers View Post
    I don't understand why this one is failing....
    So any authoritative assistance would be really help full...

    thanks guys.
    I'm not going to be as bold to say I'm an authority in this regard, and I certainly can't say why yours is failing, but I can say that due to the sheer number of spammers and would-be abusers 'out there', most systems tend to get locked down pretty tight these days and it can sometimes take a bit of juggling and experimenting to find what works and what doesn't. There is no single answer or method that will work for everyone.

    I do have a couple of suggestions though.

    1. Try to get your webhost involved. They will have log files that will let them know *exactly* what is going on.

    2. If your host gives you cPanel for administration purposes have a look for the 'Mail troubleshooting' or the 'Email Delivery Route' module(s).
    Enter a few email addresses, eg robert@chalmers.com.cn It may provide a few clues as to what is going on (especially if the test mails are to one of your own aliases on the same server).

    Anyway, as I said at the start, I've no real answers or solutions for you, I'm just imparting a few things that I know that may or may not be helpful.

    Cheers
    Rod
    Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

  7. #17
    Join Date
    Mar 2008
    Posts
    55
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    Hi Rod,
    thanks for the breakdown. However - tried all the above.
    I've been working with coding for donkeys years now - and have countless other packages all running fine on the server. Some quite complex like Moodle, some as simple as instant downloads for audiobooks, and a couple of ecommerce sites. any number of mailers, like news letter subscriptions etc etc.

    phpinfo tells me that the linux server is running sendmail. In addition to this, the webmail side, that I don't use, uses qmail.

    all those email addresses you see are valid and belong to my domains, hosted on this same server.

    Well. Only recently taken up zen-cart - and what do you know. the core of the product - the email system - is a real dog.
    I've wandered across the forums, and the internet looking for answers, and as usual .... nada. although there are many many people having email problems. So I'm not alone.

    All of the above options I tried, were to see just what would work and what wouldn't. As it turns out - nothing works. In that I still haven't received even one email from the system. Oh sorry. My son tried a purchase on the audiobook site I ran up, and he got a text message back as an Order Confirmation. That's the only email I've ever seen from both systems. I thought the audiobooks one was working but it's not after all - only that order confirmation.
    So of all the software I have installed - only zen-cart wont deal with email properly. So I can say with confidence that it's not the ISP/Hosting service or server. It's not anything else but zen-cart as far as I can see.

    the email-archive addon tells me that email has been sent from the various tests - but there's no sign of it. So I need to go deeper it seems.

    so it looks like I'm going to have to delve into the code and try and see what is happening. what a pain. A real pain.

    Thanks for your thoughts on the subject Rod. All input is very welcome in case I miss something - as I'm sure I will :-)

    cheers
    Robert

  8. #18
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,186
    Plugin Contributions
    7

    Default Re: Could not receive Password Forgotten Email

    Quote Originally Posted by rachalmers View Post
    Well. Only recently taken up zen-cart - and what do you know. the core of the product - the email system - is a real dog.
    I've wandered across the forums, and the internet looking for answers, and as usual .... nada. although there are many many people having email problems. So I'm not alone.
    I have no doubts that you are not alone, and I do apologise if I told you many things you already knew. Hopefully I didn't appear to be condescending?

    Quote Originally Posted by rachalmers View Post
    All of the above options I tried, were to see just what would work and what wouldn't.
    Yes, it WAS pretty obvious that you had tried many things to see what did and didn't work.

    Quote Originally Posted by rachalmers View Post
    As it turns out - nothing works. In that I still haven't received even one email from the system. Oh sorry. My son tried a purchase on the audiobook site I ran up, and he got a text message back as an Order Confirmation. That's the only email I've ever seen from both systems. I thought the audiobooks one was working but it's not after all - only that order confirmation.
    I'm sure that this is as puzzleing to you as it is to me. As you know, computers are so pedantic they either work or they don't work. To have something partly work (or work sometimes) is really extremely unusual, and there is always a cause for it. It make me wonder what is different between the order confirmation that you did receive and all the mails that you aren't recieving.

    Quote Originally Posted by rachalmers View Post
    So of all the software I have installed - only zen-cart wont deal with email properly. So I can say with confidence that it's not the ISP/Hosting service or server. It's not anything else but zen-cart as far as I can see.
    I'd really like to agree with you on this, but there are many of us that don't appear to be having any problems with emails, so even though it clearly has *something* to do with zen-cart, the actual problem is a bit more subtle than that, and it would suggest that it has something to do with a configuration setting OR some sort of compatibilty issue with some hosts only.

    Quote Originally Posted by rachalmers View Post
    the email-archive addon tells me that email has been sent from the various tests - but there's no sign of it. So I need to go deeper it seems.

    so it looks like I'm going to have to delve into the code and try and see what is happening. what a pain. A real pain.
    I still reckon that getting your ISP involved (assuming you don't have access to the mail log files) would be the easiest next step. At least their findings may give a clue as to where you should be looking.

    Quote Originally Posted by rachalmers View Post
    Thanks for your thoughts on the subject Rod. All input is very welcome in case I miss something - as I'm sure I will :-)
    Well, we do all miss things at times - so tossing considered ideas and thoughts around is often all it takes.

    I'm pretty much out of ideas. I am convinced that the log files will hold the key to the problem (but not necesarily the solution ).

    Cheers
    Rod
    Last edited by RodG; 22 Jan 2010 at 03:22 PM.
    Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

  9. #19
    Join Date
    Mar 2008
    Posts
    55
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    I just checked the Moodle install. It uses PHP for mail, and is working fine? Has done for over a year and over a thousand students.

    PHP in zen doesn't work, returning an 'insubstantiate' error message.

    hmmm

  10. #20
    Join Date
    Mar 2008
    Posts
    55
    Plugin Contributions
    0

    Default Re: Could not receive Password Forgotten Email

    and I see that in the osCommerce forums, the same problems are being talked about.
    I'm suspecting that it's a problem in the zen mail handling interface.
    The fact that some work and some don't is probably a factor of poorly configured host/server mail handlers that let anything through, rather than correctly configured zen installations.

    as I said, any number of other packages on my system work fine. Zen doesn't.

    When I find a solution to this, I'll post it for all to see.

 

 
Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. v154 Password Forgotten - Error: The Email Address was not found in our records;
    By kcb410 in forum Managing Customers and Orders
    Replies: 12
    Last Post: 25 Jan 2016, 06:50 PM
  2. v154 Forgotten Password Email Not Working for Customer
    By sparrowce in forum General Questions
    Replies: 6
    Last Post: 8 Aug 2015, 07:28 PM
  3. v153 Customers not receiving "Password Forgotten" email
    By t4gal in forum General Questions
    Replies: 24
    Last Post: 25 Nov 2014, 09:00 PM
  4. Forgotten Password Email Not Being Received
    By Heyzoos in forum General Questions
    Replies: 2
    Last Post: 6 Jun 2008, 09:04 PM
  5. Forgotten Password Email
    By deannasdreams in forum General Questions
    Replies: 4
    Last Post: 5 Jun 2008, 08:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR