Page 1 of 8 123 ... LastLast
Results 1 to 10 of 77
  1. #1
    Join Date
    Jan 2006
    Posts
    158
    Plugin Contributions
    0

    Default Newsletter won't send in HTML

    Admin gets emails just fine but I cannot send Newsletter emails in html format...the preview is fine, but it is recieved in plain text with the html stripped out. I have read everything I can find but can't find anything that solves the problem. Also the Admin email comes as plain text and also I have an account with a different email addy and it comes in plain text so I know the customers are getting plain text also. It's not just Admin email.

    Admin->Configuration->Email Options->Send MIME HTML Email ....is set to TRUE
    Admin->Configuration->Email Options->Admin Email Format .... set to html

    Any ideas why the email sends in plain text?

  2. #2
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Newsletter won't send in HTML

    1. What version of Zen Cart ?
    2. What is your "Email Transport" method set to ? What happens if you try other options?
    3. If you change the setting for "Email must send from known domain", does that help?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jan 2006
    Posts
    158
    Plugin Contributions
    0

    Default Re: Newsletter won't send in HTML

    1. Zen Cart 1.3.6
    2. sendmail...I can send an email to an individual customer as in Tools/Send Email and it sends just fine in html and is recieved just fine as html. So there's nothing wrong with the way it sends email therefore I don't want to mess with those settings.
    3. tried that, no

    Since all other types of email sends just fine as html and is recieved just fine as html, seems to me the problem is in the newsletter section somehow...

  4. #4
    Join Date
    Oct 2006
    Posts
    21
    Plugin Contributions
    0

    Default Re: Newsletter won't send in HTML

    Quote Originally Posted by Dizzie View Post
    1. Zen Cart 1.3.6
    2. sendmail...I can send an email to an individual customer as in Tools/Send Email and it sends just fine in html and is recieved just fine as html. So there's nothing wrong with the way it sends email therefore I don't want to mess with those settings.
    3. tried that, no

    Since all other types of email sends just fine as html and is recieved just fine as html, seems to me the problem is in the newsletter section somehow...
    Mine is the same the HTML previews OK but gets lost en-route, I've tried it using the HTML form in the admin and by building an email first in the Coffeecup editor, niether works.

    I sent them manually through Outlook Express now, bit of a chore but it's the only way it seems.

    Regards Steve

  5. #5
    Join Date
    Jan 2006
    Posts
    158
    Plugin Contributions
    0

    Default Re: Newsletter won't send in HTML

    I sent mine out and then found out it had stipped the the html...really embarrassing to the customers. Do you know how many hours it took to go thru every single customer information to make up a list of who is subscribed and who is not so I could send it out manually...yikes!
    Guess there's no fix for it....so I removed it and put my own "Notify Me of New Products" form on the front page.

  6. #6
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Newsletter won't send in HTML

    Some mailservers appear to strip HTML unpredictably. There doesn't seem to be a pattern to it.

    Exporting your email addresses to use in an external mailing program can be done simply with this addon:
    http://www.zen-cart.com/index.php?ma...products_id=80
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Mar 2005
    Posts
    92
    Plugin Contributions
    0

    Default Re: Newsletter won't send in HTML

    My problem was that when I sent a newsletter to the admin it always arrived in plain text no matter what i tried. I fixed this issue by creating a customer with the same email address as the admin. Set the customer profile to HTML and now I can send HTML newsletters to the admin.

    It appeared all the customers were getting the HTML newsletter when requested. It was just the admin that did not get it.

    Seems strange that the settings has a spot to set the admin email option but it did not work. I am running 1.3.7 on Windows server.

    Hope this helps. I searched the forum and did not find this solution.

  8. #8
    Join Date
    Jan 2006
    Posts
    158
    Plugin Contributions
    0

    Default Re: Newsletter won't send in HTML

    I created an account as if I were a customer so I recieved the newsletter as the admin and also to another email address as a customer....So I know the customers are not getting the email in html.....since this is a problem with no fix, I had to remove use of the newsletter and go thru each customer setting individually and find the ones subscribed to the newsletter to get their email addy. Now I send a newsletter using OE. But I had to set up a mailing list they can subscribe to on the front page of the store in place of a newsletter.

  9. #9
    Join Date
    Mar 2007
    Posts
    1
    Plugin Contributions
    0

    Default Re: Newsletter won't send in HTML

    I am having the same problem and can't find a solution. Anyone? I've tried everything mentioned as well and still it's a no-go. Version 1.3.7 for me.

  10. #10
    Join Date
    Nov 2006
    Location
    Papworth, Cambridgeshire, UK
    Posts
    731
    Plugin Contributions
    3

    Default Re: Newsletter won't send in HTML

    For email or newsletters sent from Admin there is a potential problem with the constant 'EMAIL_ENCODING_METHOD' not being defined to '8bit'.
    To fix this, copy the file email_use_8bit.php from /includes/extra_configures/ to /admin/includes/extra_configures/
    Each folder should have a copy of the file..

 

 
Page 1 of 8 123 ... LastLast

Similar Threads

  1. Replies: 0
    Last Post: 26 May 2012, 06:16 AM
  2. Unable to send newsletter by HTML
    By sharontan in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 23 Dec 2010, 05:32 PM
  3. How to send newsletter in HTML?
    By lina0962 in forum Discounts/Coupons, Gift Certificates, Newsletters, Ads
    Replies: 3
    Last Post: 16 Nov 2010, 08:56 PM
  4. Newsletter won't send
    By jvalent in forum General Questions
    Replies: 5
    Last Post: 30 Sep 2008, 08:21 PM
  5. Newsletter won't send in html...its just plain text!?
    By icklebits in forum General Questions
    Replies: 2
    Last Post: 26 Jul 2007, 03:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR