Page 101 of 357 FirstFirst ... 519199100101102103111151201 ... LastLast
Results 1,001 to 1,010 of 3563
  1. #1001
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    163
    Plugin Contributions
    0

    Default Re: Google Base Feeder Support Thread

    Question about this mod:

    Which version should I use for ZC version 1.3.7? Can I use the latest or do I need another version?

    Thank you!

  2. #1002
    Join Date
    Dec 2006
    Posts
    102
    Plugin Contributions
    0

    Default Re: Google Base Feeder Support Thread

    Quote Originally Posted by FatGuyinAZ View Post
    I just got it working with the following:

    Code:
    GET 'http://www.values-galore.com/googlefroogle.php?feed=yes&upload=yes&type=products' > /dev/null 2>&1
    I found this on the forum at http://www.numinix.com/forum
    I just got around to playing with the cron jobs, and you are right, this one works
    thanks

  3. #1003
    Join Date
    Jul 2007
    Posts
    2,169
    Plugin Contributions
    16

    Default Re: Google Base Feeder Support Thread

    This is a post from numinix web site about running cron jobs.


    powerhour

    So you want to manually have your base feed ftp to Google Base? Well, it doesn't work on GoDaddy's shared hosting accounts due to limitations. However, just login to google base and setup a scheduled fetch of your product feed.
    Enter the URL location of the feed: https://www.powerhourstore.com/feed/domain_products.xml

    It pretty much accomplishes the same tasks. It's auto-pilot!
    Response from numinix powerhour, that is really great information. I didn't know Google was now offering that service. I would definitely recommend this for everyone as it would also reduce cpu load from having a cron run on a daily schedule.
    I hope this helps some of you with this issue, it sure helped me.
    Is your site Upgraded to the current version 1.5.4 Yet?
    zencart-upgrades-website-installation

  4. #1004
    Join Date
    Dec 2007
    Posts
    30
    Plugin Contributions
    0

    Default Re: Google Base Feeder Support Thread

    Quote Originally Posted by greenhat View Post
    Following up on my own thread. After a few emails back and forth with GoDaddy, we figured out that they were wrong in their first email and that ftp from inside out is not allowed - something about security risk (didnt make much sense, since ftp access from outside in is allowed). They offered to get a different plan that would cost about 10 times the price of what im paying now - not an option.
    In case others here are in the same shoes , here's how i solved the problem:

    - signed up for a free (ad based) hosting here: reallyfreehosting.com (there are other free hosts out there..
    - wrote a script to create the product.xml file, download it from my site, and upload it to google
    - put the script in a cron job on the free hosting site..dont forget to set it to executable.

    here's the script (just replace all the variables and directories):

    #!/bin/sh
    USERNAME_TO="aaaaa"
    PASSWORD_TO="bbbbb"
    SERVER_TO="uploads.google.com"
    USERNAME_FROM="xxxxx"
    PASSWORD_FROM="yyyyy"
    SERVER_FROM="your_domain.com"

    FILE="zzzz_products.xml"
    FEED_DIR="/{your_store}/feed"


    #create new feed file
    curl "http://{your_domain}.com/{your_store}/googlefroogle.php?feed=yes&upload=no&type=products"

    sleep 10

    echo
    echo "file:$FILE created ... "
    echo

    # login to server and get product.xml file
    ftp -n $SERVER_FROM <<EOF
    user $USERNAME $PASSWORD_FROM
    cd $FEED_DIR
    get $FILE
    quit
    EOF

    echo "ftp download from server:$SERVER_FROM file:$FILE ...done!"


    # login to google server and upload the file
    ftp -n $SERVER_TO <<EOF
    user $USERNAME $PASSWORD_TO
    put $FILE
    quit
    EOF

    echo "ftp upload to server:$SERVER_TO file:$FILE ... done!"
    --------
    I tried this and the cron job is giving me :"command not found"? Any ideas?

  5. #1005
    Join Date
    Dec 2007
    Posts
    30
    Plugin Contributions
    0

    Default Re: Google Base Feeder Support Thread

    Quote Originally Posted by countrycharm View Post
    This is a post from numinix web site about running cron jobs.

    I hope this helps some of you with this issue, it sure helped me.
    I am going to try this and see if it works, scheduled to go off at noon!

  6. #1006
    Join Date
    Dec 2007
    Posts
    30
    Plugin Contributions
    0

    Default Re: Google Base Feeder Support Thread

    Worked, thanks!

  7. #1007
    Join Date
    Jul 2007
    Posts
    2,169
    Plugin Contributions
    16

    Default Re: Google Base Feeder Support Thread

    I'm glad you have it working.
    Is your site Upgraded to the current version 1.5.4 Yet?
    zencart-upgrades-website-installation

  8. #1008
    Join Date
    Apr 2007
    Location
    Vancouver, Canada
    Posts
    1,541
    Plugin Contributions
    81

    Default Re: Google Base Feeder Support Thread

    Quote Originally Posted by Hank3rd View Post
    I tried this and the cron job is giving me :"command not found"? Any ideas?
    That method would defeat the purpose of a cron job and would take just as much time to upload your feed file directly through the Google website or with your own client FTP program.

    The new method is the way to go and I will eventually update the documentation once I've tested it out myself.

  9. #1009
    Join Date
    Jun 2007
    Posts
    105
    Plugin Contributions
    0

    Default Re: Google Base Feeder Support Thread

    Quote Originally Posted by magneteye View Post
    Question about this mod:

    Which version should I use for ZC version 1.3.7? Can I use the latest or do I need another version?

    Thank you!
    Would like to know this as well, I have an old version running on 1.3.7 of google froogle, and a google base feeder. Wanted to dl the newest version will it work on 1.3.7

  10. #1010
    Join Date
    Feb 2007
    Location
    Earth
    Posts
    116
    Plugin Contributions
    1

    Default Re: Google Base Feeder Support Thread

    First off thanks for the contribution and support. I do however have one error on the feed that causes Google to break while processing the feed. It looks like an HTML character is the source of the problem "&uuml;". I replaced it with a regular "u" and everything worked fine. I am using 1.6.15 with zen 1.3.8. Does anyone else have problems with encoded letters? Should a string replace in zen_xml_sanitizer function be used to catch this?

    I have just decided to change this character to a regular "U" in my admin due mainly to SEO reasons. I don't know if it matters for those or not but it's a select number of products so why not. Thought I might point this out.

    Thanks

 

 

Similar Threads

  1. v150 Google Merchant Center Feeder for ZC v1.5.x [Support Thread]
    By DivaVocals in forum Addon Admin Tools
    Replies: 493
    Last Post: 2 Mar 2022, 12:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR