Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2004
    Posts
    33
    Plugin Contributions
    0

    Default empty delimiter / general problems with yourpay

    hey guys,

    i've used propay before, but this error is new to me. have the latest versions of the yourpay plugin and zencart. but i get this error (I *THINK* only when https is turned on):


    Warning: strstr(): Empty delimiter. in /nfs/cust/4/33/02/320334/web/onlinestore/includes/modules/payment/linkpoint_api.php on line 74

    I saw one or two mentions of this in the forums, but nothing that straight out told me what to do. Anyone have any ideas?

    The cart is located here. Feel free to create test accounts:

    https://www.erinlondon.com/onlinestore/

    I'm also having general problems at the end of checkout (regardless if i use http or https). It gives me that "sorry we can't communicate with the credit card company" error. I have followed the instructions included with the plugin (the .pem file is downloaded and on my server) so i'm scratching my head on that as well (could be connected with the above error but i'm not sure).

    So HELP please! :-)

  2. #2
    Join Date
    Jan 2004
    Posts
    66,362
    Blog Entries
    7
    Plugin Contributions
    274

    Default Re: empty delimiter / general problems with yourpay

    1. What version of Zen Cart?
    2. What patches have you installed?
    3. Has site been upgraded? From what versions?
    4. Are you running the Linkpoint/Yourpay module built-in to Zen Cart, or the older version from the downloads section?
    5. How long has this been happening? When did it last work properly?
    6. Does your hosting account support CURL ?
    7. Does your host firewall have port 1129 open bidirectionally for both UDP and TCP ? (ask your host)
    8. Who is your host?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Dec 2004
    Posts
    33
    Plugin Contributions
    0

    Default Re: empty delimiter / general problems with yourpay

    1. 1.3.7
    2. No patches that I recall.
    3. Nope, brand new.
    4. I wasn't aware or saw a built-in choice in the payment module, so i grabbed the one in the downloads section. Is there SUPPOSED to be one built-in?
    5. This happened the moment i installed the plugin (it's a newly built store). It has never worked (without the https, on standard http, i didn't get the php but the plugin still came back with the "sorry, can't communicate" error after the order confirmation screen.

    I'm not running the server so i'm asking someone to look into the other questions. I'm getting the empty delimiter error on the payment information (page 2 of 3) page so i'm guessing it's not CURL or port related.

    In the meantime, I would like to hear feedback on the above especially #4.

    Thanks!

  4. #4
    Join Date
    Dec 2004
    Posts
    33
    Plugin Contributions
    0

    Default Re: empty delimiter / general problems with yourpay

    i'm trying to be smart and investigate on my own a little.

    i found an (older?) linkpoint module, so i tried that. same error, different line number. so i compared the two modules and found out this is where it's having it's problems:

    if (strstr(EXCLUDE_ADMIN_IP_FOR_MAINTENANCE, $_SERVER['REMOTE_ADDR'])) {
    if ($this->code_debug) $this->enabled=true;
    }

    I did an echo on the $_SERVER variable and nothing shows up. Ok, this probably is the problem but i'm not sure on the cause OR the cure.

    Why would the $_SERVER variable be blank?

  5. #5
    Join Date
    Dec 2004
    Posts
    33
    Plugin Contributions
    0

    Default Re: empty delimiter / general problems with yourpay

    ok, think i solved it. tell me if this was smart or not.

    after the server variable didn't show up, i did more searches on the forum. and on the server variable itself.

    i changed the line of code from what you saw above to this:

    if (strstr(EXCLUDE_ADMIN_IP_FOR_MAINTENANCE, zen_get_ip_address())) {
    if ($this->code_debug) $this->enabled=true;
    }


    i'm guessing for some reason the host/server couldn't provide the REMOTE_ADDR. Why, I wonder?

    Anyway, the zen_get_ip_Address function seemed to remove the error message and i'm getting a successful test message / confirmation. this is still testing, not live, but i'm further than i was before!

    Feedback still welcome!

  6. #6
    Join Date
    Jan 2004
    Posts
    66,362
    Blog Entries
    7
    Plugin Contributions
    274

    Default Re: empty delimiter / general problems with yourpay

    That's acceptable, and indeed it's even one of the changes already in the code for the next version ... so you should be safe with that one.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. Empty delimiter
    By mcpisik in forum General Questions
    Replies: 4
    Last Post: 10 May 2012, 05:23 AM
  2. Warning: strpos Empty Delimiter
    By OJM in forum Installing on a Windows Server
    Replies: 2
    Last Post: 12 Nov 2007, 09:18 PM
  3. Empty delimiter error
    By TimBaloo in forum General Questions
    Replies: 5
    Last Post: 29 Jan 2007, 12:21 AM
  4. PHP Warning: Empty Delimiter
    By ioancuza in forum Templates, Stylesheets, Page Layout
    Replies: 8
    Last Post: 9 Dec 2006, 04:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR