Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2006
    Posts
    9
    Plugin Contributions
    0

    Default Payment modules missing in my admin

    I've been trying to set up my authorize.net payment account but was having issues because I wanted to set it up so their server accepts the CC# so I don't need an SSL cert. I disabled all my payment modules and then installed the php file for the next version (just uploaded the php files) then went back in to the admin to re-install it but there are no modules showing up. I manually went in to the configurations table and added the script names but still no go.

    Any ideas?

  2. #2
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Payment modules missing in admin

    First, what version of Zen Cart are you using?

    Quote Originally Posted by scottrof View Post
    disabled all my payment modules and then installed the php file for the next version
    "the next version"? Please explain.

    Quote Originally Posted by scottrof View Post
    I manually went in to the configurations table and added the script names
    where exactly?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jul 2006
    Posts
    9
    Plugin Contributions
    0

    Default Re: Payment modules missing in my admin

    1.3.7.1 is the version i'm on.

    I went in to the database and in to the table 'configurations' and added back in 'authorizenet.php' as 'configuration_value' where configuration_title = "Installed Modules". There must be something else missing. Again my guess is because all were disabled that it caused the problem.

    Again the Payment modules page has no modules listed.

  4. #4
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Payment modules missing in my admin

    There is NO need to manually edit the "Installed modules" key in the database. That happens automatically when modules are actually installed.

    If you have no modules showing, then Zen Cart is unable to find the files in your /includes/modules/payment folder.

    You didn't answer my question about what you meant by "the next version"
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jul 2006
    Posts
    9
    Plugin Contributions
    0

    Default Re: Payment modules missing in my admin

    I found the issue, when I had installed a new authorizenet.php module i left the backup file in the directory and that apparently messes things up. I moved it out and all was better.

    The "Next Version" i was referring to was there is a 1.3.8 version of the SIM authorize.net module which has more options.

    Now I have a new problem though, I get through the CC entering on the authorize.net site and it tries to send it back to the zen cart and I get a "Whoops! Your session has expired." error. I was getting this error when I tried the basick SIM module too. No CC info gets captured at authorize.net.



    Quote Originally Posted by DrByte View Post
    There is NO need to manually edit the "Installed modules" key in the database. That happens automatically when modules are actually installed.

    If you have no modules showing, then Zen Cart is unable to find the files in your /includes/modules/payment folder.

    You didn't answer my question about what you meant by "the next version"

 

 

Similar Threads

  1. payment modules missing in admin area
    By nemy in forum Addon Payment Modules
    Replies: 9
    Last Post: 6 Jan 2016, 09:15 PM
  2. v154 Payment modules missing in Admin
    By David R in forum Installing on a Linux/Unix Server
    Replies: 15
    Last Post: 20 Jun 2015, 03:18 AM
  3. v151 Missing payment modules
    By Cyber Lolita in forum Built-in Shipping and Payment Modules
    Replies: 4
    Last Post: 28 Feb 2015, 09:54 AM
  4. Protx Module Missing in Payment Modules List in my admin
    By edzpgt in forum Addon Payment Modules
    Replies: 15
    Last Post: 24 Jul 2009, 07:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR