Page 4 of 14 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 138
  1. #31
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,883
    Plugin Contributions
    21

    Default Re: "There was a security error when trying to login" - v1.3.8

    You are so right - and now I'm going to go back and reread the list of changes.

  2. #32
    Join Date
    Aug 2007
    Location
    South of France
    Posts
    46
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    I have the same error. I am in progress of comparing and merging old/new version but have a question relative to the database upgrade not the zip files.

    Is there an upgrate script or do we have to build one ourselves ?

    Comparing the old database to the new I have made the following changes:

    Change the Table: authorizenet authorization_type field to varchar 50

    Create tables: Table: nochex_apc_transactions and Table: nochex_sessions
    with this script

    CREATE TABLE `rws_zen_nochex_sessions` (
    `unique_id` int(11) NOT NULL auto_increment,
    `session_id` text collate latin1_general_ci NOT NULL,
    `saved_session` mediumblob NOT NULL,
    `expiry` int(17) NOT NULL default '0',
    PRIMARY KEY (`unique_id`),
    KEY `idx_session_id_zen` (`session_id`(36))
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci AUTO_INCREMENT=1 ;


    CREATE TABLE `rws_zen_nochex_apc_transactions` (
    `nochex_apc_id` int(11) unsigned NOT NULL auto_increment,
    `order_id` int(11) unsigned NOT NULL default '0',
    `nc_transaction_id` varchar(30) collate latin1_general_ci NOT NULL,
    `nc_transaction_date` varchar(100) collate latin1_general_ci NOT NULL,
    `nc_to_email` varchar(255) collate latin1_general_ci NOT NULL,
    `nc_from_email` varchar(255) collate latin1_general_ci NOT NULL,
    `nc_order_id` varchar(255) collate latin1_general_ci NOT NULL,
    `nc_custom` varchar(255) collate latin1_general_ci NOT NULL,
    `nc_amount` decimal(9,2) NOT NULL,
    `nc_security_key` varchar(255) collate latin1_general_ci NOT NULL,
    `nc_status` varchar(15) collate latin1_general_ci NOT NULL,
    `nochex_response` varchar(255) collate latin1_general_ci NOT NULL,
    `last_modified` datetime NOT NULL default '0001-01-01 00:00:00',
    `date_added` datetime NOT NULL default '0001-01-01 00:00:00',
    `memo` text collate latin1_general_ci,
    PRIMARY KEY (`nochex_apc_id`),
    KEY `idx_order_id_zen` (`order_id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci AUTO_INCREMENT=1 ;

    Exported my old database to an sql file and changed all swedish_general_ci to
    latin1 COLLATE latin1_general_ci;

    CREATE DATABASE `mydabasename` DEFAULT CHARACTER SET latin1 COLLATE latin1_general_ci;

    but now when I try to login I get the security error. I will now look at the login files like you mentioned to look for the security token code.

    Maybe I overwrote it by accident.

    Have I missed anything database side ?
    My Favourite desert is zen-tart.

  3. #33
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,616
    Plugin Contributions
    25

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by FromTheRiviera View Post
    I have the same error. I am in progress of comparing and merging old/new version but have a question relative to the database upgrade not the zip files.

    Is there an upgrate script or do we have to build one ourselves ?
    The database upgrade is the easiest bit of all. You simply navigate to www.YOUR_SITE.com/zc_install and make sure that you select the database upgrade option.
    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  4. #34
    Join Date
    Aug 2007
    Location
    South of France
    Posts
    46
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    Thanks I'll try to start again . Didn't know this option existed. Must have gone too fast.
    My Favourite desert is zen-tart.

  5. #35
    Join Date
    Aug 2007
    Location
    South of France
    Posts
    46
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    I just made a fresh install on a copy of my old database but must have missed this option ?

    I have got to the part :
    Upgrade Detection
    Check for Zen Cart™ updates when logging into Admin

    This will attempt to talk to the live Zen Cart™ versioning server to determine if an upgrade is available or not. If an update is available, a message will appear in admin. It will NOT automatically APPLY any upgrades.
    You can override this later in Admin->Config->My Store->Check if version update is available.
    Is this what you are referring to ? If so , I do not think this will upgrade the structure of my database without overwriting the old data.
    Last edited by FromTheRiviera; 2 Dec 2007 at 07:34 PM.
    My Favourite desert is zen-tart.

  6. #36
    Join Date
    Oct 2006
    Posts
    5,481
    Plugin Contributions
    12

    Default Re: "There was a security error when trying to login" - v1.3.8

    It is ALWAYS recommended that you do an upgrade on a testing site, where you can afford to BREAK anything and can just restore it back easily.

    With that said, if you are already doing it on a test site, just go ahead and try the options, if things don't go your way, simply copy the backup files and database back.
    I no longer provide installation support on forum for all my modules. However, if there are real bugs with the modules please feel free to contact me

  7. #37
    Join Date
    Aug 2007
    Location
    South of France
    Posts
    46
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    I finally figured out that there is an sql script in the folder called ZC_INSTALL

    mysql_upgrade_zencart_137_to_138

    I was looking for this option in the installatoion proceedure.

    Would it not be a good idea to put it there ? For newcomers like me who are first time upgraders.

    Thanks for all your help.
    My Favourite desert is zen-tart.

  8. #38
    Join Date
    Jun 2003
    Posts
    33,804
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    When upgrading you need to upload the zc_install directory from the *new* version to your site and run the upgrade procedure ...
    Please do not PM for support issues: a private solution doesn't benefit the community.

    Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

  9. #39
    Join Date
    Aug 2007
    Location
    South of France
    Posts
    46
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    Just ran

    mysql_upgrade_zencart_137_to_138

    and get error

    Table 'mydbname.linkpoint_api' doesn't exist

    What version did this table get created in cause I don't see it in 1.3.8 either.

    Should it not read CREATE TABLE rather than ALTER TABLE ?
    My Favourite desert is zen-tart.

  10. #40
    Join Date
    Jun 2003
    Posts
    33,804
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    That is a warning not an error and can be safely ignored.
    Please do not PM for support issues: a private solution doesn't benefit the community.

    Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

 

 
Page 4 of 14 FirstFirst ... 23456 ... LastLast

Similar Threads

  1. Replies: 6
    Last Post: 6 Nov 2011, 05:26 AM
  2. 1.3.9d "There was a security error when trying to login"
    By noderaser in forum General Questions
    Replies: 1
    Last Post: 17 Aug 2010, 07:26 AM
  3. "There was a security error when trying to login" - v1.3.9c
    By lafhaha in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 13 Jul 2010, 05:39 PM
  4. "There was a security error when trying to login"
    By TurtleDove in forum General Questions
    Replies: 1
    Last Post: 9 Feb 2010, 04:18 AM
  5. Users cannot login after upgrade - "There was a security error when trying to login"
    By rob.chevalier in forum Upgrading from 1.3.x to 1.3.9
    Replies: 19
    Last Post: 9 Jun 2008, 08:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR