Page 23 of 25 FirstFirst ... 132122232425 LastLast
Results 221 to 230 of 241
  1. #221
    Join Date
    Aug 2011
    Location
    North Dakota
    Posts
    34
    Plugin Contributions
    0

    Default Re: Login as Customer module fails on login page

    Quote Originally Posted by swguy View Post
    You'll have to work with your developer to review your installation then. It's impossible for me to know what went wrong.
    Hi SWguy, I have same problem with this module and ZenCart 1.56. I get a store page that the main section is blank white (header, menu, and column shows) but says "Home::Login As Customer". Interesting also, if I refresh that page I get the red banner attached. Name:  AdminTokenExpired.JPG
Views: 160
Size:  25.5 KBBut I wonder if the Master Password module is maybe the root of the problem with version 1.56. I tried to login to my test email address using the master password, which should work on all email addresses, and I get "Error: Sorry, there is no match for that email address and/or password." I also checked my server Error Report and nothing shows up for either module.
    Last edited by NDboots; 4 Jan 2019 at 09:37 PM.

  2. #222
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,973
    Plugin Contributions
    119

    Default Re: Login as Customer module fails on login page

    You get the expired message if you try to refresh the storefront page that you get when you press Place Order in admin.

    Not sure what you guys are doing wrong. Works fine for me in PHP 5.6 and 7.2 with Zen Cart 1.5.6.
    Like I said, you'll have to work with your developer to straighten out what ever is wrong.
    Last edited by swguy; 4 Jan 2019 at 10:34 PM.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  3. #223
    Join Date
    Nov 2010
    Posts
    117
    Plugin Contributions
    0

    Default Re: Login as Customer module fails on login page

    Quote Originally Posted by NDboots View Post
    Hi SWguy, I have same problem with this module and ZenCart 1.56. I get a store page that the main section is blank white (header, menu, and column shows) but says "Home::Login As Customer". Interesting also, if I refresh that page I get the red banner attached. Name:  AdminTokenExpired.JPG
Views: 160
Size:  25.5 KBBut I wonder if the Master Password module is maybe the root of the problem with version 1.56. I tried to login to my test email address using the master password, which should work on all email addresses, and I get "Error: Sorry, there is no match for that email address and/or password." I also checked my server Error Report and nothing shows up for either module.
    This is exactly what I am getting. Depending on what Webbrowser I use, it either shows the *expired token* message, or just a blank page with no log in at all. I uninstalled are reinstalled it several times because I thought I was doing something wrong, but it's the same each time. On different languages it stops showing the customer names and ID.

  4. #224
    Join Date
    Nov 2010
    Posts
    117
    Plugin Contributions
    0

    Default Re: Login as Customer module fails on login page

    [QUOTE=swguy;1352956]You get the expired message if you try to refresh the storefront page that you get when you press Place Order in admin.

    QUOTE]

    HI Scot, I don't refresh anything, this is what I get when I click on Place Order.

  5. #225
    Join Date
    Aug 2011
    Location
    North Dakota
    Posts
    34
    Plugin Contributions
    0

    Default Re: Login as Customer module fails on login page

    Quote Originally Posted by Dustie View Post
    This is exactly what I am getting. Depending on what Webbrowser I use, it either shows the *expired token* message, or just a blank page with no log in at all. I uninstalled are reinstalled it several times because I thought I was doing something wrong, but it's the same each time. On different languages it stops showing the customer names and ID.
    Well, I'm still trying to work out this problem myself. And if the Master Password don't work, for sure the Login as Customer is not going to work either. I just did get my Master Password to work. I went via FTP program and found that even though I reloaded the file 3 times already, it was not the same size file, it was smaller. So I reloaded the file again for a fourth time. Then it showed up the same size. Next I CHMOD the file to 644, even though it said that already. Then I went to my carts home page and hit the login link, in the login window I put my test email address, then stuck in my Master Password, and finally it worked. Make sure you did not load the Master Password file into the Admin area, as it works in the public area. But I still have the same problem with my Login as Customer. So, going to check file sizes and CHMOD on those next.

  6. #226
    Join Date
    Aug 2011
    Location
    North Dakota
    Posts
    34
    Plugin Contributions
    0

    Default Re: Login as Customer module [Support Thread]

    Okay, I just got it to work with ZenCart 1.56. I reloaded all the files, made sure they were CHMOD to 644. I notice the folder in the public area: includes/function is empty for this module. I think the following might of been the real problem I had though: includes/templates/YOUR_CUSTOM_TEMPLATE/templates/tpl_login_as_customer_default.php I put it here: includes/templates/templates/responsive_classic/templates/tpl_login_as_customer_default.php and I did leave it there as that is the template I'm using. But, as an after thought I put a second copy here and now Login as Customer works: includes/templates/template_default/templates/tpl_login_as_customer_default.php
    Last edited by NDboots; 4 Jan 2019 at 11:16 PM.

  7. #227
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    8,973
    Plugin Contributions
    119

    Default Re: Login as Customer module [Support Thread]

    Quote Originally Posted by NDboots View Post
    I think the following might of been the real problem I had though: includes/templates/YOUR_CUSTOM_TEMPLATE/templates/tpl_login_as_customer_default.php I put it here: includes/templates/templates/responsive_classic/templates/tpl_login_as_customer_default.php and I did leave it there as that is the template I'm using.
    That *was* in fact the real problem. You put it in

    includes/templates/templates/responsive_classic/templates/tpl_login_as_customer_default.php

    it should have been in

    includes/templates/responsive_classic/templates/tpl_login_as_customer_default.php
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
    Do you benefit from Zen Cart? Then please support the project.

  8. #228
    Join Date
    Feb 2015
    Location
    UK
    Posts
    13
    Plugin Contributions
    0

    Default Re: Login as Customer module

    Hi,

    I have installed both the Master Password and Login as customer plugins and ran into a slight problem. I can login using the master password however when logging in with the place order button it says that the credentials are wrong.

    I've had a little look and to me it looks like the $pass seems to be looking for MASTER_PASS which does not seem to exist anywhere other than within this module.

    Could it be the issues are because the correct admin password is not being passed to the $pass variable?
    From memory I think a previous version of master password required the password to be entered within the admin rather than using the Admin account passwords, is it still trying to look for this rather than using the dynamic admin passwords.

    Thanks

  9. #229
    Join Date
    Jul 2012
    Posts
    345
    Plugin Contributions
    0

    Default Re: Login as Customer module

    Installed but getting following error when tried to use it. When clicked on Place order button on admin/customers.php It opens new tab and same page with following url
    http://www.domain.com/admin/customer...in_as_customer

    I have uninstalled and installed it again but running into same issue. Zencart version is 1.5.3.

  10. #230
    Join Date
    May 2011
    Location
    Tennessee
    Posts
    348
    Plugin Contributions
    0

    Default Re: Login as Customer module fails on login page

    Does anyone know when Master Password will be compatible with 1.5.6 so Login as Customer Module can be used with 1.5.6?

 

 
Page 23 of 25 FirstFirst ... 132122232425 LastLast

Similar Threads

  1. MultiSite Module Support Thread
    By Gerome in forum All Other Contributions/Addons
    Replies: 2215
    Last Post: 21 Sep 2022, 05:43 AM
  2. v150 Admin New Customer [Support Thread]
    By lhungil in forum All Other Contributions/Addons
    Replies: 34
    Last Post: 4 Nov 2016, 06:20 AM
  3. v150 Minimum Customer Account Information - Support Thread
    By lat9 in forum All Other Contributions/Addons
    Replies: 87
    Last Post: 30 Nov 2015, 04:00 PM
  4. PC Configurator Module [Support Thread]
    By lebrand2006 in forum All Other Contributions/Addons
    Replies: 254
    Last Post: 22 Aug 2012, 03:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR