Page 55 of 55 FirstFirst ... 545535455
Results 541 to 543 of 543
  1. #541
    Join Date
    May 2018
    Location
    Melbourne, Australia
    Posts
    21
    Plugin Contributions
    0

    Default Re: Product Attribute Grid

    Quote Originally Posted by mc12345678 View Post
    That was from a point "silent" protest to the absence of the define as in a default installation TEXT_PREFIX and UPLOAD_PREFIX are the same value. As a result of that fact, for a default installation the above commenting out of code won't hurt anything. It still though doesn't explain the situation of the product not being added to the cart.

    That said, some interim changes I've locally made included a test for FILE_PREFIX being defined and in the previous if statement to verify that TEXT_PREFIX is also defined.

    What should happen here though for the widest compatibility is for the above FILE_PREFIX to be changed to UPLOAD_PREFIX:
    Code:
    } elseif (defined('UPLOAD_PREFIX') && substr($option_id, 0, strlen(UPLOAD_PREFIX)) == UPLOAD_PREFIX) {
                            $option_ref[substr($option_id, strlen(UPLOAD_PREFIX))] = $option_id;
                            $option_id = substr($option_id, strlen(UPLOAD_PREFIX));
    I've just applied this, and tested it with SBA. The product is now correctly added to the shopping cart.

    Many thanks for your help.

  2. #542
    Join Date
    Jul 2012
    Posts
    16,014
    Plugin Contributions
    17

    Default Re: Product Attribute Grid

    Quote Originally Posted by donw View Post
    I've just applied this, and tested it with SBA. The product is now correctly added to the shopping cart.

    Many thanks for your help.
    For clarity though, was a test performed before making that change but after updating the SBA files? Or was that the only change that was made? If it was the only change that was made, did the log file(s) have more to them than just the early warning result of 'FILE_PREFIX' not being defined? Was there some line that indicated a true error not just a warning?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  3. #543
    Join Date
    May 2018
    Location
    Melbourne, Australia
    Posts
    21
    Plugin Contributions
    0

    Default Re: Product Attribute Grid

    Quote Originally Posted by mc12345678 View Post
    For clarity though, was a test performed before making that change but after updating the SBA files? Or was that the only change that was made? If it was the only change that was made, did the log file(s) have more to them than just the early warning result of 'FILE_PREFIX' not being defined? Was there some line that indicated a true error not just a warning?
    I didn't update the SBA files, as I'm sure you are aware, changing multiple things when tracing the cause of a problem is not a good idea. There was only a php warning in the error log before the change. There is no error log generated after the change.

 

 
Page 55 of 55 FirstFirst ... 545535455

Similar Threads

  1. Product Attribute Grid Help - Willing to Pay
    By MM_Dude in forum General Questions
    Replies: 0
    Last Post: 26 Nov 2014, 08:19 PM
  2. Quick Order & Product Attribute Grid...Possible?
    By laurenjj in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 2 Jul 2010, 02:02 AM
  3. Product Attribute Grid!!!
    By runoka in forum Setting Up Categories, Products, Attributes
    Replies: 3
    Last Post: 5 Apr 2010, 05:50 PM
  4. Product Attribute Grid Instructions Possible Paragraph Missing
    By printchic in forum Setting Up Categories, Products, Attributes
    Replies: 0
    Last Post: 8 Aug 2009, 05:54 AM
  5. Help Uninstalling Product Attribute Grid
    By Dr Tweak in forum All Other Contributions/Addons
    Replies: 7
    Last Post: 20 May 2008, 05:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR