Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Join Date
    Nov 2004
    Posts
    45
    Plugin Contributions
    0

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    I've attached a screenshot, it just stayed on this page forever.
    Attached Images Attached Images  

  2. #12
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    Can you open your /cache folder and zip and post the zcInstall log files?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #13
    Join Date
    Nov 2004
    Posts
    45
    Plugin Contributions
    0

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    Thanks, here is the zip file
    Attached Files Attached Files

  4. #14
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    Quote Originally Posted by lennypeng View Post
    Or is there anyway to upgrade directly in PHPmyAdmin?
    If you want to sort out every possible error manually, sure, go ahead. The 137-to-138 sql script is in the sql folder in the zc_install directory.
    You won't have any of the safeties that the installer provides. If it blows up, restore from backup.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #15
    Join Date
    Nov 2004
    Posts
    45
    Plugin Contributions
    0

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    Thanks for your advice. Have you found out what might went wrong given the log file? Cheers

  6. #16
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    The log file hasn't supplied anything obvious.
    Unfortunately I cannot duplicate the problems you're experiencing, so I cannot "fix" anything to be sure it doesn't happen again.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #17
    Join Date
    Jul 2004
    Posts
    8
    Plugin Contributions
    0

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    I was having this exact error! That is, submitting the db 1.3.7 to 1.3.8 upgrade form and having it hang until I quit the browser.

    Running the 'mysql_upgrade_zencart_137_to_138.php' update script line by line through my MySQL client (MySQL server version 5.0.45-community-nt), I found that line 62, which reads...

    INSERT INTO query_builder (query_category, query_name, query_description , query_string) VALUES ('email,newsletters', 'Customers who have never completed a purchase', 'For sending newsletter to all customers who registered but have never completed a purchase', 'SELECT DISTINCT c.customers_email_address as customers_email_address, c.customers_lastname as customers_lastname, c.customers_firstname as customers_firstname FROM TABLE_CUSTOMERS c LEFT JOIN TABLE_ORDERS o ON c.customers_id=o.customers_id WHERE o.date_purchased IS NULL');
    ...was causing the script to hang every time.

    I commented out that line and the upgrade script was able to complete successfully. I then added the query_builder record manually through my MySQL client.

    Hope this helps any that are having a similar issue!

  8. #18
    Join Date
    Mar 2007
    Location
    Louisville, Kentucky, USA
    Posts
    42
    Plugin Contributions
    0

    Default Re: Need help upgrade from 1.3.7 to 1.3.8

    I had the same problem as dim.star. and his solution worked.

    The query_builder insert fails with the error:

    #1364 - Field 'query_keys_list' doesn't have a default value
    Steve Magruder, Freelance Web Programmer
    WebCommons :: Web Programming Services

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. v151 Need to upgrade from PHP 5.4.45 to 5.5 or higher
    By rayw1679 in forum General Questions
    Replies: 10
    Last Post: 30 Mar 2016, 10:26 PM
  2. Replies: 1
    Last Post: 15 Feb 2013, 07:42 AM
  3. v150 Need to re-do my upgrade - but need help!
    By annieh in forum Upgrading to 1.5.x
    Replies: 0
    Last Post: 14 Jun 2012, 01:32 AM
  4. Do i need to upgrade from 1.3.8a?
    By creamcrackers in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 7 Oct 2010, 05:21 AM
  5. Need help with upgrade from 1.3.7 to 1.3.8
    By josee225 in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 7 Sep 2009, 09:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR