Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2008
    Location
    Washington State
    Posts
    240
    Plugin Contributions
    0

    Default USPS extra 3lbs debug issue

    Hi all,

    I made my first sales today.. Just went live last night and I have an issue with the USPS shipping module.

    The product in it's package weighs only .1839 pounds. However, when I add one to my shopping cart and go through checkout I can't see the
    First Class" mail choice. First class can be used up to 13 ounces.

    I turned on the debugger for email and received this:

    Code:
    <RateResponse><Package ID="0"><Error><Number>-2147219434</Number><Source>
    DomesticRatesV2::clsRateV2ValidateWeight;RateEngineV2.ProcessRequest</Source>
    <Description>First Class mail must weigh 13 ounces or less.</Description>
    <HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package>
    <Package ID="1"><Service>PRIORITY</Service><ZipOrigination>98271</ZipOrigination>
    <ZipDestination>98271</ZipDestination><Pounds>3</Pounds><Ounces>3</Ounces>
    <Container>None</Container><Size>REGULAR</Size><Machinable>FALSE</Machinable>
    <Zone>1, local</Zone><Postage>5.70</Postage></Package><Package ID="2"><Service>
    PARCEL</Service><ZipOrigination>98271</ZipOrigination><ZipDestination>98271</ZipDestination>
    <Pounds>3</Pounds><Ounces>3</Ounces><Container>None</Container><Size>REGULAR</Size>
    <Machinable>FALSE</Machinable><Zone>1, local</Zone><Postage>7.34</Postage></Package>
    <Package ID="3"><Service>MEDIA</Service><ZipOrigination>98271</ZipOrigination>
    <ZipDestination>98271</ZipDestination><Pounds>3</Pounds><Ounces>3</Ounces><Container>
    None</Container><Size>REGULAR</Size><Machinable>FALSE</Machinable><Zone>1, local
    </Zone><Postage>3.15</Postage></Package></RateResponse>
    Inside all that code I noticed 3 pounds 3 ounces. Where did that come from? Each product is only .1839 pounds which I have put in during the creation of each product. I have re-checked and it is correct.

    Any idea why it's getting bumped up to 3lbs3oz ?

  2. #2
    Join Date
    Mar 2005
    Location
    United Kingdom
    Posts
    534
    Plugin Contributions
    0

    Default Re: USPS extra 3lbs debug issue

    Try this FAQ on tare weight settings.

  3. #3
    Join Date
    Feb 2008
    Posts
    385
    Plugin Contributions
    0

    Default Re: USPS extra 3lbs debug issue

    It's the built-in tare weight. Just go into Admin - Configuration - Shipping/Packaging and change the small/medium and large tare weights to whatever you want. I have it set as 0 and just add a small handling fee in the shipping module to cover the weight of packaging.
    [FONT="Times New Roman"]Sylvia
    PM at your own risk, I don't check in regularly!
    MamaSylvia.com My ZenCart tutorial
    [/FONT]

  4. #4
    Join Date
    Feb 2008
    Location
    Washington State
    Posts
    240
    Plugin Contributions
    0

    Default Re: USPS extra 3lbs debug issue

    thanks to you both!

    I owe a couple customers a shipping credit.

 

 

Similar Threads

  1. Blank page issue: I can't debug
    By arrow in forum Templates, Stylesheets, Page Layout
    Replies: 5
    Last Post: 5 Mar 2008, 09:15 PM
  2. shipping module is adding extra 3lbs to my orders
    By pglenn in forum Built-in Shipping and Payment Modules
    Replies: 3
    Last Post: 2 Feb 2008, 04:44 AM
  3. USPS Shipping adds 3lbs to cart weight. Problem with USPS or my Zen?
    By Yuchant in forum Built-in Shipping and Payment Modules
    Replies: 2
    Last Post: 17 Oct 2007, 01:02 AM
  4. USPS quote has 3 extra pounds on it
    By diggersf in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 6 Sep 2006, 10:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •