Zen Cart Logo
Forums / General Questions / New members cannot register for shopping cart purchase

New members cannot register for shopping cart purchase

Views: 2,004

Results 1 to 12 of 12
5 Jun 2014, 2:37 AM
#1
dguillory101 avatar

dguillory101

New Zenner

Join Date:
Jun 2014
Location:
Lafayette, LA
Posts:
2
Plugin Contributions:
0

New members cannot register for shopping cart purchase

After several people emailed about a problem, I tried to register myself. The page goes to an error message page (HTTP 500 Internal Server Error) and will not let anyone register.

I recently had my "Welcome" letter updated and that is when the problem seemed to start. I know very little about updating my cart so had my web master do it. Now he tells me he mostly works platforms other than Zen Cart and that I should get someone else or change to what he is working with now.

I would welcome a suggestion to fix the problem, if I could do that myself, or suggestions as to someone else I could contact to fix it.

5 Jun 2014, 2:54 AM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: New members cannot register for shopping cart purchase

Any idea what changes he might have made to your site for that?

5 Jun 2014, 7:05 AM
#3
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: New members cannot register for shopping cart purchase

dguillory101:

I recently had my "Welcome" letter updated and that is when the problem seemed to start. I know very little about updating my cart so had my web master do it. Now he tells me he mostly works platforms other than Zen Cart and that I should get someone else or change to what he is working with now.

I would welcome a suggestion to fix the problem, if I could do that myself, or suggestions as to someone else I could contact to fix it.

Taking a bit of a punt here, but my guess is that when the 'Welcome letter' was updated, the 'web master' (and I'm using that term very loosely) he or she changed one (or more) of the folder (or file) permissions from "775" to "777".

If you don't know how to check or change file permissions I would suggest you contact your web hosting provider, as they will have log files that will tell them exactly what file/folder is causing the problem, as well as having the ability to fix it for you.

It is best if you can check and fix this yourself though as you'll get 'instant' results. Waiting on your webhost could take a day or three.

Cheers
RodG

6 Jun 2014, 3:30 AM
#4
dguillory101 avatar

dguillory101

New Zenner

Join Date:
Jun 2014
Location:
Lafayette, LA
Posts:
2
Plugin Contributions:
0

Re: New members cannot register for shopping cart purchase

Great advice RodG. Since I can't do it myself, I will take your suggestion and contact hosting provider. Thanks...

6 Jun 2014, 4:10 PM
#5
balihr avatar

balihr

Totally Zenned

Join Date:
Oct 2008
Location:
Croatia
Posts:
1,794
Plugin Contributions:
22

Re: New members cannot register for shopping cart purchase

Uhm... Rod, I'm not trying to be a smartass here, but how could the change from "775" to "777" cause a 500? That's basically just MORE permissions, not less. :dontgetit

@dguillory101 - you say there was a change to the Welcome email... What kind of change? Could it be some textual changes? Because, if your "web master" (allow me to quote Rod: and I'm using that term very loosely) didn't escape an apostrophe somewhere in the text, this might result in the error you're getting.
Can you take a look at your includes/languages/english/create_account.php and see if there are any apostrophes that weren't escaped? In case you don't know what I'm talking about:
For example:

define('EMAIL_WELCOME', 'You are now registered at <strong>' . STORE_NAME . '</strong>.');

If you want to use "you're" instead of "you are", the code would need to look like this:

define('EMAIL_WELCOME', 'You\'re now registered at <strong>' . STORE_NAME . '</strong>.');

Notice the backslash in red.
If you want, you can just copy/paste your text here and I'll look into it. (BTW, there might be an override in your template directory, something like includes/languages/english/YOUR_TEMPLATE_NAME/create_account.php - if you have that, then use that file).

Regards,
Leonard

6 Jun 2014, 4:48 PM
#6
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: New members cannot register for shopping cart purchase

balihr:

Uhm... Rod, I'm not trying to be a smartass here, but how could the change from "775" to "777" cause a 500? That's basically just MORE permissions, not less. :dontgetit

That's a perfectly valid question.

This doesn't occur with all servers, only those that have been configured to have 'additional security' that consider folders that are writable by anyone/all as being a security weakness.
It's actually quite a common problem.

Cheers
RodG

6 Jun 2014, 4:58 PM
#7
balihr avatar

balihr

Totally Zenned

Join Date:
Oct 2008
Location:
Croatia
Posts:
1,794
Plugin Contributions:
22

Re: New members cannot register for shopping cart purchase

RodG:

This doesn't occur with all servers, only those that have been configured to have 'additional security' that consider folders that are writable by anyone/all as being a security weakness.

Ah, makes perfect sense - thank you for the clarification. I must admit I haven't had any similar problems with any of my clients - this must be common only with you Aussies... :P Just kidding, of course - I've just learned something new so thank you!

6 Jun 2014, 7:19 PM
#8
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: New members cannot register for shopping cart purchase

balihr:

I've just learned something new so thank you!

Since you appear to be happy to learn new things, I hope you don't mind me saying that although your suggestion about the apostrophe can and will cause a problem, it won't be the cause in this instance.
The reason being is that the apostrophe will cause a PHP error and not a SERVER error.
If/when the server errors no PHP code will be executed at all. On the flipside if the PHP is executed (with or without errors) then the server itself must be functional.

Knowing this difference can save a lot of time, especially when very few hosts will help solve PHP problems, and very few end users can resolve server issues. The exception being is if the server issue is caused by the end user changing folder permissions as being discussed.
Cheers
RodG

6 Jun 2014, 7:26 PM
#9
balihr avatar

balihr

Totally Zenned

Join Date:
Oct 2008
Location:
Croatia
Posts:
1,794
Plugin Contributions:
22

Re: New members cannot register for shopping cart purchase

RodG:

Since you appear to be happy to learn new things, I hope you don't mind me saying that although your suggestion about the apostrophe can and will cause a problem, it won't be the cause in this instance.
The reason being is that the apostrophe will cause a PHP error and not a SERVER error.

Actually, I'm gonna have to disagree on that one... I thought the same so I did a real quick test on a clean 1.5.1 before I posted my initial reply. I just added an apostrophe in the following line:

define('EMAIL_WELCOME', 'We wish to welcome you to <strong>' . STORE_NAME . '</strong>.');

and tried to create an account... I got a 500... Give it a try. :wink:

7 Jun 2014, 8:58 AM
#10
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: New members cannot register for shopping cart purchase

balihr:

Actually, I'm gonna have to disagree on that one... I thought the same so I did a real quick test on a clean 1.5.1 before I posted my initial reply. I just added an apostrophe in the following line:

define('EMAIL_WELCOME', 'We wish to welcome you to <strong>' . STORE_NAME . '</strong>.');

> and tried to create an account... I got a 500... Give it a try. :wink:

Sorry about taking a while to get back to you on this, but as I'm getting old and forgetful and server configurations are forever evolving, I thought I'd give you the benefit of the doubt, so, during the day as I've been working on various zencart stores I've done my best to try to verify this, and so far not a single one of them has given me a '500 Server' error as a result of an apostrophe anywhere in any of the PHP scripts (or its defines). 

I tried it using six different stores on different servers, plus my local development site.  I performed two tests on each, one with the apostrophe placed as/where you described, and again by adding one to the define('HEADING_TITLE', 'Welcome, Please Sign In'); in the login.php file. 

On all cases the result is what I would expect,  namely a blank page, and a php error log file reading like: 

[07-Jun-2014 08:33:27 UTC] PHP Parse error:  syntax error, unexpected T_STRING in /testsite/includes/languages/english/login.php on line 11

On this basis, until/unless someone else can confirm your claims, I'm calling BS on this.  

Cheers
RodG
9 Jun 2014, 1:21 PM
#11
balihr avatar

balihr

Totally Zenned

Join Date:
Oct 2008
Location:
Croatia
Posts:
1,794
Plugin Contributions:
22

Re: New members cannot register for shopping cart purchase

RodG:

I tried it using six different stores on different servers, plus my local development site. I performed two tests on each, one with the apostrophe placed as/where you described, and again by adding one to the define('HEADING_TITLE', 'Welcome, Please Sign In'); in the login.php file.
Why login.php file? That file has nothing to do with the email process, it's just the page elements...

RodG:

On this basis, until/unless someone else can confirm your claims, I'm calling BS on this.

Well, I must say I'm a bit disappointed, especially because of the BS part of your reply...

One thing I find MOST important when approaching any problem is to think outside of the box and try to put myself in a position of the person who doesn't dream in code... I've noticed that almost all developers have a very strict path they walk and they don't even bother to try thinking as regular people. Not everyone's a dev and not everyone can explain the problem they are having as you might expect.

So, when I tested my theory, I tried using Firefox (which I always use). I got a blank screen (standard php parse error, of course). But, Firebug Console was saying HTTP 500. It wasn't my server's custom 500 page so it did get me a bit confused. And, when in doubt, just use Internet Explorer. My proof is attached - 2 screenshots from Firefox and IE11, with one single change to includes/languages/english/create_account.php:

define('EMAIL_WELCOME', 'We wish to welcome you' to <strong>' . STORE_NAME . '</strong>.');

[Attachment no longer available]
[Attachment no longer available]

I rest my case.

Regards,
Leonard

9 Jun 2014, 7:24 PM
#12
lhungil avatar

lhungil

Totally Zenned

Join Date:
Feb 2012
Location:
mostly harmless
Posts:
1,818
Plugin Contributions:
4

Re: New members cannot register for shopping cart purchase

dguillory101:

After several people emailed about a problem, I tried to register myself. The page goes to an error message page (HTTP 500 Internal Server Error) and will not let anyone register.

I recently had my "Welcome" letter updated and that is when the problem seemed to start. I know very little about updating my cart so had my web master do it. Now he tells me he mostly works platforms other than Zen Cart and that I should get someone else or change to what he is working with now.

I would welcome a suggestion to fix the problem, if I could do that myself, or suggestions as to someone else I could contact to fix it.
Have you been able to resolve this issue?

If you have, please post how the issue was resolved so other people potentially encountering a similar issue in the future can benefit from the knowledge!

If not, can you check for the presence of any Zen Cart "debug logs" or any error message logged to the Server's "error log"? Posting the contents of these (using the # / code button) when present may help members of the Zen Cart community further guide towards a resolution.