I've just had this failure where I can get to the main site but not to my admin page.
Downloaded version https://sourceforge.net/projects/zencart/files/v1.5.5e/v1.5.5e.tar.gz dated 03/03/2017
The log shows the following error:
[06-Mar-2017 21:06:39] PHP Parse error: syntax error, unexpected '[' in html/zencart-155e/includes/classes/upload.php on line 205
[06-Mar-2017 21:06:39] PHP Stack trace:
[06-Mar-2017 21:06:39] PHP 1. {main}() html/zencart-155e/myadmin/index.php:0
[06-Mar-2017 21:06:39] PHP 2. require() html/zencart-155e/myadmin/index.php:10
[06-Mar-2017 21:06:39] PHP 3. require() html/zencart-155e/myadmin/includes/application_top.php:171
The issue was in this section
function set_extensions($extensions)
Here's the diff for the fix I tried that seemed to work. HOWEVER, I am not sure what else may or may not break as yet.
--- upload.orig 2017-03-06 21:23:01.000000000 +0100
+++ upload.php 2017-03-06 21:24:07.713163300 +0100
@@ -202,10 +202,10 @@
if (is_array($extensions)) {
$this->extensions = $extensions;
} else {
Yes, I run CentOS 6 with PHP 5.3.x It is supported by RHEL until end of life in 2020.
Yes I could possibly mess about with SCL repos to upgrade PHP but I personally hate doing anything outside of standard - less chance of breakage that way. There are probably many who may not be ALLOWED to mess with their servers due to service contracts etc etc, or are bound by what their hosting provides. So my guess is that PHP 5.3.x will be around for a few more years yet, like it or not.
I would certainly call this a bug and it should be fixed - a php check would do it I guess.
I just hope their are no more gotchas... I am no coder and wasted a good deal of time on this.
B. Rgds
John