Installation - Requirements

From Zen Cart(tm) Wiki
Revision as of 20:49, 28 September 2013 by DrByte (talk | contribs)
Jump to: navigation, search


Zen Cart v1.3.x (v1.3.x is now officially no longer supported)

The minimum suggested server requirements for running Zen Cart® v1.3.x are:

  • PHP 4.3.2 or higher (see compatibility list below)
  • Apache 1.3.x
  • MySQL 3.2x or higher
  • Register Globals may be on or off
  • PHP Safe_Mode = off (recommended)

Zen Cart v1.5.x

The minimum server requirements for running Zen Cart® v1.5.x are:

  • PHP 5.2.14 or higher, or PHP 5.3.5 or higher 5.3.x version. Specifically, you should be using the latest PCI Compliant version as per PCI Standards.
  • Apache 2.x or newer (Specifically the latest PCI Compliant version)
  • MySQL 5 or higher (again, use a PCI Compliant version) (will work with MySQL 4.1.3)
  • Keeping these components up-to-date is recommended for PCI Compliance and general overall security reasons.

PHP Note

While the following are deprecated (obsolete) since PHP 5.4, if you're using PHP 5.3 or older, you should have them set to off:

  • Register Globals off
  • PHP Safe_Mode = off


Many shipping and payment modules require CURL to be installed and compiled into PHP, along with OpenSSL support.
Support for HTTPS may be required depending on the payment methods being accepted. The use of SSL during account creation and checkout is recommended. Once SSL is configured and enabled in your store, Zen Cart® will automatically activate it on screens related to Login, My Account and Checkout.
If you are running on a Unix/Linux host with PHP running as CGI, you may have some difficulties. In Linux, unless your host is skilled at configuring PHP in "suPHP" mode, it is recommended to use PHP as an Apache module, not as a CGI app, unless you have server-level control of configuring the CGI options and advanced knowledge of tuning the server to function optimally.
MySQL 4.1.x and PHP4 
This combination is not recommended. MySQL 4.1.x uses an encryption scheme that is not 100% supported by PHP4 on older servers, so may not work with Zen Cart® unless your host has upgraded their support for compatibility between the two systems.
MySQL 5 
MySQL 5 has some tighter constraints on various SQL statement constructs. Zen Cart® v1.2.x does not work in a MySQL5 environment. Zen Cart® v1.3.9, and newer, works fine with MySQL5.

PHP Version Compatibility

Zen Cart® v1.3.x+ with a PHP version lower than 4.3.2 will result in problems with maintaining sessions. Zen Cart v1.5.0 and newer will NOT work on PHP4.
Zen Cart® v1.3.7 and older
Works only on PHP4
Zen Cart® v1.3.8 
Best to use PHP 4, but can go as high as PHP 5.2.x.
Zen Cart® v1.3.9 
Can use PHP4 but PHP5 is recommended. Use PHP 5.2.3 or newer, or PHP 5.3.2 or newer 5.3.x. PHP 5.4 not supported.
Zen Cart® v1.5.0 
Use PHP 5.2.14 or newer, or PHP 5.3.5 or newer 5.3.x; DO NOT USE older than PHP 5.2.3 (no PHP4)
Zen Cart® v1.5.1 
Use PHP 5.2.14 or newer 5.2.x, or PHP 5.3.5 or newer 5.3.x.
Zen Cart® v1.6.0 
Use PHP 5.3.x (minimum 5.3.5) or PHP 5.4.x.