Zen Cart Logo
Forums / General Questions / about config file

about config file

Locked

Views: 1,425

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
29 Sep 2008, 4:31 PM
#1
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

about config file

I keep getting this error message and no matter what I do it won't go away and stay away.

I have gone into the file and changed it to 644, 444 and the host has changed it to 400 and the error stays away for a day, maybe less, then it is back again.

Warning: I am able to write to the configuration file: /home/fantasie/public_html/market/includes/configure.php. This is a potential security risk - please set the right user permissions on this file (read-only, CHMOD 644 or 444 are typical). You may need to use your webhost control panel/file-manager to change the permissions effectively. Contact your webhost for assistance. See this FAQ

29 Sep 2008, 7:38 PM
#2
fairestcape avatar

fairestcape

Totally Zenned

Join Date:
Mar 2008
Location:
Cape Town & London (depends on the season)
Posts:
2,957
Plugin Contributions:
0

Re: about config file

When the error comes back, has the CHMOD somehow reverted to 644?

30 Sep 2008, 2:53 AM
#3
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: about config file

well this and other errors started taking over my entire server so had host move us to a new one because everything they did was to no avail. Things are finally straightening out--I hope.

The error comes up, I have changed it to 644 (manytimes it is already that cdmod), in both ftp agent and c-panel direct file. The host has done the same they have changed it to 444 when it is set to 644 and even 400 and the error goes away then comes back.

When it comes back you go back and check the file and it is correctly chmodded yet the store throws that error saying it needs reset.

Right now they have removed a cron job they themselves set to make it stay put and so far it is gone, but usually it comes back. I have even replaced the file with a new one and still...lol

hopefully they have it fixed, as I told them it had to be a setting they did on their end when trying to get rid of the various error messages and forgot to reset, on their end. Moving to a new server with fresh settings seems to have helped, we shall see.

6 Oct 2008, 7:45 AM
#4
bsgtackle avatar

bsgtackle

New Zenner

Join Date:
Jan 2008
Posts:
3
Plugin Contributions:
0

Re: about config file

fairestcape:

When the error comes back, has the CHMOD somehow reverted to 644?

Im experiencing this problem right now. Any ideas?

6 Oct 2008, 4:00 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: about config file

Talk to your hosting company about why it's changing on you.

7 Oct 2008, 12:45 AM
#6
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: about config file

bsgtackle:

Im experiencing this problem right now. Any ideas?

I don't know what to tell you. They finally had to move me to another server, much to their dismay I might add.

It has not done it since nor have any of the other errors that were plauging my entire server/ shop and forums has returned ---after nearly the entire month of no access but read only.

Contact your host to see if they did any server changes/updates and if you chmod the file through ftp then try to do it through c-panel or whatever administration panel the host has provided for you to access your files with.