Zen Cart Logo
Forums / General Questions / Please urgent help needed

Please urgent help needed

Locked

Views: 968

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
10 Oct 2008, 12:07 PM
#1
kasnah36 avatar

kasnah36

New Zenner

Join Date:
Mar 2007
Posts:
28
Plugin Contributions:
0

Please urgent help needed

Hi there

please help me fix my website, this is my domain name spoilurpets.com, it is not working at all, there must be something that changed in the script and i am not aware of.
i did not do any changed recently! i wonder what happened.

this is error message will get in you try to go to the website.

i will send some money to who ever help me fix it via paypal.

thank you

Warning: main(includes/application_top.php) [function.main]: failed to open stream: No such file or directory in /home/urtkkcom/public_html/index.php on line 23

Warning: main(includes/application_top.php) [function.main]: failed to open stream: No such file or directory in /home/urtkkcom/public_html/index.php on line 23

Fatal error: main() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/urtkkcom/public_html/index.php on line 23

10 Oct 2008, 12:27 PM
#2
fairestcape avatar

fairestcape

Totally Zenned

Join Date:
Mar 2008
Location:
Cape Town & London (depends on the season)
Posts:
2,957
Plugin Contributions:
0

Re: Please urgent help needed

No need to panic... and you don't need to offer money.

This is a common error message and is reporting an error in your application_top.php file.

Either the file is missing, or it has an error in it that is preventing it from loading.

It is probably a very small error - possibly an SPACE before the opening <?php tag...

...or a similar error at the END of the file, with a SPACE after the closing ?> tag.

Best solution is to FTP a fresh copy of appplication_top.php to your includes folder. See if that helps.

15 Oct 2008, 1:36 AM
#3
kasnah36 avatar

kasnah36

New Zenner

Join Date:
Mar 2007
Posts:
28
Plugin Contributions:
0

Re: Please urgent help needed

Hi fairestcape

unfortunately, what you suggested did not solve the problem!
I opened the file to see if there is space where you said, but everything is where it should be.
i FTP an old back up i did 2 months ago and it did not help either.

Can you please help, i am getting frustrated with this issue.

thank you

15 Oct 2008, 7:37 AM
#4
fairestcape avatar

fairestcape

Totally Zenned

Join Date:
Mar 2008
Location:
Cape Town &amp; London (depends on the season)
Posts:
2,957
Plugin Contributions:
0

Re: Please urgent help needed

This is a problem relating to the php files, not your database. And furthermore (until proved otherwise), is not a problem with your template php files.

There are TWO main things you need to do now.

  1. Make a BACKUP of all your files in the "includes" folder... everything - including all the sub-directories etc. Easiest way to do this is to do a "reverse FTP" - from your server, to your hard drive. Make sure you use the AUTO mode in the FTP transfer, so both ASCII and BINARY files are correctly transferred.

  2. FTP a FRESH COPY of the "includes" folder TO the server - to over-write the entire includes folder on the server. Do this from an original set of the Zencart version you are using.

This should fix the problem. You will then (bit by bit) re-FTP your CUSTOM TEMPLATE folders and files to the server, to re-instate your original design. The STYLESHEETS will be an important component to change back (from your backup copy).