Zen Cart Logo
Forums / Addon Shipping Modules / UPS Shipping - not working (UPS-XML addon)

UPS Shipping - not working (UPS-XML addon)

Locked

Views: 14,293

Results 21 to 31 of 31
This thread is locked. New replies are disabled.
24 Oct 2008, 12:10 AM
#21
rstevenson avatar

rstevenson

Totally Zenned

Join Date:
Nov 2006
Location:
Dartmouth, NS Canada
Posts:
2,400
Plugin Contributions:
0

UPS Shipping - not working (UPS-XML addon)

Strange but true! Setting the zone to none gets me a green light. But what are the implications?

But I still get an error contacting the UPS servers. I'm beginning to think I'm fighting two overlapping problems, one somewhere in the initial setup, which is giving me the yellow light, and the other is a problem with the account at UPS -- proabably one or more of the key, password or username is incorrect. I've gotten all the info from the site owner through the site designer, so something may have been lost in translation. I'll double check with them.

Thanks for sticking with me during this. Better to have two heads butting against a wall than just one. The wall will fall down sooner that way. :laugh:

24 Oct 2008, 12:24 AM
#22
rstevenson avatar

rstevenson

Totally Zenned

Join Date:
Nov 2006
Location:
Dartmouth, NS Canada
Posts:
2,400
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

Moments later, after reading the right page in The Book... ...

The yellow button appears for any shipping module when you have a shipping zone set. It just indicates that that particular module will appear only for customers in that zone. Setting it to "none" means the module appears for all users, and therefore turns the light to green. In this case, that's okay, so I'll leave it set to none.

Now on to the problem of connecting to UPS, since I also confirmed my access key, password and username are all correct.

[sigh]

Rob

24 Oct 2008, 2:35 AM
#23
breck avatar

breck

Zen Follower

Join Date:
Sep 2007
Posts:
106
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

If your key was incorrect, it tells you.
I tried it by changing the last letter in my key.

I installed the ups xml on my other store just now and works ok.

I am thinking that possibly you might have a file missing or in the wrong directory.

Might want to double check and maybe re-upload. Could be corrupt file.

Did you remember that the folder "catalog" should be changed to match your store directory, or copy the "admin" & "includes" folders both over to the same folders.

24 Oct 2008, 1:22 PM
#24
rstevenson avatar

rstevenson

Totally Zenned

Join Date:
Nov 2006
Location:
Dartmouth, NS Canada
Posts:
2,400
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

Thanks,

I FTP most carefully. I never just drag a folder of folders to upload. I always drill down and upload file by file. Tedious, but guaranteed to work. So yes, the files are where they should be and they are all in good condition. I checked by opening them each over the FTP connection.

I had yet another look at the instructions in the Readme file for the module, where he explains how to enable logging. I made some changes to the log file path in hopes of getting it working. Not yet.

One curious note on that. The author says that after you set up logging, "Your request/response will eventually show up there." Eventually? Is there latency in logging? Seems odd.

Rob

24 Oct 2008, 1:27 PM
#25
rstevenson avatar

rstevenson

Totally Zenned

Join Date:
Nov 2006
Location:
Dartmouth, NS Canada
Posts:
2,400
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

Ahhhhh!!!!! Success!

Well, not quite. But after one further change to the path for the log file I got it working. So I now have an error which actually tells me what's wrong. It's the domain cert which is not verifying at UPS.

I remember way back at the beginning of this process I mentioned to the site owner that the UPS docs seemed to imply you needed a cert for the shipping module itself, or something like that. I'll have to go find that reference now.

Strange are the ways of the web.

Thanks for all the help breck. You may not think you helped, but you kept reassuring me there was a way out and that helps a lot, believe me. :bigups:

Rob

And here's the error, in case it makes sense to anyone here...
Error from cURL: Error [60]: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
UPS RESPONSE:

24 Oct 2008, 8:46 PM
#26
breck avatar

breck

Zen Follower

Join Date:
Sep 2007
Posts:
106
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

Don't understand the cert. part.

Thinking maybe try getting the access key again.

I had to get UPS to email me a key and then when you go to get the access key, you have to use the key from the email to get the access key.

You do it the same way?

24 Oct 2008, 11:06 PM
#27
rstevenson avatar

rstevenson

Totally Zenned

Join Date:
Nov 2006
Location:
Dartmouth, NS Canada
Posts:
2,400
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

One final stumbling block removed...

Way down in the upsxml.php file (the one in the admin/modules/shipping folder), down at line 655, there is a note that if you get the error I was getting about the cert not being recognized, you uncomment that line and all would be well. And it was, and it is.

The module now works.

Rob

25 Oct 2008, 2:17 AM
#28
breck avatar

breck

Zen Follower

Join Date:
Sep 2007
Posts:
106
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

Cool.

Congrats...

5 Dec 2009, 2:19 PM
#29
jabbawest avatar

jabbawest

Zen Follower

Join Date:
Oct 2009
Location:
Texas
Posts:
197
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

rstevenson:

One final stumbling block removed...

Way down in the upsxml.php file (the one in the admin/modules/shipping folder), down at line 655, there is a note that if you get the error I was getting about the cert not being recognized, you uncomment that line and all would be well. And it was, and it is.

The module now works.

Rob
I know this is old news but, I've been looking for a fix for the exact same error and your solution worked!

Finally, I can move on! :clap:

Thanks Rob,

Stephen

4 May 2010, 11:06 AM
#30
cpaesano avatar

cpaesano

New Zenner

Join Date:
May 2010
Posts:
1
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

Hi Rob and Stephen:

I know it has been a long time since you guys wrote on this post. I am using Zen Cart v1.38 and installed UPS XML module also. The module is working fine. I registered with UPS and got the TEST MODE ACCESS KEY. Now, I need to obtain the production access key from UPS. But, I don't know how to get Scenario 1 that UPS is asking for. UPS gives me the following data entry to run this scenario:

Consignee Name: Consignee Test 1
Consignee Address: 1000 Consignee Street
Consignee City: Allanton
Consignee State: MO
Consignee (destination) Zip: 63001
Weight (lb): 1500
Prepaid/Collect: P (prepaid)
Class: 92.5
NMFC: 116030 sub 1

I don't know how to enter the last three data fields because the module does not have entries for these.

Based on this info, UPS wants to provide the results for:

Pickup confirmation Number: ?
Bill of Lading: ?
Total Freight Charges: ?

Any ideas? Or this module was built before UPS demanded production access keys?

Thanks in advance for any answers.

Carlos

20 Aug 2010, 2:24 AM
#31
jacdesigner avatar

jacdesigner

Zen Follower

Join Date:
Jun 2005
Location:
Austin, Texas, US
Posts:
205
Plugin Contributions:
0

Re: UPS Shipping - not working (UPS-XML addon)

I experienced similar errors after upgrading Zen Cart and reinstalling some modules. Uncommenting the 2 lines (near line 653 and 655) worked great. The UPS rates are now displaying again. THANK YOU ALL.