Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Transferring site ERROR

Transferring site ERROR

Locked

Views: 2,029

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
21 Oct 2008, 7:05 PM
#1
95_boyz avatar

95_boyz

New Zenner

Join Date:
Oct 2008
Location:
Laie, Hawaii - Provo, Utah
Posts:
26
Plugin Contributions:
0

Transferring site ERROR

I get this error message when transferring my site to another host:

1146 Table 'startswapping.configuration' doesn't exist
in:
[select configuration_key as cfgkey, configuration_value as cfgvalue from configuration]

Anyone got any idea as to what this means? I know it has to do something with the database info (either old database or new one) but I have no clue about databases. If you've seen this before and know a quick fix, please reply. Any help would be much appreciated!!!

21 Oct 2008, 9:07 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Transferring site ERROR

Did your old site have a DB_PREFIX value different than what you've got on your new site? Check your configure.php files for the DB_PREFIX setting.

21 Oct 2008, 11:43 PM
#3
95_boyz avatar

95_boyz

New Zenner

Join Date:
Oct 2008
Location:
Laie, Hawaii - Provo, Utah
Posts:
26
Plugin Contributions:
0

Re: Transferring site ERROR

DrByte:

Did your old site have a DB_PREFIX value different than what you've got on your new site? Check your configure.php files for the DB_PREFIX setting.

It looks like the prefix from my old site was different. Do I need to go through the transfer process all over again and change DB to what my old prefix was?

22 Oct 2008, 3:05 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Transferring site ERROR

If you edit the 2 configure.php files on your new site so that the DB_PREFIX matches the DB_PREFIX from the old site, that should be sufficient.

22 Oct 2008, 4:03 AM
#5
95_boyz avatar

95_boyz

New Zenner

Join Date:
Oct 2008
Location:
Laie, Hawaii - Provo, Utah
Posts:
26
Plugin Contributions:
0

Re: Transferring site ERROR

DrByte:

If you edit the 2 configure.php files on your new site so that the DB_PREFIX matches the DB_PREFIX from the old site, that should be sufficient.

I think with GoDaddy, they automatically give you some kind of prefix prefix (usually account name). I'll give it a go.

22 Oct 2008, 4:08 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Transferring site ERROR

Many auto-installers choose "zen_". Doesn't matter what they selected. The key is what EXACTLY is ALREADY in YOUR old files ... since that's the prefix that was used to access the tables ALREADY in the database you exported.

In a perfect world, no prefix would be used, since prefixes only cause confusion. Sadly, cheap hosting companies which offer only one database make the use of prefixes required in those isolated cases. Thus the option exists.