Zen Cart Logo

PayPal (Phillipines)

Locked

Views: 763

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
22 Oct 2008, 3:31 PM
#1
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

PayPal (Phillipines)

I have a client using paypal - they are in the Phillipines.

They have somehow messed up their paypal and need to get it fixed.

When I am go to admin, enter their PDT, then select UPDATE I get an error message (406 I believe) that says admin/modules.php does not exist on this server.

I checked the admin files in ftp and the file is there - I even uploaded a fresh copy of that file and still get the error.

Any suggestions where to look next?

Tina

23 Oct 2008, 2:22 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: PayPal (Phillipines)

Their server probably has a mod_security rule that's flagging something submitted in the parameters on that page, thus throwing the 406 error.

You can temporarily get around it by adding the following to the /admin/.htaccess file (create one if it doesn't already exist):```
<IfModule mod_security.c>

SecFilterEngine Off

SecFilterScanPOST Off
</IfModule> ``` If that doesn't make it work, try removing the # If that doesn't work, you'll have to check the server's errorlogs for the specific reason for the 406, and then talk to the server administrator (hosting company) to fix it.
23 Oct 2008, 4:05 AM
#3
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: PayPal (Phillipines)

Dr.Byte,

Thanks,
I will try it and post back.

Tina

23 Oct 2008, 4:33 AM
#4
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: PayPal (Phillipines)

I'm back! That sure fixed the problem in admin - now getting same error on catalog side when trying to make a purchase.

Tina

23 Oct 2008, 7:10 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: PayPal (Phillipines)

If it's the same error, then you need to talk to the hosting company.
You need to identify which mod_security rule is causing the problem, and have them turn it off.
Or maybe they can help you disable that one rule using another .htaccess command.
You should be able to identify the rule via the server's errorlog.

In the meantime, you could do a similar .htaccess edit in the root of your store folder. Just be mindful that you're forcing off all the security protection offered by mod_security.

23 Oct 2008, 2:20 PM
#6
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: PayPal (Phillipines)

Dr. Byte

Thanks for the help ~ all working fine now!

Tina