Forums / Templates, Stylesheets, Page Layout / Unable to Login in Admin Section

Unable to Login in Admin Section

Locked

Views: 3,268

Results 1 to 12 of 12
This thread is locked. New replies are disabled.
24 Oct 2008, 2:45 AM
#1
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Unable to Login in Admin Section

Hi i've just completed a first install of zencart.
I am unable to login to the Admin panel even though i know my username and passwords are correct.

I have tried resending my password also and running the following script

DELETE FROM admin WHERE admin_name = 'Admin'; INSERT INTO admin (admin_name, admin_email, admin_pass, admin_level) VALUES ('Admin', 'admin@localhost', '351683ea4e19efe34874b501fdbf9792:9b', 1);

This runs succesfully. I can see in the server database that my username has been changed to Admin but I am still unable to login.

The server company seem to think everything is working ok.

Please help - i've spent 2 full days on this and it's driving me nuts!

Thanks

Craig

24 Oct 2008, 6:35 PM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to Login in Admin Section

Are you able to login to the Shop?

The idea being if you cannot login to either, then it could be your secure settings ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

25 Oct 2008, 1:16 AM
#3
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Re: Unable to Login in Admin Section

Hi
No i am unable to login to shop.
I did chose to not enable SSL on the installation. My server company also tried logging in from my server with no luck either. I've also tried logging in from other PC's turning firewalls off and deleting cookies etc.
Did you know if there is any way of checking what the secure settings are selected to in my server database?

25 Oct 2008, 1:29 AM
#4
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to Login in Admin Section

On your server, you have two configure.php files:
/includes/configure.php
/admin/includes/configure.php

If you could post those, from the server, without your username and password, perhaps we can see something that is not configured correctly ...

How did you install Zen Cart?

And I am assuming you installed Zen Cart v1.3.8a ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

25 Oct 2008, 3:01 AM
#5
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Re: Unable to Login in Admin Section

Hi I really appreciate your offer of help.
Sorry i'm having trouble attaching the .php (downloading as php.txt) files to this message. When I click the attach button above this message and click upload to upload the .php files from my desktop (where i have downloaded them to) i get an invalid file message. Sorry about this but any ideas on this one first?

25 Oct 2008, 4:29 AM
#6
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to Login in Admin Section

You could load the file with cut and paste as CODE ... one per post ...

Just be sure you are getting the current files from the server and that you remove your username and password at the bottom of the files ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

25 Oct 2008, 6:11 AM
#7
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Re: Unable to Login in Admin Section

I've opened the files in word and zipped them, putting xxxx where my name and password is - hope this is ok.

I installed zencart by uploading all the files to my server and by following the FAQ tutorial installation instructions from this site.

Thanks

Craig

29 Oct 2008, 12:24 PM
#8
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Re: Unable to Login in Admin Section

Hello - anyone out there able to help me on this. I've tried deleting and reinstalling plenty of times. I've also tried everything I could find in days of trawling through the web. I can see my shop but I am still unable to log in to admin to change anything.
Please help me

29 Oct 2008, 3:41 PM
#9
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to Login in Admin Section

Based on those files, I cannot get your Catalog nor your Admin to load ...

Note: be sure if you edit files that you use a valid TEXT editor and not a Word Processor like Microsoft Word as that will break your files ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

30 Oct 2008, 12:39 PM
#10
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Re: Unable to Login in Admin Section

Hi
I've posted the two files as text below
Thanks
Craig

<?php /** * @package Configuration Settings circa 1.3.8 * @copyright Copyright 2003-2007 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 */ /*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // Main webserver: eg-http://www.your_domain.com - // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com // HTTP_CATALOG_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_CATALOG_SERVER is your Secure webserver: eg-https://www.your_domain.com /* * URLs for your site will be built via: * HTTP_SERVER plus DIR_WS_ADMIN or * HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or * HTTP_SERVER plus DIR_WS_CATALOG or * HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG * ...depending on your system configuration settings * * If you desire your *entire* admin to be SSL-protected, make sure you use a "https:" URL for all 4 of the following: */ define('HTTP_SERVER', 'http://www.imagocollections.com.au'); define('HTTPS_SERVER', 'https://www.imagocollections.com.au'); define('HTTP_CATALOG_SERVER', 'http://www.imagocollections.com.au'); define('HTTPS_CATALOG_SERVER', 'https://www.imagocollections.com.au'); // Use secure webserver for catalog module and/or admin areas? define('ENABLE_SSL_CATALOG', 'false'); define('ENABLE_SSL_ADMIN', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_ADMIN', '/cataloge/admin/'); define('DIR_WS_CATALOG', '/cataloge/'); define('DIR_WS_HTTPS_ADMIN', '/cataloge/admin/'); define('DIR_WS_HTTPS_CATALOG', '/cataloge/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_ADMIN', '/clientdata/n5200-2-dynamic/i/m/imagocollections.com.au/www/cataloge/admin/'); define('DIR_FS_CATALOG', '/clientdata/n5200-2-dynamic/i/m/imagocollections.com.au/www/cataloge/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_SERVER', 'mysql-3.imagocollections.com.au'); define('DB_SERVER_USERNAME', 'XXXXXXXXX'); define('DB_SERVER_PASSWORD', 'XXXXXXXXX'); define('DB_DATABASE', 'cartdb_imagocollections_com_au'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'db'); // for STORE_SESSIONS, use 'db' for best support, or '' for file-based storage // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/clientdata/n5200-2-dynamic/i/m/imagocollections.com.au/www/cataloge/cache'); // EOF <?php /** * @package Configuration Settings circa 1.3.8 * @copyright Copyright 2003-2007 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 */ /*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com define('HTTP_SERVER', 'http://www.imagocollections.com.au'); define('HTTPS_SERVER', 'https://www.imagocollections.com.au'); // Use secure webserver for checkout procedure? define('ENABLE_SSL', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_CATALOG', '/cataloge/'); define('DIR_WS_HTTPS_CATALOG', '/cataloge/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/'); define('DIR_WS_PHPBB', '/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', '/clientdata/n5200-2-dynamic/i/m/imagocollections.com.au/www/cataloge/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/'); define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_SERVER', 'mysql-3.imagocollections.com.au'); define('DB_SERVER_USERNAME', 'XXXXXXXXXX'); define('DB_SERVER_PASSWORD', 'XXXXXXXXXX'); define('DB_DATABASE', 'cartdb_imagocollections_com_au'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'db'); // for STORE_SESSIONS, use 'db' for best support, or '' for file-based storage // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/clientdata/n5200-2-dynamic/i/m/imagocollections.com.au/www/cataloge/cache'); // EOF
30 Oct 2008, 2:12 PM
#11
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to Login in Admin Section

Try running this one more time in phpMyAdmin for your database:

DROP TABLE IF EXISTS admin;
CREATE TABLE admin (
  admin_id int(11) NOT NULL auto_increment,
  admin_name varchar(32) NOT NULL default '',
  admin_email varchar(96) NOT NULL default '',
  admin_pass varchar(40) NOT NULL default '',
  admin_level tinyint(1) NOT NULL default '1',
  PRIMARY KEY  (admin_id),
  KEY idx_admin_name_zen (admin_name),
  KEY idx_admin_email_zen (admin_email)
) ENGINE=MyISAM;
INSERT INTO admin VALUES (1, 'Admin', 'admin@localhost', '351683ea4e19efe34874b501fdbf9792:9b', 1);

This will make the login:
Admin
admin

When you get in, be sure to go to the Tools ... Admin Settings ... and set your email and password for this ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

2 Nov 2008, 6:57 AM
#12
craig_robbo avatar

craig_robbo

Zen Follower

Join Date:
Oct 2008
Posts:
109
Plugin Contributions:
0

Re: Unable to Login in Admin Section

I ended up paying the server company to install it for me. Really sorry to waste your time - really appreciated your help though.